Search the Community

Showing results for tags 'voltage input'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 36 results

  1. Hey there forum guru's!!! I am trying to read through the manuals for an NX-HAD401 High Speed Analog Input Card.  It is not very clear as to where you assign your variable in order to grab a channels analog input value.  Can you point me in the right direction? I am thinking it is in the "Analog Input Values 1 to 10" and if so why is it set up as an array?  Is it because it takes the average of the samplings and uses the result as the channels input value? I am sure I will have more questions but this may clear up a few.
  2. IC200ALG264 Analog Input module

    Hello all, Thanks for the forum which has provided me with a lot of help overtime. I'm posting my first thread since I can't seem to find an answer to my issue. I'll quickly explain the situation: I'll be installing a RTD sensor to a GE Fanuc IC200ALG264 analog input module using a 4-20mA converter. Everything is fine except I can't seem to understand the polarities of the Fanuc inputs. I'll explain better: the module has an IC200CHS022 for the terminals, 15 terminals total, and the manual is reporting a "number" and a "connection" for each terminal. Now, the "number" seems to correspond to the visible pin of the terminal. But the positive and negative symbols are represented on the "connection", which I can't seem to wrap my head around what it means. Attached are abstracts from the manual and a photo of the terminals. Please tell me where to connect positive and negative outputs of the 4-20mA converter. Thank you. Terminals Table Terminals drawing Terminals photo (front)
  3. E-Designer

    I have E-Designer 7.52 Build 344 installed on 3 windows 7 laptops the 2 that the problem is on are Pro 64 and the 1 thats working is Home Premium 64 but I seem to recall having this problem on the the Home one 9 years ago and getting it sorted but cant remember how The problem In Alarms,  Alarms New Alarm Alarm text: When typing cursor stays at left side and can only be moved to the right by the arrow key then jumps to left side after letter is pressed or you can type in reverse Signal:        Typing works normal OK:             Entry is not valid ;May not be blank Copy: Ok: Same result Properties:Ok:Same again Is there anyone who can help me with this as the laptop that works is on its last legs Thanks  
  4. Hello! I am new at PLC programming. I am using TM221CE16R PLC with TM3AI8 analog input module and SoMachine Basic v1.6. I am trying to scale analog input value. I am using 4-20 mA pressure sensor. I managed my wiring so that I get raw values in SoMachine Basic. But I don't know how to scale these values to usable values. My sensor works in range 0 - 16 bar. What is best way to get values? Is it PID function block or multioperand function block using equations to get range 0 - 16? I will appreciate your help.   Thanks in advance!
  5. I'm using simple function block, one input and one output, like in this example: Problem I have is how to call function block and use inverted (NOT) value , ie instead 5.01 I need to use NOT (5.01) . Of course I could create new symbols that are inverted values of actual inputs but i'm trying to avoid that, number of addresses is significant.
  6. Hi all,  I am in the process of doing a project for some school work and need to do a SWOT analysis of the latest modular PLCs from Mitsubishi (R series), Siemens (S7-1500) and Allen Bradley (ControlLogix).  So I thought what better way than to ask the people on what they think are the pros and cons of each! Thanks for your responses in advance!
  7. hello everyone , I am involved in the development of an industrial  product. It has a 24 V On / OFF  output signal which will be read by a PLC digital input. It could be Allen Bradley / Siemens .  Can anyone tell me what would be the approximate values of the internal pull ups and pull downs? where can i find this? Thank you for all the help.  Regards Sha  
  8. This is a bizarre one... CompactLogix, 1769-IF8 with 1492-AIFM8-F-5 wiring system. My client has reported several instances where one of his flow rate displays is frozen at its maximum value.  Each time, I have gone to the site, found that the value in the analog input tag is at full scale, and measured more than 20mA at the input - as much as 28mA!  I measure it using a clamp-on meter and I measure it at the input module (1769-IF8) and the external, pre-wired terminal block (1492-AIFM8-F-5).  I cycle power to the PLC.  No change.  I cycle power on the transmitting device.  No change.  I disconnect and reconnect the input (signal wire at the module or the terminal block) and everything goes back to normal.  This has happened on multiple channels on multiple input modules and with two different types of transmitters. I didn't install this system, but it seems to have been done properly and it had been running fine for many years.  These problems just started happening out of the blue. Has anyone out there had any similar experience?  This is a new one for me after more than 25 years in the business.
  9. Analog Input Addressing

    Hello Everyone, This is first time i am using Omron's CX-Programmer. PLC-  CP1L-EM40DT1-D I have 2 built in analog input of 0-10V on PLC Board. I want to know the default resolution, Data Type and Register address to detect analog Input for my further programming. Please Help me with these...
  10. Best Practice Rack 0

    Is there any reason not to have input and output modules on the same rack as the processor and Ethernet cards? We have RIO’s and sometimes have networking outages, I want to move critical IO to Rack0 the same rack as the processor, is this bad practice?  I've seen architecture for BMS that only have Ethernet cards and processors in Rack 0... 
  11. PLC Not fast enough?

    Hello, I used a Schneider Electric SR3B261B PLC to create a trivia machine (as I call it).  Basically 20 buttons that let contestants ring in to trivia.  There is a display that shows the number of the person who rang in.  It works pretty well unless people press the buttons at exactly the same time.  Then it shows 2 results at the same time.  Usually resulting in a display of 18 when really it was 12 and 14 that rang in, for example. The PLC has options for: "Adjustment of the basic cycle time of the module."   and "Type of Hardware Input Filtering." Which I assume would make the PLC operate faster and avoid two inputs triggering at the same time.  If I change the setting and update the changes do not keep.  I appear unable to change it past 20 x2 ms  and slow (3ms). Is that a correct assumption that changing this would fix it? Why can I not change this?  Is it because I have so many inputs (14 or so) and Outputs (16 or so)? or because my program uses nearly all 240 lines of ladder logic allowed? What can I do to fix this?   Emerald
  12. Control Panel

    Is it possible to view the values / states of all inputs, outputs and workbits (e.g. 64.00 through 64.15 on Omron CQM1 PLC) on a single screen or control panel within CX-Programmer software?  I'm trying to troubleshoot some ladder logic that I wrote and need to know the values of 5 or 6 inputs/outputs/workbits simultaneously.  Having to scroll up and down through my ladder logic repeatedly does not work well with code that changes state every 5-10 seconds or so. Any help is welcome.
  13. Omron Hardware

    Please let me know if it is allowed to sell PLC hardware on your forum. I accumulated lots of Omron hardware  that I want to get rid off. Here is the list, I have several of each type, asking $12 each plus shipping. All in working condition.  Base Unit C200HW-BI051 Base Unit C200HW-BC101 16 Point DC Input Module C200H-ID212 16 Point Digital Output Module 24VDC C200H-OD212 Power Supply Module C200-PA204    
  14. Anyone have experience with the Peak to Peak hold function on Keyence IL-1000 amplifier?  I have an IL-030 lase head running off it and I want to utilize the peak to peak hold function.   I connected the red wire from a generic 24VDC, 1A, power supply to the IL-1000 Pink/Purple (timing input wire) and the black wire from the power supply to IL-1000 Blue (0V).   I have a 24VDC, 5A, power supply connected to IL-1000 Brown (10-30V) and IL-1000 Blue (0V) to power the IL-1000.   What I thought might work is to plug the 24VDC, 1A power supply in and out of an outlet to trigger the timing input for the P-P hold (similar to an on/off button).  But it's not doing anything.   I am not an electrical guy.  Any tips here?  Thanks,
  15. OD212 Card Outputs not powered

    Hello! I'm running into a problem with a malfunctioning OD212 output card on my PLC.  I figure the problem has something to do with my wiring, because I've put 2 different cards in with the same results. The card is unable to switch any of the relays I have as outputs although the indicator lights on it are functioning as expected. The setup it is in is: A PA202 power supply, followed by a CJ1M CPU13 CPU, 2 ID211 input cards, and 3 OD212 output cards. The bad card is the second OD212. All of the other cards work fine, it's just this one that's been having problems.  8 of the terminals on the bad card are hooked up to relays that each draw 0.02A and two more are attached to relays that draw 0.05A. So in total that's 0.26A if all the outputs are on at the same time (which they never will be.) I saw someone was having a similar problem to me on the forum, which was solved by switching out the PA202 supply, but that didn't work in my case. I don't think the problem lies with the PLC or the card's placement in the rack because I switched the card's position with the one next to it (output card 2 switched with output card 3) and tested that card (output card 3 in output card 2's place) without hooking it up to the original wiring and it worked just fine. However, I was still getting the same issue with the bad card even though it was in a different position, leading me to believe that I fried it somehow. Some other quirks of the bad card are that its outputs do not turn on and off with the indicator lights like how the other OD212s do. Below is a link to a video that shows this. The bad card has already been switched with the one next to it in the video - so it's on the end, but it's original position was second to last. https://youtu.be/wTvvGCHFpsc ( you may want to watch it at half speed ) So what I'm wondering is: how am I frying these cards / Is the problem easy to fix or will I have to send them to Omron? Thanks in advance!  
  16. HI I'm using PlC5/20 when I click on setup screen on the BTR block (to view the analog input configuration) i find the following message: No modules exist in the IOconfiguration for this R/G/M however the analog input signals is running properly....i just want enter the setup screen for configuration. I'm assuming that I need to enter I/O module in the I/O configuration? Can I do this without taking PLC to Program mode?  
  17. High-Speed Counter Input

    Hi, I working on reading impulse from the input. I am using M8000 as a contact, on the coil [C235 K9999] and it is working fine on the lad, but the problem is I need to applicate sth like that in structure ladder but I dont know how. I found function on the image below but it is for FX3U. I know that 2-phase 2-count input use OUT_C(for example EN True| CCoil CC251| CValue K0) and then DMOV(for example EN True| s CN251| d D100), so is there any method to read impulses from the input? .Thanks in advance. PS I have Mitsubishi FX3G series.  
  18. QJ71C24N INPUT PROBLEM

    I am using QJ71C24N to communicate with my devices, ASCII mode. I can send my output to the device by using non-protocol method ( G.output). However,  when I using G.input to try to receive the feedback from my device. The signal seen not stable to receive by my PLC. Sometime can get the full signal sometime can't and sometime I get some messy signal. Is there any setting I need to set to get the stable feedback from my device? Please anyone can help me to solve this problem? 
  19. QJ71C24N-R4 G.Input command

    I need some help with G.input and g.output commands. I have a Q04UDEHCPU and my slots are as follow: slot 0 - QJ61BT11N cclink slot 1 - QJ61BT11N cclink slot 2 - QJ71C24N-R4  2-channel RS4222/RS485   I need to have 2 separate RS485 stings going to different devices. I cannot find the way of setting up the g.output command. G.Output "Un" (s1) (s2) (d) "Un" says it is the start I/O signal of the module, but I am not sure what that means. What there be a different "Un" number for each channel?   
  20. Hi,   I am using Omron CP1E NA 20DTD with built-in ANALOG inputs and output. I know how to deal with digital inputs. But I have no idea about analogue input wiring and programming. I tried connecting gefran LVDT PY2 directly to an analogue input of plc. But the indicator light did not turn on. Do I need to use any signal conditioner or converter? The output of lvdt is 0 to 25volts. I HAVE ATTACHED THE DATASHEET OF LVDT. DTS_PY2_06-2016_ENG.pdf
  21.    Have 10 POE Analog Input Modules available on clearance  10/20-channel Voltage Input, Current Input, & Analog Input Module with High Voltage Protection PoE Module, communicable over Modbus TCP and Modbus UDP    Model Number PET-7017-10     Regular price $459.00/EA    Clearance price $344.25/EA   only good on clearance quantity only.   http://www.icpdas-usa.com/pet_7017_10.html      
  22. Hi I am searching for plc having negative analog input and output. i.e. 0 to -10v analog i/p and Analog o/p.  Can any one help me in finding plc which has this feature .  Thank You  
  23. Hi, Iam new to schneider electric PLC drive programming and also to canOpen communication. I have an LMC058 PLC and there are three Lexium 32A drives connected via canOpen which inturn controls three servomotors. My question is how to find/ read hardware limit status of the axis in which limit is connected to a digital input pin of the drive. Even though the axis is properly working by configuring the digital input pins we are unable to get the digital input status of the drive. In the drive manual its given that the digital input status can be read from canOpen address 3008:F(hex) we dont know how to read the status during run time in the program . Can any one advise me how to read that address. I tried SDO_read function but its giving me error(canOpen network id Unknown). Thanks in advance.
  24. G.INPUT

    I'm working on a project that reads an RF - TAG via RS232. It uses the G.INPUT command. I need some help to see if I understand clearly how it works. Now it reads a maximum of 16 digits but in the future i want to pass it to 32 bits. The command line is |G.INPUT    U5    D6500    D6800    M7922| If I understood correctly I load in D6500 either 1 or 2 to tell it which channel to read from. It stores the 16 digits in words starting from D6800 and goes on till D6815 if I am correct. My questions are: - did I understand correctly how to use the command and is there anything else i need to take care of while using it? - do I need to do additional settings to it in order to read 32 digits or does it automatically read (if the RF reader is compatible with 32 digits)? Thank you, Andrei
  25. Good day, I have Allen Bradley Compact Logix PLC with few I/O cards, there are 5 analog output cards amongst them. Today one of the analog cards does not provide more then 3.8 Volt on the outputs. Any voltage between 0 and 3.8 V is supplied correctly, whereas anything above it results in 3.8 V only. The card does not report any errors to PLC. Other cards do not have this problem. The PLC was running non-stop for couple of years and yesterday it was turned off for an hour. The problem started right after this. I have checked the module settings and verified that the output is not limited to 3.8V Can anyone give any advice in regards to this situation?