Search the Community

Showing results for tags 'servo motor'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 125 results

  1. Hi, I have to implement an axis control in a NX1P2 PLC using an inverter (3G3MX2) and an encoder cabled on a EC0122 board. I found something similar implemented  on a CJ2M PLC, but I have no idea how to set up the axis in the configuration of sysmac studio and how to implement the control. Can someone help me? Some sample to catch out the configuration?   Thanks a lot Andrea
  2. Omron 1S Servo

    Hello:           Does anyone know the details explanation of the Homing Settings for the Axis? Set the homing operation. 0: Proximity reverse turn/home proximity input OFF 1: Proximity reverse turn/home proximity input ON 4: Home proximity input OFF 5: Home proximity input ON 8: Limit input OFF 9: Proximity reverse turn/home input mask distance 11: Limit inputs only 12: Proximity reverse turn/holding time 13: No home proximity input/holding home input   Limit Input referring to Input (I/O) ? How about Proximity Input ? It is confusing with the terms. The manual has no explanation for each of the above selection.   Any one?   Simon
  3. Hey y'all- I have an application that uses an Allen Bradley servo with a brake and a linear actuator to lift a plate vertically. While maintaining a position, the servo drive (Kinetix 5500) will occasionally fault due to over-torque.  I'm thinking it could possibly be due to mechanical issues i.e. bearings in the actuator but my initial thought would be that it would fault while moving up/down as well, so far I've only ever seen it fault while holding a position. This leads me to suspect that there may be something off in the control loop. I'm not involved in the setup but I know we use load observer and I reckon we use auto-tune. Other than that, I wonder if it's something to do with the brake. I also read about mechanical resonance in the manual which seems like a stretch but it could be contributing, the frame that the actuator/motor is attached to does vibrate a fair bit.  I'm familiar enough with basic motion control using Allen-Bradley and understand the basic concepts behind the servo/control loop. However I'm at a loss for why the servo/drive would spontaneously over-torque while maintaining a position.  How would you guys approach troubleshooting this further/solving this issue?  Many thanks!
  4. Problem during tuning

    Hi! I would like to do some tuning on our machine, but the problem is that the machine stops and drops origin positions. I selected User Command method with Basic setting. After 5sec I started the tuning, the machine stops with the roblem of that axis. Is there a parameter bit that goes high (or low) during tuning? There're no strange sounds nor movements..even the amplifier doesn't give error code. Is there something else that i should check? In the Servo-Adjustments parameters, One Touch Tuning setting I found the Permissible Overshoot Amount Level is set to 0.  Can it be the problem? 
  5. Powerflex 400 25HP wird amp behavior

    ello I have a powerflex 400 of 25HP for a 60amp 25HP motor, the motor have a belt that move the clarifier of milk. It is a process that requires strength to move.So I try with the motor without the clarifier the vdf works well with a constant amp of 12 to the max of 50hz that is set up with a ramp of 600 sec.Then I try with the belt that move the clarifier... The vdf start the ramp with a wird amp behavior like 10 sec 100 amp and then 13 amp for 10 sec.When it gets to 50hz (the max) it starts the same behavior 13 amp when it reach the max RPM and when it decrease a little bit it gets 100 amp to get to the max RPM again.In this vdf powerflex 400 I didn't see the % of torque options that the last one Fuji had.Someone told me that powerflex 400 is not for power processed, they are focus in pumps and blowers more alike, and that I need a vdf vectorial like a powerflex 725.What do you think...PD: as the 100 amp is like 10 sec the protections dont show up. PD: I made a try with water and hot water, in that point with the max hz  (and 6800rpm) when the hot water start to flow the amp gets constant in 75 amp, but the motor dosnt get to the 6800 rpm again it just keep trying in 6700rpm and it mantains the 75amp triggering the motor protection for overload.
  6. Hi there I was reading this thread: And trying to create 3 axes. 1 virtual axis and 2 real axis, I would like to use MC_GearIn for each real axes so both real ones follow  the virtual axis (so both can move in sync motion). But my question is: If I give Move cmd(Absolute or relative)to master virtual axis and since it's virtual, it is not going to move then how can the other real ones follow the master(assuming that it's literally electronic gearing).  Any help will be appreciated!
  7. Anyone know what could be missing to be able to import this stepper motor to sysmac? This is one of the supplied xml files for the stepper motor.     FASTECH_Ezi-SERVO2_EtherCAT - OMRON.xml
  8. Hi there This attached pic I got from Omron motion control manual. I am trying to wrap my head around it. Does it mean that the slave servo axis is gonna follow master encoder axis using GearIn FB?? If so, then Can we executive Move FB on encoder axis? Looking forward to your responses.  
  9. Hello I am not sure if anyone know how to select cable cross section for 5KW AC motor? Thank you
  10. Axis Permanent Control

    Hi Guys, How can I bring an axis into permanent control? that as soon as a value changes, the axis reacts. My Hardware FX5U, FX5SSC MR-JE-20B. Thanks a lot.
  11. Servo tuning

    Hi.  I am planning to do a full scale servo tuning on our producting machine. Is it possible to do it while the servos are in, assambled? I mean no production, no disassembling, servos stay where they are, just tuning them one by one with their empty load..
  12. HELLO EVERYONE THERE IS THIS PROJECT WHERE I CHANGED THE OLD SERVO SETUP WITH NEW SERVO DRIVE MRJ4200A-RJ SERIES. OLD SERVO HAS A REVOLUTION OF 15 BITS BUT NEW SERVO HAS 22 BITS RESOLUTION. PROGRAMMING IS SAME BUT MY DISTANCE CALCULATION IS DIFFERENT NOW AND MACHINE DOES NOT GIVE CORRECT DISTANCE. PLEASE HELP ME
  13. servo training

    Hello . Does anyone from the forum have such a program as on flimik, and he could share a program for f3x and the got1000 panel regards
  14. Hi there I am working on a project where Omron servo drags a part to a certain position using belt mechanism, But to avoid any slippage we decided to put an external encoder directly on the part. I was wondering what is the best to approach to drive the servo using the position of this external encoder. Is there any way that it can be configured directly with the servo? I am fairly new to coordinated motions, any help will be appreciated. Thanks
  15. Alternative Servo Drives

    I'm sure many of you are in the same boat with supply issues and elongating lead times with the Logix 5500 and 5700 servo drives. Are there any decent alternatives that are easily integrated into a 5380 controlled system, maybe with an AOI? I've looked at Beckoff and Parker systems, but Parker only seem to line CoDeSys as far as I can tell. Do any of you clever clogs have any suggestions for a well stocked alternative? As a side note, I'm not new to PLC programming, but I am only 6 months in to using motion and servo systems so be kind :)
  16. Hello! I'm trying to connect my QD75M2 with a MR-J2S40B1 Servo amplifier with an SSCNET cable. The problem is when I try to turn on the Servo ON/OFF on the Intelligent function in GxWorks2, an error occurs saying the servo amplifier is disconnected with my QD75M2. I'm confident that I've wired it properly. What could be the problem? Hoping you might help. Thank you.
  17. Is it possible to reset " Motor replacement detected error" ( Error code 95.01) using code without connecting to PLC through sysmac studio? If yes please suggest how to do it... Thanks in advance...
  18. All of the ethercat servos I have installed are Omron. I have used many many brands in the past - over analog, pulse train, but not ethercat. I have one of the Yaskawa servopacks that can control two servos independently. The drive is all wired (POT, NOT, safety), autotuned, it's in RUN OK state, I have installed the ESI file, set up the axis, mapped the PDOs.. it's all working, but they do not move. I made a test program just with MC_POWER and MC_MOVEJOG/MC_MOVERELATIVE/MC_MOVEABSOLUTE along with the resetting of MC and EC and the servos do turn on, but ignore any movement command. They do not flare up with an error, and they give me their actual position, so the network is working. If I send the movement command the command position starts to differ, so the plc is/should be sending the command. I feel like there's something missing in the PDO mapping screen, but I didn't need to do all of this with Omron so I have no idea. I thought at first the servos needed huge units of movement and speed but the actual position value confirms this is not the case since it doesn't ever change.
  19.  What is the difference between Active Immediate homing and passive immediate homing ?   Does Motion servo axis have to be turned ON for active immediate and turned OFF for passive immediate homing ?.
  20. I have seen some programs in which they manually unlatch all bits like in figure 1, and in some programs they don't do that.  The instruction help page, ladder execution says that in pre-scan .EN, .DN, .ER, .IT bits are cleared to false So do we need to unlatch all these bits before giving a motion command like MAM ?  
  21. We currently have Delta DVP60ES2 and DVP32ES3 PLC's doing positioning control on Inovance IS 620PS2R8I 400w Servo Drives by Pulse/Direction. Under both of these environments our pulse count read on the Inovance drives are reading higher than what the PLC is outputting. We also have Mitsubishi & Inovance PLCs, which when connected to the same Inovance drives dont have any discrepancies in the pulse count. We also have Delta ASDA servo drives, which when connected to the Delta DVP PLC's also don't have any discrepancies. Given we have tested these combinations, it has led us to believe there is something unique about the pulse train output from the DVP PLC's that is causing the Inovance drives to read additional pulses. Has anyone experinced a similar issue with Delta PLC pulse output? If so what was the solution? 
  22. Hello everyone, I have this weird problem that the PC (process complete) bit of MAS command does not clear after a cycle time.  As you may probably see in the picture attached when the desired torque has been reached, the servo has to be stopped using MAS command; however, this is good only for one cycle!! The PC bit will remain on even when the whole sequence gets unlatched/reset. I have to manually reset this bit. I was wondering if you could help me with this issue, please?  Thank you!  
  23. Kinetix 6000 drive Gurad

    Hi,  Can someon help me with the following question. Like what makes a Kinetix 6000 drive a Guarded drive ? What type of safety stuff can you set to make it more safe.  Is it some parameter ? I am bit confused, by the manual. Should I active it in the PLC program or how ? Or it is some setting like a safe speed or torque.  I would really appreciate any help. Thank you so much ahead.  Have a great day, thanks for the reading.
  24. Kinetix 6000

    Hello guys!  Im using RS Logix 5000.  Can someone explain me what is the difference between when a servo is shutdown or disabled ?  I read the help but it says the same. I can assume it like when its shutdown, there is inside some circuit which is not allow the 3 phase for the drive.  Disabled is that when it have the 3 phase but nothing can happen ? Is there any difference with the break ? Like when its shutdown it can rotate until its slow down by itself or the break will be active ?  I tried to uplod a pic but it was not succesful. When you open a servo axis properties and you choose the Fault actions tab. You can find there these settings.    Thanks a lot. 
  25. servo auto tuning

    Hello Guys! I have couple of questions about tuning an ab servo motor. -Actually what does the drive or plc doing when I launch a servo auto tuning?  - What are the little boxes like position error integrator ? There are checkmarks in fornt of the lines. Can I choose the methode or something? I mean its not "auto" ? Why it is auto then ? - Can someone send me some basic literature where they explain me what these stuff acutally meaning ?  - What is the hook up test what for is good ?  -When you are doing a servo auto tune what are the parameters that you are monitoring and why ?  -I should do the auto without or with load ? Whats the difference ? I know there are so many question I would be so grateful if someone could help me with these answears, or even just with one. Thanks again.