Search the Community

Showing results for tags 'servo motor'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 96 results

  1. CHANGE position MR-J3

    hi I want to change a position of a servo (MR-J3-350T) which displays as current value 9500 to zero. how I can do it with MR-Configurator. in which menu should I go? thanks
  2. reset position MR-J3

    hi I want to change a position of a servo (MR-J3-350T) which displays as current value 9500 to zero. how I can do it with MR-Configurator. in which menu should I go? thanks
  3. home postion servo J3

    Hi, I have a Mitsubishi Servo motor with its amplifier MR-J3-350T. I lose the home position. How can I set the value of the position to zero if I detect a home detector. I use gx developer. thank you
  4. Kinetix 5500 and motor setup

    Hi, I am quite newbie in the PLC world but I got my hand on a Kinetix 5500 (model 2198-Hxxx-ERS2) with a VPL-A0631E-C motor. I also have a CompactGuard logix 5380 to program it. I am doing a "for fun" project to experiment and learn how the devices work.  My first question is about power wiring. In my understanding from the manual, the Kinetix 5500 main power can be configured as three-phase or single phase (Using the L1, L2, L3, GND connector - think is called IPD). In my home I have a classic 220V (EU) socket. Is there a way to connect the Kinetix directly to my socket? I tried a few random stuff like L1 -> L , L2 -> N or L1 -> N , L3 -> L,  (GND -> GND) but every time the circuit would break. (Actually, I had one lucky attempted where the circuit did not fail with  L1 -> L , L2 -> N, and I managed to operate the motor, but when I reconnected it again it failed. Am quite buffled about the issue here. I am using a socket splitter if that something to comment on.) The second question is about purchasing an actuator. I found many interesting stuff like index tables or linear actuators. I requested a few quotes from some vendors but the price range they provided is a bit off budget for me (the majority was more than 2k). I am looking for some thing to attach to the motor in a price range of 1k - 1.5k. Do you have any suggestions for me? There are no load requirements. I just need to have a moving part so that I can for example put a barcode sticker on it and change the behaviour reading on that. I could attach something handmade but I am willing to put something extra to buy commercial equipment. As I am new to this, feel free to comment any inaccuracies or misconceptions. Happy to learn.
  5. QD75M4 AND MR-J2S-40B

    Hello i have problem about connection between QD75M4 AND MR-J2S-40B  now MR-j2S is display "Ab" every time i can't solve this problem 
  6. I am looking for how others have set up vertical axis motions using the Kinetix 5700 servo system. I have a 2 axis pick/place unit with a horizontal axis (X @ 2500mm) and vertical axis (Z @ 1200mm) that works as designed during normal operation. X axis has no holding brake and Z axis has a factory installed 24vdc to unlock brake. There is a GuardLogix L81ES control system that handles the safety and control. On pressing E-stop/opening Gates the vertical axis will stop the motion, apply the brake and hold with no problems. (2198-D032-ERS3 Drive, 2198-P031 Bus Power, MPL-B430P-MJ72AA X Axis, MPL-B330P-MJ74AA Z axis) The issue that I ran into was an accidental download of the program without activating the e-stop and the vertical axis dropped unexpectedly when entering program mode on the processor. I am aware that this instance was my fault as the programmer, however I am also concerned that this might occur again in the future if the controller ever enters fault mode or someone else completes a download. I have done some investigation with the "ProgrammedStopMode" parameter on this single motion axis and attempted all 5 options and the vertical axis still has a free fall drop for a second before the brake grabs hold - so evidently this is not working for me. (Page 24 of Vertical Load/Holding Brake manual - https://literature.rockwellautomatio...t003_-en-p.pdf) I am curious if there needs to be something done elsewhere as the X and Z axis are set up as coordinated axis? I also am unaware if I need to preform some action/parameter with the bus power supply for this? The current state of the machine as it sits now is preforming a MSF in manual mode after 5 seconds of inactivity or 30 seconds in auto mode. This axis is usually in demand every ~22 seconds. This will shut down the axis after preforming a brake test on the vertical load and seems to function OK, however it is still in the back of my mind the issues mentioned previously if we ever enter a controller fault while indexing. Thanks for your insight
  7. I searched FX5 manuals and it appears that with the high speed inputs I can run a stepper motor without a motor controller. I have little experience setting up a new system with any motor but have made changes with servo issues. I sent a request for info from my supplier but I still have some questions/requests.   1. Can an FX5U control stepper motors without a motor controller? 2. If not then what Q/R series setup is required 3. Are there any document to help understand? (program examples are welcome)   Main objective is to run a sensor head to 3 or 4 specific points using a belt driven linear actuator with a nema motor.
  8. Hello everyone, I have a Kinetix 6000 CIP drive (unwind) and I need to control its speed by a PID controller. I have everything working except the MCD instruction doesn't pick up on the PID output value change. It changes the JOG speed, which I use to control the unwind, if I set the speed manually, which is slow. The PID changes the speed almost continuously. Any suggestions are welcome. This is how I'm attempting to control the speed: A1_r_JogSpeed = PID output value   Thank you    
  9. Hello to everyone! Our company is trying to make a quick disconnect for motors that connect tp servo amplifier R88ND-1S. As I know Omron doesn't have any options to do it or make an extension cable. Does anyone tried to cut the cable and make custom connector? If yes, could you share your experience? I'm afraid of having issue with encoder count. Thank you in advance! Scotty.
  10. PLC Panasonic FP0R Motion Control

    Hi, I am using FP0R C32T, i use FPWIN GR to make plc program using jog operation instructions F172. I used the program exactly like manual, but still got error code 45? Did anyone know about this thing?
  11. Hi all! We have a problem with a Mitsubishi system. After switch off the machine in home position and back on, it resets the servo encoder value to 0.  I checked the servo parameters, and the Absolute encoder is enabled, the ext. battery is ok and no zero reseting in the program ( I think...). Is there a parameter I should check or some setting in the intelligent module? The system consists Q01CPU, QD77MS2 im., J4 200B amp with 6v battery, and HG-SR152 motor.
  12. Good Afternoon  im a complete newbie when it comes to PLCs but have done plenty of PIC programming in the past. I've been gifted a couple of FX0s 20mr units to try to repair something I made with PICs years ago. It got damaged during a move and I can’t see well enough now to make PCBs anymore so thought that this might be a solution. The basic operation is  1. switched on 2. motor A moves till hits limit switch (X000) 3. Wait 2 seconds 4. motor reverses till hits second limit switch (X001) then once this has been completed then the following  5. Motor B turns clockwise for 30 seconds then stops  And while Motor B is turning I need Motor C to turn until hitting limit switch (X002) I then need to get it to repeat on the press of a button but I need to reverse operation of Motors B and C I am using double position relays to drive the motors so motor A is on Y000 and Y001 if I power either relay the the motor turns in that direction. Same with Motor B and C Y002 to Y005 is this something that’s possible with one of these controllers or am i going to be programming a PIC to control the PLC ?   All the various COM and powers are connected up, I can individually make every motor do what I want, but the program doesn't flow from one item to the next. but this is probably just me      
  13. Dear all, I had bought a mitsubishi plc fx3s-20MT/ESS which is the source output and I plan to try to send pulse to Mrj3a Servo Drive. According to the manual, it stated that the servo drive able to support the source type plc but I do find out that manual also mention that only sink type plc is suitable for melsec servo drive.  Anyone can help me in this case? 
  14. Hi all, I am studying how to control servo with PLC Mitsubishi Q-series. When I click Servo_parameter in Simple motion module setting tool, this annoucement appears.  Does anyone know why it appears? I tried reinstalling MR-configurator 2 but it didn't help. Please give me some advices. Thank you all!
  15. I have a Mitsubishi FX5U-32M with 3 MR-JE-40C servos. Our system will be used in a robot cell, and needs to convey some information to the customers system, which is this EtherCAT side of things. They want to know RPM, torque values, position ,etc, of things on our system.. Our Mitsubishi supplier recommended an AnyBus X-Gateway (AB7961). They have a few YouTube videos on configurations, but unfortunately none on the Mitsubishi side i found. I've only been using Mitsubishi for a little over a year, but know my way around GX Works 3 pretty well.  I come from the Rockwell world with EDS Files and tag based setups, and for the life of me cant figure out where to start with this AnyBus. I've gone to the support page, got all the downloads and software, and gotten online with the Anybus. As far as beginning to setup the Anybus in GX Works side, to setup what registers i want to send, im lost... Anyone out there have experience with this sort of thing?
  16. Is it possible to reset " Motor replacement detected error" ( Error code 95.01) using code without connecting to PLC through sysmac studio? If yes please suggest how to do it... Thanks in advance...
  17. Is there a way to monitor the Temperature of a Servo Motor on Allen Bradley Servo motors... MPL? PLC: CompactLogix 1769-L30ERM Drive: Kinetix 6500   Motors: MPL-B310P-MJ72AA, and  MPL-B560F-MJ72AA I would like to be able to monitor the temperature, and flash a warning screen on the HMI if the Motor gets too hot, or perhaps shut down the operation before the Motor overload trips. The drive and PLC are connected through Ethernet IP What I don’t know is if that Motor heatsink temperature information is available to the PLC.
  18. Hello, Have this error come up constantly and can't be reset. Motor hasn't tried to drive at all. Second motor showing same problem. This is a new configuration on new machine. Other inverters configured without any problems. Anyone seen this before or any ideas what could be the issue.
  19. Virtaul Axis - Simulation

    Is it possible to simulate a servo axis in Sysmac Studio? Can you create a virtual axis and then set velocity & position for this virtual axis? If this is possible, is there an example program that anyone can share with me? Thank you. Happy new Year! 
  20. Getting this error while adding MC_TorqueControl. I want to control torque from HMI value. Using R88D-1SN08H-ECT drive and R88M-1M75030T-S2 Ac servo motor with NX1P2 PLC. Newbie Here. Please support. Error    1    The Axis parameter of the MC_TorqueControl instruction does not support single-axis position control axes.    Program1 Section0    Row 6  
  21. stepper motor position control

    Hello, I need to have a cx-programmer code which I can control my linear actuator position by setting 3 positions with timer, I am using a CP1L pro'skit
  22. Hello,   I have  a project where I need to run 2 Omron Servos 1S at same time with 1:1 ratio. I created virtual servo axis and attached my 2 physical axis to virtual one ( screenshot from Sysmac studio attached). For some reason when 1 of the axis has a fault, my whole virtual axis goes down. For recovery I need to to do GearOut and GearIn again. In one of the moments I'm losing count in my motion that cause issue later. I believe that I'm doing something wrong.  Can somebody help me to understand how I can keep my synchronized axis all the time? Thank you in advance!  
  23. Sample blocks for S7 1200 plc's

    Hi experts, please share the sample blocks for the EDITABLE TIMER block it should be editable from HMI(Siemens). And also motor run hour block. Actually i am having all blocks in tia v12 version and sadly i dont have the old software to convert it again. So please share the blocks that it shoud be work in TIA V14 for s7 1200 plc's. Please note that the blocks should use add instructions to calculate the time because i don't have much memory.
  24. MR-J4-60GF-RJ Programming

    I am new to Mitsubishi (only done Allen Bradley) and Im tasked with programming a MR-J4-60GF-RJ servo drive with a HG-SR motor. I am using GX Works 3 and have a R02CPU and I am wanting to use CC Link IE Field Basic communication with this. Do I have to use the point table to move this motor from "Point A-B" or can I send absolute positions, speed, etc to a given position. Any advice/programming examples would be great. 
  25. Autotuning Kinetix 350

    Hell PLC World! I have been trying for several weeks in my spare time at work to tune an Allen Bradley Servo Motor.  Below is the list of hardware I am currently using: - CompactLogix Motion Controller (1780-L33ERM) - Kinetix 350 Driver (2097-V34PR5-LM) - MPL Series Rotary Servo Motor (MPL-B310P-MJ74AA) I have been using RSLogix5000 for testing and I plan to use it to develop a simple conveyor type program later.  I have tried a list of things which will be below, but to no avail, I cannot simply jog the motor for any period of time without triggering a position, velocity or bus voltage error.  I have tried changing the motor, driver and feedback cable to no avail.  Here is the process I have used: 1) Add the hardware to RSLogix5000 (PLC, Driver and Motor) 2) Configure the motor 3) Run the hookup test.  This works flawlessly.  The motor will slowly turn independently on the feedback test for as many revolutions as I input.  This is what makes me think I am doing something wrong in the tuning process. 4) Run autotune process with the velocity, acceleration and jerk set well below the limits of the hardware.   5) Attempt manually control motion 6) Recieve error I have tried changing the input from trapezoidal to S-Curve, changed velocity and position limits, manually tuned velocity gains in a myriad of configurations.  I have swapped legs on the 3 phase input (which made matters worse). I suppose it is possible that multiple pieces of hardware are faulty because this equipment was previously used, but I still cannot wrap my head around why the hookup test would work so flawlessly, yet I cannot just get the servo to rotate at an equivalently low speed. If anyone recognizes my mistake, I would be eternally grateful.  I am an intern studying control systems in graduate school and as popular as AB is, I would sure like to get some experience with it.  Thanks in advance!