Search the Community

Showing results for tags 'connect more than one plc in a same network'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 65 results

  1. Can USB-A2 connect PLC through PROFIBus? Can profibus connect sub-stations directly for diagnosis?   There is a 3152dp, which communicates with the sub-station through dp, and it is inserted into the dp head of cpu. It is not connected by automatic mode, but can be inserted into mpi port. Do you need any Settings?
  2. Change Subnet On CP1L PLC

    I am trying to change the subnet of this CP1L plc. Currently it is at 192.168.250.*** and I would like to change it to 192.168.54.***. I already tried starting fresh by writing to the controller with ip 0.0.0.0 and then putting my desired ip address after. When I try to write to the controller with a subnet other than .250 for example 192.168.54.13, the controller saves the node address(.13) but keeps the same .250 subnet which results in me being able to ping 192.168.250.13 successfully but get no response from pinging 192.168.54.13. Yes I did change my local network card when pinging different subnets and also did a network reset in CX-P after every ip change. Let me know if there is anything I am missing!! 
  3. Hi,I am running a Windows 10 VM with Rockwell Studio 5000 on a Windows 10 host PC. I communicate to the PLC network through a USB-C to ethernet adapter. Occasionally, the communications drop out, if this happens the only way I can re-establish comms, is to shutdown the VM and restore defaults in the virtual network editor, as this can happens a few times each day, it can be very frustrating.When this happens I cannot ping the host either, until the defaults are restored and the VM re-started.I am using the bridged connection in the VM.Can anyone help with this?Thank you
  4. Currently have a A1SJ71E71-B2-S3 in the system for coaxial (thin) ethernet (10BASE-2), it's connected to a conversion module for TP-cable and from that then to a PC with plain TP network card.  I was thinking about getting an A1SJ71E71N3-T to replace it and that way get rid of the converter from coax to TP. I wonder if it's possible to just have it hooked directly to the computer without hub - if I need a hub there's really no point in swapping - as there's still another thing between the computer and the PLC system that can cause problems. I was looking through the manual at mitsubiSIH.com and they seem to think they are connected to large nets with a bunch of hubs, PLC systems and computers. Appreciate thoughts and help. 
  5. Hi, First of all, thanks in advance for those who support and advises. I have a Modbus/TCP operational network as shown below. However, at any 1 time only 1 LAN is able to communicate instead of both LAN networks of the device. In another system with S.E Premium Unity PLC, both LAN networks are able to communicate at the same time. Thus, I would like to enquire if this is a limitation of Quantum NOE 771 whereby only 1 LAN can communicate at any one time or whether I have missed out any parameter/configuration settings? Any issue on the IP address configurations? Please advise. Thank you very much for the advise and assistance.
  6. Help with LAN network

    I am trying to set up a brand new network of PLCs and GOTs in a classroom. Something I haven’t ever done before.  I’m using simple Ethernet and going from a pc to a switch then the switch to each device.  I can not get anything to communicate to each other.  I can read from one GOT or one PLC but that’s it.  Any help would be appreciated, thank you!
  7. connect encoder to nx1p2

    hi everyone i have a question about nx ec0122 i connected an encoder to ec0122. now i want creat a programm for read the pulse and reset pulse. Then write a program to measure the length of a roll. How should I do this? Thank you for your help
  8. I am trying to set up a ifm AL1322 EtherNet/IP IO Link Master to communicate with a NX1P2 or CS1 PLC. When using Network Configurator I have added the EDS file and added the AL1322 to the network and set its IP address.  It shows all the parameters in the device but if you make a change it says it has downloaded but nothing on the unit changes.  If you make a change to a parameter and then verify it says there are no difference even though there are.  I have set up the communication with the PLC but there is an error  Establishing a tag data link connection failed. This is the same for both the CS1 and NX1P2. I have also tried setting it up using Sysmacstudio for the NX1P2 and get the same result.   I have had the unit back to ifm and there is no issue with it running with an AB PLC.  I can also communicate with the unit using the ifm LR software. Any ideas why the Omron software is unable to read from or write to the unit? ifm_IOL_Master_AL1322.eds
  9. Hi, I'm currently in a project where I'm putting up together a network where a CJ2M-CPU33 is reading the memory of 4 G9SP safety controller and communicating with an unchosen HMI. Since I'm new to Omron communications, I've decided to set up a network composed of only 1 CJ2M-CPU33 and 1 CJ2M-CPU31, both equiped with built-in EIP21 port, to help me understand the FINC protocol used to Read/Write and other commands from one PLC to another. I'm currently trying to use the CMND(490) function in the CJ2M-CPU33 to attempt and read part of the D memory in the CJ2M-CPU31 without success. I've tried many ways of sending the Hexa code to the PLC I'm trying to read the memory from but always come up with a 0401 end code (Service unsupported: Undefined command) or nothing at all when my Hexa code is really messed up. It's also good to know that the informatician of the company has succesfully read from the memory area but with his computer. I have provided with this topic an overview of my setup, settings and program in the PLC that is performing the CMND(490) function. I'd also like and take this opportunity to say that I really don't understand the settings in the FINS/UDP and FINS/TCP menu and when and how the PLC is using these protocols even if I've read tons documents on the FINS protocol. I find that that Omron's doc is complete but kinda lacks of setting and program examples. FINS_Problem_description.docx
  10. Are you working with networks for automation – and operational technology? Are you involved in planning, commissioning or maintaining industrial networks? We are looking for experts for operational technology networks like you for an online interview. We want to understand, how you work, what steps you take while working with your network/s and what you need to work well. The remote interview is going to take around 120 minutes and should take place between 09/14 and 09/30. For your time expenditure you will get a compensation of 200€. The interview will take place online via Zoom or Teams. We are counting on your support as an expert. If you are interested I am looking forward to your response, either via this forum or via eMail to j.walter@custom-interactions.com Let me know if you have any further questions! :)
  11. How to scan Ethernet/IP network?

    Scenario: You show up on site and the only knowns are Omron PLC and EtherNet/IP network. You have a laptop loaded with CX-One, an ethernet cable, and the ethernet port that is connected to a known EtherNet/IP Omron network (you can not see the PLC). I have previously worked with Siemens systems and used Primary Setup Tool and Proneta with wonderful results. Do similar tools exist for an Omron environment?  Question: How to (relatively quickly) scan an EtherNet/IP network for connected devices without knowing their ip addresses?  
  12. hi, I have a question regarding DH+ network for those who has really experience.   1. I has on plant 5 plc's connected   in seral by DH+ network to GW PLC.       I would like to de install the last one in chain . question is: while the DH+ disconnection dose all network line will be shut downed? in case of yes how do I minimize the shutdown time?   2. in other case there is HD Remote panel connected in the middle of line . how  I can to DE install it with minimum time of shut down for the RIO's  tht installed after him in topology. thanks.                 
  13.   Good afternoon, dear specialists. Recently, only without preparation, I began to set up communication between the scada and the PLC. The problem is that RSLINX LITE (v3.90.01 CPR 9 SR9) sees both PLCs on the network, but one of them gives a problem with reading data, or rather, the data monitor does not load at all (or shows a red cross (which means there is no physical connection to the PLC)). But it responds perfectly = 1ms. Nearby is an old PC with an old RSLINX LITE (v2.41.00) that perfectly reads data from both PLCs. What is the problem? why doesn't the more recent program read the data? There is an even older PC on Windows XP on the Intouch scad, via OPC the "SMC" application also reads data without problems New PC:                                               Old PC:                                                still the third ancient PC: Windows 10                                         Windows 7                                            Windows XP RSLINX LITE v3.90                             RSLINX LITE v 2.41                             SMC (intouch) Status Not working                              Status Working                                      Status Workinп It was also connected via the "Ethernet" and "Ethernet / IP" drivers. I directly connected a new PC to the PLC and set up only one connection, still the result is negative. I would be grateful for any help! If I apologize for my English, I did it through a translator.    
  14. Hi experts :D Can anyone help/try to help  with the following conundrums: a) when changing the Ethernet Operation settings from Binary code to ASCII code, the setting are 'saved' in PLC settings, meaning that ASCII code is read as selected after a restart, but the PLC accepts commands and responds in Binary code. b) when adding a new TCP port, the new port is 'saved' in PLC settings, meaning that read as selected after a restart, but the PLC refuses commands on that port (the "Open" LED on the Q71E71-100 card turns on for the duration of the transmission but no reply is received from the PLC) notes: setting software: GX Works 2 target test software: Custom made Driver for MC protocol. (tested and working with FX and Q series  and with ASCII and Binary code) PLC model Q02 (reset performed by removing the battery for more that 2 hours) ports used for test are: 5500 and 4999 (decimal) found 5002 port opened by default (no open setting required) PLC network module Q71E71-100 (new)   I would upload screenshots of the settings but I get this error: "There was a problem processing the uploaded file. Please contact us for assistance."
  15. connection to omron CJ1M PLC

    I have an omron PLC (CJ1M type) at home which I would like to connect to, however, lately, I can't anymore.  I'm trying on two different PC's a newer and an older one, both running on windows 10. 1 is just mentioning a DLL error and I can't even start cx-programmer, the other one seems to work, however, when I try to go online it always fails I'm using a usb to serial device and after some searching on the net, I thought the issue was with the prolific driver.  I tried all kind of fixes, but nothing seemed to work.  I have now purchased another device, the XS8801 from usconverters and installed the latest driver.  I have checked if cx programmer is set to work with the correct port and this is the case. My knowledge is very limited but I would really want to connect to that PLC again, so hoping someone out here is able to help me. Thanks a lot    
  16. CJ1W-EIP21 To CJ2M-CPU33 Setup

    Hi All,     I am working on a system that uses multiple Ethernet IP devices to control Pneumatic valves and D I/O. We have integrated several (smaller systems) with success. However, these systems are using a large amount of network words. One system uses 210 Byte Produce and 210 Bytes Consume. My Current count of these systems on one machine is Six masters. I need a total of 2,520 Bytes plus some for other devices in my network configurator.  My controls vendor told me I could expand the network by adding a CJ1W-EIP21 Card to help run these masters. After about 24 Hours of reading the Manual w465 I still dont quite understand how I am supposed to run these valves with this card or with Tag Data Links. Currently I have a network config. with all my masters networked to a CJ1w-EIP21 Card and TagData Links that were setup through the Tag Data Link Wizard via Network Config. I need help setting up variables in the CJ2M_CPU33 using tag link data that will allow me to output data to these masters. All assistance and Information is much appreciated.    Nate
  17. I have a purchased Machine that came with a Siemens LOGO 8.FSR PLC (Smart Relay). Generally we use Allen Bradley or Mitsubishi. Anyway, we need to communicate data between the LOGO and an Allen Bradley Compact Logix.  I do not desire to add an additional network to the AB but as best i can tell the LOGO is exclusively Modbus TCP/IP. Has anyone come across a similar situation?  I look online and did find an  Anybus module that claims to be able to link them together.  Looking for anyone who has faced this challenge and succeeded, or failed.   Thanks
  18. Hmi temperature delta

    I have connected 2 temperature devices with him delta with plc delta by rs485. When I run plc I can see the temperature change on pc but the problem in hmi  it's give errors. Com 2 errors  I need someone help me to connect these devices please 
  19. Good day,   Does anybody know if one can connect multiple micro 800 PLC's to each other via GSM?
  20. Hey all - I am working on a car wash system design that will utilize the Nayax payment system. Has anyone utilized them? How do I incorporate the device with PLC to automate the system. After payment is approved how can I send out that signal from them, all via ethernet on a managed switch w/ wifi for exterior comms for the Nayax.
  21. Hi all, after my complaing about my lack of network access in the workshop ive been tasked with fixing this so ive have some general questions about networking and concerning Ewons so this network will be used for connecting ewons to test products as well as general computer access the plan is to have 7 computer access points as well as 2 points to connect to product lines for testing my intial thoughts were to run 2 cables from our network to 2 routers, 4 computer access points and one line testing connection on 1 and 3 computer access points and one line testing connection on the other so first question is what type of ethernet cable should i use? i assume cat5 is fine, is it worth going for cat6 or is it just a waste of money? and should i be running crossover cable or straight through? do i need any specific routers or will anything do? will i be able to add splitters later down the line and be fine? or should i future proof a bit with more robust routers? my years of avoiding networking at uni has come back to haunt me i know the basics but thats all really thanks to anyone who can offer some usefull information i mention the Ewon units because ive been told that they need to be the only one on their connection to the network, although i dont know how true this is  
  22. Network Dropouts at Night!

    We have been having a re-occurring issue where some of our PLC's throughout our plant have a network outage that occurs around the same time every night. The PLC's are disbursed among the plant and it has been confirmed no large pieces of equipment are being turned on around this time every night... The network traffic does not fluctuate around this time and is not near a "troubling" level. There was a reboot to one of our servers on the same VLAN as the PLC's that are having the connectivity issues... What could have changed from a server reboot to remedy this issue, the server is not communicating to the PLC's, they are just on the same VLAN. 
  23. Utility Power at Night

    Has anyone had any issues with dirty power or disturbances from Utility that occur duration the night?
  24. Network Number Problem

    Hi,  I am trying to connect a new CJ2M-CPU31 to a used NS12-TS01B-V2 (it seems to be restored to default). I want to connect that using Ethernet.  In the Cx-Designer I have set the following for the NS ethernet Port:   - Ethernet: Enable   - Net number: 1   - Node number: 5   - UDP Port: 9600   - IP address: 192.168.140.5  //  255.255.255.0  //  0.0.0.0  //  0.0.0.0 And the following for the host:   - Name: CPU_A   - Type: SYSMAC-CJ2   - Protocol: Ethernet/IP   - IP Address: 192.168.140.10 In the Cx-Programmer I have set the same IP address for the PLC from the I/O table configuration.  However, they are not connecting. After some seconds the HMI shows a Time-out Error. I am used to works with this kind of HMI, I think the problem is in the PLC because this is my first time working with a new, out of the box, PLC. I have tried to comunicate them using the "Com. Test" tool from the System Menus of the HMI; however, I didnt get it.  I think the problem is than the integrated ethernet port of the PLC is not in the Net Number 1. I have tried to set it using Cx-Integrator. I have clicked in "Create routing tables" -> "Insert SIO CPU unit" for the Unit250(Integrated Ethernet Port) -> Local network number = 1 -> Transfer to PLC. Nevertheles, the windows "Online Connection Info" is allways showing Net(-) instead of Net(1):    "Ethetnet [CJ2M-EIP21] Net(-), Node (10),  Unit (0)" I have checked the Cx-Integrator Manual and says in this case it is only neccessary to "Connect", but I have tried it, waited for the 254 nodes, and... it doesn't work!! I don't know what to do! Thank you.
  25. Hi Guys, who knows about the new Software FactoryTalk Network Manager? I am trying to get the connection with a stratix 5700 but no success. I think i do not know how to really configure the network Manager so that it sees the switch. Now just for the test i have a LAN cable from switch (any port) to the host PC where Network Manager is installed; the IP of the PC is in the same range like the switch. Any ideas? thank you