Search the Community

Showing results for tags 'servo motor problems'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 77 results

  1. Autotuning Kinetix 350

    Hell PLC World! I have been trying for several weeks in my spare time at work to tune an Allen Bradley Servo Motor.  Below is the list of hardware I am currently using: - CompactLogix Motion Controller (1780-L33ERM) - Kinetix 350 Driver (2097-V34PR5-LM) - MPL Series Rotary Servo Motor (MPL-B310P-MJ74AA) I have been using RSLogix5000 for testing and I plan to use it to develop a simple conveyor type program later.  I have tried a list of things which will be below, but to no avail, I cannot simply jog the motor for any period of time without triggering a position, velocity or bus voltage error.  I have tried changing the motor, driver and feedback cable to no avail.  Here is the process I have used: 1) Add the hardware to RSLogix5000 (PLC, Driver and Motor) 2) Configure the motor 3) Run the hookup test.  This works flawlessly.  The motor will slowly turn independently on the feedback test for as many revolutions as I input.  This is what makes me think I am doing something wrong in the tuning process. 4) Run autotune process with the velocity, acceleration and jerk set well below the limits of the hardware.   5) Attempt manually control motion 6) Recieve error I have tried changing the input from trapezoidal to S-Curve, changed velocity and position limits, manually tuned velocity gains in a myriad of configurations.  I have swapped legs on the 3 phase input (which made matters worse). I suppose it is possible that multiple pieces of hardware are faulty because this equipment was previously used, but I still cannot wrap my head around why the hookup test would work so flawlessly, yet I cannot just get the servo to rotate at an equivalently low speed. If anyone recognizes my mistake, I would be eternally grateful.  I am an intern studying control systems in graduate school and as popular as AB is, I would sure like to get some experience with it.  Thanks in advance!  
  2. Hello, I have a project where I need to synchronize 2 servos. I use GearIn command to sync this servos. I created 1 virtual axis and attached my 2 physical servos to virtual one. Based on application logic I need to stop sync servos when count from sensor reached max value. To stop the servos I'm using ImmidiateStop command. For some reason stop point for this servos variate based on servos speed.    How I can improve my stop point?      Thanks!
  3. Alice Sales Manager Changsha Zhinian Automation Equipment Co;ltd   Te/whatsapp:+8613341312293 Fax: 0086 0731-82292217   Email: info-zna@zhinianauto.com   Main products: PLC: Mitsubishi, Omron, Panasonic Inverter: Mitsubishi,Fuji, Omron,. HMI: Mitsubishi, Omron,, Proface,FUJI, AC Servo: Mitsubishi, Omron,FUJI Sensor: KEYENCE,OMRON   Air cylinder: SMC Below is our best price product list: MITSUBISHI: 1.MR-J2S/ MR-J3/ MR-ES AC servo pack ( amplifier, motor, cables ,connectors) 2.FR-A700, F700, E700, and D700 inverters 3.GOT1000 and GT1500 Human machine interfaces 4.A, Q and FX series PLC(FX1N/FX2N/FX3U/FX3G/FX1S) plc OMRON: 1.C200H/ CQM1/ CS1W/ CJ1W/ CP1H/ CP1L/ CPM1A/ CPM2A/ CPM2AH plc 2.SYSDRIVE 3G3JZ/3G3MX2/3G3JE/3G3RX Series inverter 3.NS5-V2/ NS8-V2/ NS10-V2/ NS12-V2/ NS15-V2 Human Machine Interface 4.E3JK/ E3JM/ E3Z photoelectric switch 5.TL-Q5/TL-W3/TL-N Proximity switch 6.E6B2/E6C2/E6CP rotary encoder 7.G3NA-205B/G3NA-210B/ G3NB-240B Solid State Relays 8.H3CA/H3CR-A/H3DE/H3DS/H3JA/H3Y-2 Solid-State Timer   Contact me if you are interested, thank you !  
  4. Stepper Motor Control

    can anybody Know how to control stepper motor using PLC
  5. Mitsubishi FX2N, Servo Output problem

    Hello guys, I am facing a problem that our Servo is generating output for only reverse direction, when we give forward command from HMI the output Y0 is active but when we give reverse command same outut Y0 is high, other output which is Y4 is not high, what could be te possible reasion.
  6. Mitsubishi FX2N, Servo Output problem

    Hello guys, I am facing a problem that our Servo is generating output for only reverse direction, when we give forward command from HMI the output Y0 is active but when we give reverse command same outut Y0 is high, other output which is Y4 is not high, what could be te possible reasion.
  7. Hi all. I have a Kinetix 350 and an AB TLY servo motor. I'm using the drive's STO function. AC power is supplied into the drive, passing through an "M1" contactor. It makes sense to m e to keep that contactor open, preventing AC power to the drive, until the drive is fully awake.  Is that what you guys do? Someone suggested to me in another forum ( http://www.plctalk.net/qanda/showthread.php?t=121021&highlight=drive+awake ) that there is no reason not to supply power to the drive right away because the STO function is inhibiting power to the motor anyway. 
  8. Kinetix 6000 servo MSO error

    Hi Guys!   Anybody Can help me ? I have a kinetix 6000 servo, and that axis dont want to go in home position. There is an MSO instruction, but the ER bit is active.  What should I do ? What would be the problem?    Thanks in advance!
  9. Hi All, I have an AB servo TLY-A110T and 2097-V31PR0-LM Kinetix 350 drive. I thought that it was fully configured and ready for tuning, but when I issue a MSO it immediately starts to spin the shaft (no load yet). This lasts about a second until a Physical Axis Fault, Excessive Velocity Error occurs. I've double and triple checked the feedback and power wiring, and everything looks right. Is there anything else I can check? What can I do to trouble shoot this if I can't even give an MSO? Any insight is greatly appreciated.
  10. Hello All I am new to sysmac studio, i am using a NJ301-1200  and R88M-KN10H servo drive , i connected the servo to the NJ using ethercat. I was able to write a program where i was able to activate the servo from the NJ using the mc_Power instruction . My question is , i am not able to run the servo using the mc_movevelocity and mc_moverelative . Do any one have any suggestion to how to go from here ..  
  11. Bonjour, Hello, I use a l33erm automaton and a Kinetix servo motor . This servo motor drives an engine with a chain moving in steps of 100 millimetres (there are 15 steps on the chain ) At each top of a cell this motor advances by 100 millimetre. in reality it advances from about 0 to about 100. Sometimes it is 100,002 times to 99,997 (this is important further) and when I give it a top it goes back to about 100 (100,003 times to 99,996) And so on and so forth up to no problem, I use a MAM with an absolute type of movement. It works.     However, this does not work any more after a rearmament following an emergency shutdown. if it is a 100,002 no problem at the next top the chain advances one step But when the engine is shut down at 99,997 and I give it the order to go to 100 it advances only by 0,003.  This only happens after an emergency stop (or door opening). Thank you for the help you can give me excuse my English this is a machine translation Un séjour sans faille
  12. Hi, I am developing Servomotor Drive Module for Mistubishi servomotor to control its positioning and speed. I have combined two FBs of the RD77MS4 FBs 1. SetPositiiningData FB 2. StartPositioning FB  and defined in Local label as  Label Name: i_stModule , Data Type : M+RD77 Class: VAR_INPUT. I get Error Invalid device or invalid constant is used. Can someone tell me how to define Module Label while combining two  FBs using same Module. Please
  13. Hi, I am developing Servomotor Drive Module for Mistubishi servomotor to control its positioning and speed. I have combined two FBs of the RD77MS4 FBs 1. SetPositiiningData FB 2. StartPositioning FB  and defined in Local label as  Label Name: i_stModule , Data Type : M+RD77 Class: VAR_INPUT. I get Error Invalid device or invalid constant is used. Can someone tell me how to define Module Label while combining two  FBs using same Module. Please
  14. Greetings every one...!                                         I am using NX1P2 PLC and G5 series Incremental Servo for decoiler machine. Now am facing issue, in the time of feeder working power interrupted then last position values are lost, but I need to retain last position value and feed again remain position. In the case  I am telling about (MC_Axis000.Act.Pos) this variable value I need to store and retrieve it back when power came.                                             Any sysmac software experts give me the best solution for this issue.  Thanks in Advance...!!
  15. Hi,  I want to use the servo drive in internally speed control, how can I change the motor direction? Do you help me for wiring and parameter settings please.  
  16. hallo everyone ...i use mitsubishi Q00UJCPU and QD77MS2.. i try to make a speed control program and the speed wants to be changed during servo operating, i use dedicated instructions ZP. PSTRT1 (axis 1) and have tryed but it was only successful to change speed with "change speed control" function once ... is it like it? cannot change "change speed control" many times when servo operations?
  17. Is there a way to monitor the Temperature of a Servo Motor on Allen Bradley Servo motors... MPL? PLC: CompactLogix 1769-L30ERM Drive: Kinetix 6500   Motors: MPL-B310P-MJ72AA, and  MPL-B560F-MJ72AA I would like to be able to monitor the temperature, and flash a warning screen on the HMI if the Motor gets too hot, or perhaps shut down the operation before the Motor overload trips. The drive and PLC are connected through Ethernet IP What I don’t know is if that Motor heatsink temperature information is available to the PLC.
  18. Hi All, I am doing an application that use servo motor to feed plastic film to a target length (set by operator), and it need to stop immediately if marker sensor is ON. This application is control by Omron CP1E PLC. It will feed plastic film in 500-1000mm/s depends on the target length set by operator. It is require to stop immediately if the servo feed length more than 90% of the target length and the marker sensor is ON. However, is there any possibility for the servo to stop immediately once the condition is meet? As I am using PLS2(887) to feed with target length, and INI(880) to stop immediately, however, it cannot get the desired result as servo not able to stop immediately after marker sensor is ON, I am not sure is because of the PLC scan time, or servo need time to deceleration (deceleration rate assigned to #FFFF). Appreciate anyone able to assist on this. Thank you.
  19. CC-Link IE + C#

    We have a controller written in C# and need to integrate a servo.  We are looking at the Mitsubishi servo MR-J4 line.  Unfortunately it doesn't support Modbus TCP but does have the CC-Link IE protocol.  Does anybody know if it is possible to talk to CC-Link IE via C#?   I'm having a helluva time trying to find an answer.  I see some thing about Seamless Message Protocol (SLMP) and CC-Link but the info is somewhat sporadic.  Any advice is much appreciated as I've never worked with the Mitsubishi product line (but interested in their PLCs).
  20. Dear Friends, I am doing a pick and place project using stepper motor.programmed movement by PLS2 command and motion are running fine.I want to program origin for the stepper axis.Please help. i don't know how to origin with a home sensor input.I am using CP1E PLC and stepper driver DM860.
  21.  Hi all. I have a question about how to set up the motor in rotary mode. My application will be a basic rotary table driven by a servo motor without gearbox between. So, in my servo drive axis settings, I select the motor as a rotary mode. then I defined the maximum position setting value for 360 degrees, and minimum to 0. So far so good. But the problem comes when I want to make an absolute move using the mc_moveAbsolute to move 360 degrees. Whit this settings the error "target position settings out of range " will come up. So, what is the solution to rotate 360 degrees without generating this error? if I set up the maximum value to 361 degrees and then if I rotate 360 the error will not occur and the motor will rotate 360 degrees as I aspected, but it's this correct ? or there is another way to do it? Thanks  
  22. Kinetix 300 servo drive

    Is there a real-time help resource for this thing other than the worthless AB site, on which the support page has been giving an error message for 2 weeks?
  23. Hello everyone! I have problem with understanding the usage/principle of operation of parameter "Mark detection number".  In manual i read: "The number of mark detections is stored. "0" clear is executed at power supply ON. Continuous detection mode: 0 to 65535 (Ring counter) Specified number of detection mode: 0 to 32 Ring buffer mode: 0 to (number of buffers - 1) Refresh cycle: At mark detection" My question is which mark detections are stored? Servo detects some kind of marks? I am novice in servo programming, please explain in the easiest way. Thanks for help.
  24. Average motor speed

    Hi Guys!   There is a task. I have a motor, and I can monitoring the actual speed. The question is how can I to determine the average speed, if I know just the actual speed. If the speed is zero, it must be ignored. So I have to measure when the motor moves. Anybody have any idea? How can I solve this problem. RSLogix 5000.  Thank you.  
  25. Servo Motor Connection

    Hello, I am using the R88M-1M40030T-BS2 ( 200V 3ph) servo motor. I am looking for a diagram that explains the connections on the top of motor ( for power supply).. there are more than 3 pins and i am not sure why. Can anyone help me understand the pins on the motor for the 3ph supply?  Thank you