Search the Community

Showing results for tags 'state machine implementation and its error handling concepts'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 153 results

  1. i just got my NX1p2-1140DT controller with a R88D-KN04-ECT. i conneted every thing and directy got the 87 message on the display. i found out dat is becous wrong wiring I dont have the I/o cable incallt with omron they where saying that i don't need it and i can controll the motor controller full via ethercat. i already try to change to pdo mapping. what am i doing wrong? can someone help me? is it indeed true i dont need the i/o cable  thanks in advance for helping.
  2. Array A INT[32] Array Index B INT Destination C INT I am trying to move an Array (A) Element (A[2]) using a symbol (B) in ladder into a destination symbol (C) C = A [ B ] Result: ERROR: Array Index of Operand 1 out of range at rung 1 ( 6, 0 ).  The documentation suggests that it is possible, but I am unsure if there is something I am doing incorrectly. Note* Fixed indexing works with no errors Is there another method to accomplish this?   PLC : CJ2M CPU31 CX- Programmer: Verion 9.74 Update 1: If I go online to the PLC It does look like the array look up is working. Is the issue with the mov block? Update 2: I changed the memory locations which has caused a different error to appear. This error is clearer but does not explain the manual excerpt I posted further up ERROR: Only the constant can be specified for the index of the array.  at rung 5 ( 6, 0 ).  Update 3: Solution 1 I managed to hack together a proof of concept using pointers and indirect offsets  Update 4: Solution 2 For some strange reason things work as expected inside of the function blocks so I made one where the array is In-Out and with an input and output respectively. Note* External reference to pointers inside of the function block produced an error. Function block Logic     Update 5: Solution 3 Now I feel like I am going crazy, I tried just the original code again and it works... I have no idea why and if it was not for all the documentation I would be lost as to why it works now... Update 6: Conclusion It seems to have array indexing work the array index must exist in the D Memory Block. The reason it did not work above is because I somehow had a MOVR block when I tested after moving all the variables to the D Memory Block. I hope this journey helps someone else :)
  3. CP1W TS001

    Hai, I have problem with my CP1W TS001, suddenly reading result always #7FFE.  i use CP1E-N60 and 2 expansion module, AD041 and TS001. I put TS001 after AD041 then my program code as follows : mov #8051 105 mov 7 D20 mov 8 D22 the reasult at D20 & D22 always #7FFE could someone help me to solve this problem?
  4. Hello. I am writing a function block and i am getting the following error: ERROR: STRING type or an Input Output variable is not supported by the PLC of this unit version. Check the unit version in program check options. When i try to remove the string i get error: instruction is not available for current plc Is there somewhere where i can see which instructions i can use? Or is it not the string or one of my in or outputs I am doing something wrong with?   Kind regards, Ralf  
  5. Q02CPU Error 2200

    Hi All; Trying to make a backup of a Q02CPU.  Used GXWorks2 to get the program and parameter files from the working CPU.  The System is on an 8-slot rack with mixed IO including a ProfiBus module (QJ71). Got a new CPU, powered down the system and installed it after setting the DIP switches the same as the working one (2 and 3 both on, others off). Power on system. Download the program and parameters to the unit, have the ERR LED blinking and the CPU will not run.  PLC Diagnostics show this 2200 error, which when I look it up in the book starts talking about 'drives', which I find out have something to do with the DIP switches.  The combination of switches 2 and 3 indicate the parameters are to be stored in Standard ROM (Drive 4), but apparently this is not happening when I do the download of the program and parameters.   Is there a specific procedure I need to follow to put the parameters into Standard ROM (Drive 4)? Or, did I get a replacement CPU that is either A)Bad or B)does not have this Standard ROM? Or...?   Any assistance would be appreciated.   CPRenaud
  6. Hi all,I'm completely new to ASCII and trying to figure out where I'm going wrong here.Application: I need to send 2d barcode data to a KGK Jet model CCS3000L Inkjet printer. Only protocol possibility is ASCII. PLC I have is a Micro850, and the only port option for ASCII is the serial port. I modified one end of a 2707-NC11 cable to connect PLC TxD to printer RxD, PLC RxD to Printer TxD, and PLC SG to Printer SG. I jumpered CTS and RTS at the printer connector, and the 2707 cable I'm using doesn't have wires on the Micro850 CTS or RTS pins.Printer company verified that I can just jumper RTS and CTS on their side and not connect their DTR and DSR pins (since I'm not using hardware handshaking). I don't really need any flow control for the application ( I don't think...again, ASCII noob here).Do the CTS and RTS on the PLC side need to be jumpered? Does the DCD pin need to be jumpered or connected to something if I'm not using handshaking?I downloaded the Micro800 ASCII read and write functions and function blocks from Rockwell library, and they seem to be working, except that I keep getting ABL error id "7". This error states, "Cannot complete ASCII send or receive because channel configuration has been shut down using the channel configuration dialog box." I have the serial port enabled and configured to ASCII, no handshaking, baud 9600 same as printer, no parity check, 1 stop bit, character length of 8.Any help in pointing out what I'm doing wrong or things to try would be greatly appreciated!   ASCII_TEST.ccwsln
  7. Trying to log into NA HMI, NA5-7U001B  Direct, using USB or Ethernet.  All attempts failed .. tho, it was easy to log into the NJ Controller, direct, with USB or Ethernet using the same PC. Then a window popped up.. saying the firmware needed updating in the HMI, and suggested launching the "update" from the same window... Then, after a few minutes.  a "update failed" was displayed on the window.. and the HMI screen changed to this: ..and the green LED went RED ... aaaaagh!   HMI no longer works... any idea why this happened, or the failure to log in happened.. or, what it will take to fix it? Please tell me it was something Omron did .... Thanks Much, Regards, ,Michael PS:  additional info..  I was using Sysmac Studio Version 1.1 .. because I could log in to the CPU (USB and Ethernet) and not the HMI.. I changed to another PC with Sysmac Studio Version 1.17 .. Now I was only able to log into the CPU with Ethernet.. USB login failed. .. and, so did any attempt to log in to the HMI (USB or Ethernet) It looks like if you use a new version of Sysmac.. better not have a device with  "old firmware" ..  I think it was the V1.17 that presented the window suggesting the Firmware Update ...  sigh!
  8. Please Help me, I want to connect aczet brand weighing machine CG203L to PLC CP1L-M. But several times I tried it didn't work, I've tried repeatedly in the settings section to adjust the baud rate and mode and have tried one by one but to no avail. Can any of your friends help? thank you
  9. CP1E won't connect or run program

    Hi there! Today a CP1E-E10DR-D suddenly stopped working. RUN led was off and I couldn't connect to it via USB getting this error: "Selected port does not exist. Select proper port number from Change PLC dialog and press OK button", and automatic online function didn't work as well(it's not a cable/driver problem since I successfully connected to a CJ2 CPU using same cable and PC). Since I also tried to connect with the CPU outside the control cabinet with no success, I asume there is something wrong at hardware level.  My question is, have you ever faced something like this? My plan is to try to revive it somehow (maybe trying to locate any defective component in the PCBs or something). So I was just wondering if you have any advice in order to achieve it.  Thanks in advance!
  10. Omron NB Software

    I am facing the error while compiling the program , there is only 1 error , but not able to figure what is the actual error. Please suggest and support.
  11. Q-Series - Operation Error 4100

    Hi guys. I found error on PLC and from PLC diagnostic I found this Operation Error 4100 as per attach picture. FYI, there is no SD card mount onto this PLC. I wonder what is ATA card. This error wont affect the operation. Any advise on what to check?   This ladder is pop up when I clicked, error jump.   Thanks.
  12. Hello, has anyone noticed that plenty (not all) forum posts are changed to quotes from TWControls? What is happening here?  Hopefully only a momentary breakdown  
  13. EPS& Rock Wool Sandwich Panel Making Machine including unwinding, before cutting, film, beading / molding, rock wool and spray delivery, Edge foam, continuous curing, cutting and other functions, high degree of automation, stable performance.Edge polyurethane foam systems, automatic feeding system, to ensure that the raw material requirements in full accordance with the ratio of mixing, spray evenly; using a reliable foam technology to ensure uniform sheet foam, dense, sheet closely connected.The production line is equipped with automaticcontrol system, userfriendly interface for easy operation, monitoring, advanced computer control, easy to adjust the entire line of argument, effectively ensure the production line stable and efficient operation. https://www.yingyee.cn/sandwich-panel-production-line/45509417.html
  14. Hi guys. I was getting Coordinates error popped up everytime I tried to go the page. If click OK, everything is normal and can operate as usual. Just wondering how to eliminate and what causing this error. Thanks!  
  15. Panasonic FPG-C32T2H - E45

    Hi, I have PLC with Error E45. I am not very familiar with Panasonic and in manual, explanation is not very clear for me. Any help appreciated    
  16. Hi. I use the email block on few of our NJ101-9020 controllers to send out daily reports or any status updates. Recently the PLC's started an unknown issue and fails to send email out anymore. I use the Mail_Send function block from Omron to send emails. The only Error ID i can get is 2005, with status being "Connection to SMTP" failed. Looking at the troubleshooting guide, i cannot find anything to do with error id 2005, in fact its missing. There is 2004 and 2006 but no 2005. I've tried all the obvious thing like, power cycle, redownload the whole project, create a new instance of Mail_Send function block etc. Nothing seems to have fixed this unknown issue. Our IT department did a full check on their side and nothing seems to be out of order. I can still remote into the PLC, so i dont know what exactly is the problem. Has anyone came across this error ID before? Any ideas why this might have been happening? It was working well until few weeks ago and nothing changed and this suddenly started. Any input is really appreciated. Thank you.
  17. Hello! I have been working with a Factory Talk Studio V8.0 and my computer was crashed, "blue screen". After this, I can not open my panel project anymore, I only get information Failed to open factory talk private directory for the application. How to save my project?  
  18. NE1A-SCUP02-EIP

    Does anyone have experience with the NE1A-SCUP02-EIP safety PLC? We had a machine shutdown yesterday with a L9n4 error on the NE1A unit. The manual says this is a tag data link error. Does this cause the safety PLC itself to shutdown? I always thought the EIP portion of the safety PLC was only used for status reporting to the PLC. The safety portion is strictly on DeviceNet and is independent of the EIP network.  The CJ2 PLC's error log tells me it had problems communicating with the safety PLC, the VFD, and NX I/O's which were all in the same panel going through an Ethernet switch. 
  19. 0x0408 error

    Friends need help on my plc omron CJ1W-PA202...can't find it's IP and connect with my servo drives 
  20. Hey Guys, Modicon M221 PLC, programming with Machine Expert. I have a project that I must create shifts for heating elements, requiring that some heating elements, those who were on for the longest period, do not turn on in the next shift. I'm looking for a sorting mechanism to determine what %MW (6 words of 8 total) have the largest value. I would like an array of 8 words, sort them, and retrieve the highest 6 or highest 4 or highest 2.   Thanks.  
  21. Hi I have encountered a problem with CX-integrator. I'm not able to open the program. The following message appears:  System error. Save the date and close the application.  (Error code 0035) I have tried to reinstall the entire CX-one packet.  Any ideas?  Regards MBD
  22. Hi, I am new to this forum and pretty new to programming fanuc robots. I do have one program that is working in production under my belt. The company I work for recently bought a used M-20iA with a R-30iB controller. The robot was tested and worked before it was shipped to our facility. However, not upon start up the robot faults out and gives the error messages:    SPOT-474  NM&OUT24v shorted after MCC SPOT-476  Fix Pwr short & then cycle    I am wondering if a wire was vibrated loose during the shipment, however I have not been able to find anything in the cabinet. It looks like all of the boards are lighting up and working fine. I have been unable to find any documentation on these particular SPOT errors.    Has anyone experience this error and knows how to fix it? Or does anyone have resources that may shed light on the situation? Thanks!
  23. Hello to all  We have a problem with starting CPU. In GX Developer we click "Diagnostics" and see Error 2400 File set Error. What causes this error? Error code list[Error code 2400] and point to step / parameter 1100 we already have format the memory the last thing not tried yet is :  - swap the CPU , (still in process provide by purchasing) - change memory battery (as per suggest by machine vendor) kindly needs some suggestion if anyone experienced this problem, or maybe some tips    Applicable machine    QnA series PLC ===================================================================================== Error code(SD0)    2400 Error message    FILE SET ERROR LED status(RUN)    OFF LED status(ERROR)    Flashing PLC operating state    Stop Diagnostics timing    At power ON & reset [FILE SET ERROR] The file specified with a parameter does not exist. ■ Collateral information • Common information: File name/Drive name • Individual information: Parameter number ■ Diagnostic Timing • At power-on/At reset/At writing to programmable controller/STOPRUN Read the individual information of the error using the programming tool to identify the numeric value (parameter No.). Check the drive name and file name of the parameter corresponding to the value, and correct it as necessary. Create the specified file and write it to the CPU module.
  24. Added new tags to an existing (and operational) PDB file.  Using DEMO mode switch (/t) to quickly add without USB dev dongle.  When switching from Workspace to Runtime all tags and graphics work.  However, when I switch out of DEMO mode and restart iFix, all tags show up as "Not Defined". the IGS OPC Quick Client shows good comms and data with the new PLC sources, so it's not a PLC comms issue.Truth be told, I do not work on iFix very often, so I'm hoping I just missed a simple step.Thanks in advance!
  25. I am trying to online edit a program in a MELSEC QCPU, using GX Works2, but I keep getting this error "A file which does not exist in the PLC was specified" <ES:010a4022> Few weeks ago I had just online edited the same program in the same PLC with the same steps with no problem. There had been no changes to the PLC after that. Just all a sudden when I try to edit yesterday I get this error. Not an expert in Mitsubishi, just started learning the basics. Connection to PLC is by USB cable. Steps I followed to connect to PLC:    -Online > Read from PLC    -Select PLC Series: QCPU (Q mode)    -Select PLC side I/F Serial Setting: Serial USB    -Select all target program to Read, then Execute I am editing the file that I had just read from PLC Steps I followed to online edit:    -Online > Monitor > Monitor (Write mode)    -Execute the function below when mode is changed: Checked all    -Edit the program (basically just deleted one -||- contact and drew back the line)    -Compile > Online Program Change Then Bam! error get! "A file which does not exist in the PLC was specified" <ES:010a4022> I had tried Verify with PLC, but all results match. Is there something I am missing? Help much appreciated!