Search the Community

Showing results for tags '5000'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 38 results

  1. Hi guys! Can anybody help me? I have an existing controlnet network. How can I connected a new module? Like an 1794 IB16. What should I need to do after I connected the new module? One more question: What's the difference if I do not connected the new module right after the last module, but I connected between already existing module. Then what should I need to configure. If anybody want to help, please write like step by step. I'm a beginner, but I want to imporve myself. Thank you for your help. I almost forget, I need to work with Allen-Bradley PLC, and I have RSLogix 5000 software.
  2. RS logix 5000 motion control

    Hi Guys! I have a problem with Motion axis move (MAM) command. There is an Allen bradley servo motor what is working well. But I need to add a new program section, wich is in  a specified moment, the axis should move a certain distance. I think I need to use the mam command, just I dont know how can I configure the motion control part. I need to make a new tag ? or what ? I need to use a user define ? PLS help me.   
  3. Any new tags I add in studio 5000 the HMI project shortcut cannot locate the tags, it says unresolved route to processor. It's the same shortcut all of the other tags are using. Please help. 
  4. This is my first time to the forum and I am still very new to plc programming. I just had to move all of our software over to a new computer ( kind of new) it's running windows 7 pro. The same is as the computer before. Same computer name, same I'm, same file directory. However when I add tags in studio 5000 and reference them in the HMI, it says it is unresolved in route to the processor. It only does this for the new tags. I used the same shortcut and everything so I am at a complete loss here. What do I do.
  5. OS: Windows 7 Ultimate 64-bit running on VMware virtual machine. Installed software: Studio 5000 V21.0 Licence: Concurrent (served by licence server on another PC). On starting Setup.exe from the VM's desktop I get the message     "Studio 5000 does not support this version of windows" Any ideas how to proceed?
  6. Hey everyone first post on here, does anyone know if it is possible to convert a string into a double integer. i am working with a dimensioner and it is sending me its box dimensions in a 12 char string (see attached picture). however i need this data as a double integer (it seems to just take the string length not the string value i have tried both dim_lengh and dim_length.data[0]). i have gotten it down to the point where i have the string split up into the dimensions i need but i dont know how to do the conversion. (box dims for reference are 21 X 15 X 14.8) Thanks in advance, Dr. Brule  
  7. Axis Attribute Error

    Hello All, First time working with PLC. Get the hang of it from stuff I researched. Having an issue with an axis setup for a servo motor.  When I try to do an auto tune it gives me an error that axis is not configured.  Source: Config Fault    Condition: MotorDeviceCode- INvalid attribute      ACtion: Immediate Stop Fault Entry: Type 8, code 9 subcode: 1314 stopaction: 4 Statechange: 3   I was wondering what am I doing wrong? Any leads or source information I can use to solve this. 
  8. Hi,  I am writing some routines to decode the data from my Input: data array to User-defined Array Parameters. Is that possible to have a generic routine to decode data coming from more than one module? I have two Module ENode and ENode_1. I have defined User-Defined parameters for the module. Can I make a generic routine to decode the data coming from these two modules and put them in the defined arrays?  the two arrays ENodeData[0] and ENodeData[1] have the Generic User-Defined parameters.
  9. RSLogix 5000 version 20

    Dear Friends; Good day. I already installed following version on my workstation RSLogix version 10, 13, 16,17 and 19. Now i have some turbo machinery there logix develop in RSLogix 5000 version 20. If i install version 20 on my workstation is previous activation work or need to activate it separately? Regards   Solarboy
  10. controller is not coming online with rslogix 5000, but i can ping the ip from the pc. getting the error message says "controller failed to come online - error 701-8004250B" appreciate ur help.
  11. Studio 5000 no From Upload option

    So my company recently purchased a new Allen Bradley PLC Demo kit from Amatrol (CompactLogix L16ER) and I installed the Studio 5000 v24 onto our company computer and started going through the Amatrol Lesson Plans. But then I had a bit of a snag. The lessons required that I open the files from the From Upload option on the Studio 5000 start up screen. Only, it wasn't there! There is no From Upload option on the start up screen. Anyone have any ideas how or why it's not there, and most importantly, how to get it there? It's kind of important!   Thanks!
  12. Could someone please generate PDF report for the ACD files on the attached .ZIP file? They are all RSLogix 5000 v20 files, I needed them for a university report which the deadline is today, but I don't have access to a computer with RSLogix 5000 :S Thanks!  ACD_files.zip
  13. To Infinity

    Hello.  This is my first post and I hope someone has a solution. I have a program calculating Gal/sec adding to a running total and have up to the end.  Using REAL I can accumulate up to 16,777,216 (2^24) and using DINT up to 2,147,483,648 (2^31), but I need to have my registers continue past these limits.  I've read through many topics here and have tried the Rockwell Knowledge Base but can't seem to find a solution that truly works.  I have gone so far as to transfer the DINT to a string, cut the string into pieces and reassemble them in an Odometer type concatenation. If anyone has a suggestion, I would appreciate it.  I know I'm not the only one with this problem. PS & BTW - I'm using Studio 5000 v24 with a 1769 L33ER
  14. Good morning i want to know how i can recognize into the compactlogix 1769-L24 ER the micro 850 (2080-LC50-24QBB), because i want to communicate this two devices with MSG, i already i can see these two equipments into RSlinx but when i start Studio 5000 i don't know whick module i have to use it to recognize the micro 850, please help me
  15. Hi, I'm a long time lurker and would like to start by saying thanks for all the help over the years, much appreciated!  This is my first post, please be gentle. I'm working through a large project with an L83 (V28) including 75 EIP nodes & 5 servos.  We have a need for quick real-time response of 2 cameras during a quick servo move (taking several pictures).  I've broken my program up into a few event driven tasks (allowing me to chose the execution time interval (5 to 8 ms for more important tasks and 20 ms for less important tasks, etc.)), along with these I have 2 periodic tasks: 1 for my HMIs & faults running every 30ms and 1 for this quick real-time response camera situation running at .5ms which contains my camera and servo logic.  Everything is running well and seems responsive and repeatable enough, but I am now adding the second half of the logic which will essentially double everything (2 up system).  This has made me consider the best structure approach: Is it better to have a few larger routines within a few larger tasks or better to have more smaller tasks containing an abundance of smaller routines or some other different mix? Thanks, JD43    
  16. I am currently working on a fwd rev motor control routine, we have all of the circuit wired up and verified the physical circuit is working as intended when manually jumped. But will not turn the outputs on...  I triple checked my logic and it all seems right, all inputs are true all the way to the output on both the fwd and rev rungs. But still the outputs won't go true. if I toggle an output bit it does show up on the dc out card, I haven't tried forcing anything.  No errors or warnings, fuses are fine. our teacher does not help as much as we'd like and we have troubleshot just about everything we can think of with our experience.    Any input would be appreciated, thanks.
  17. RSLogix Tag Name Confusion

    I am trying to learn the logic of a process at my new job. There are tag names that I can't make sense of because they end with _xva, _xvb, _xvu, _xvd, _xvo, _xvc, _zsm, _zsu, _zsc, _zso, _zsd and so on and so forth. I know they are associated with motion, but I need to make better sense of them. There are no descriptors. What do they mean and is there a resource available that I can reference?
  18. Dear all, I have 1794 IE8H Hart flex input module to which one Emerson HART flowmeter is connected...I have gone manual of flex module...I have to write program to read 3 parameters from HART transmitter in RSlogix 5000 (compactlogics)....in manual there are so many & geeting confused how to get this...even got sample code from rockwell site...but still nt working...If anyone have any proper document to follow please suggest or mail me on gspatil555@gmail.com.....thanks.
  19. Can't Communicate to 1769-L32E

    I was practicing some concepts on concurrency in periodic tasks where I handle such using SSV instruction to inhibit tasks, as suggested by Logix5000 Programmer Manual and after I downloaded the program through ethernet cable to the PLC (Compact Logix L32E) it became impossible to communicate to it, showing 1789 Virtual Chassis in the Who Active Window isntead of the PLC I'm using. I tried to reconfigure it using RSLinx and serial cable but I had no success, the only solution was reset it by removing its batery. I was wondering what could have caused the problem. Concurrency.ACD
  20. Hey guys, this is probably a stupid question so I apologize if it is, but I have a PanelView Plus 6 700 and a CompactLogix L36ERM on one of my machines at my plant.  We have several different molds that run in this machine, so we have 5-7 different PLC programs that can possibly run in this processor, depending on which mold is in.  I'm planning to go to a single program with recipes, but I haven't had the time to set that up yet.  So we use the PanelView for troubleshooting, and adjusting process paramters.  On the main screen in the PanelView I have the time/date and also the program name.  What I have been doing is just creating a string tag in RSLogix 5000 that is the program/processor name (we use the same name for the processor and program) and then on my PanelView I just create a string display that looks at the string tag name in the processor.  That way anytime a mold is changed over and the PLC program is downloaded, the PanelView displays the correct program/processor name.   Now this is all fine and dandy and works as long as if a new program is created, we remember to change the string tag to the name of the new program, we often run new sample parts and what we do is rename an existing program that has similar logic and save it as a new program name.  The problem comes up because if somebody copies an existing program and makes a new one, the string tag is still going to say the name of the old PLC program.  Now if we only had one or two or even 5 machines, it would be simple enough to just remember to change that string tag.  Our, or I should say MY problem is that we have approximately 40ish machines in our plant, and I can't always remember to change that string tag every time we create a new program.  I should say that I have been, but there are times that I may forget. My question is this, is there any way that in FactoryTalk View ME Studio to have a string display the name of the processor or the name of the PLC program automatically without having to manually enter the name into the string tag that I created in RSLogix 5000?  Like is there a system tag somewhere that has the name of the processor or the name of the program?   That was way more explaining then probably necessary.  It's early and I've had way too much coffee haha.   Thanks guys.
  21. Programmatic Timer/Delay

    Howdy, Wasn't sure the best place to post this Programmatic Timer/Delay question. I need to create a Timer whose 'time' will change programmatically. I am having trouble coding this in RSLogix/Studio 5000. I need to delay a little more every time 1 Product passes through up to a certain count then reset and start over. Basically during a conveyor transition, via a pop=up conveyor, I don't want the product in the same place every time. I want each successive product to be in a little bit different spot, call it the Conveyor Land Point. The product will land a little further each product, then start back at the first land point I have no code to share as all attempts were FAILs Inputs: > Product Count (Count up or down counter) > Product Count Cycle (Number, constant, set able, currently = 4) > Delay Time Sequence Interval (Number, constant, set able, currently = 0.25 seconds) Outputs: A sequencing delay, based on Product Count > Delay Sequence:  1st delay 1 second. 2nd delay 2 seconds, ... up to Product Count Cycle (4) then reset back to 1. Program: (As I was thinking) Set Product Count Cycle, Product Count Cycle = 4 (May change could be 3,4,5, or 6) (Might be hard code, might be an HMI input) Set Delay Time Sequence = 0.25 seconds (May change could be 0.5, 0.75, 1.0 etc.) (Might be hard code, might be an HMI input) Line start, Product Count at one (1) Calculate Delay     Delay   = Delay Time Sequence Interval * Product Count Cycle * Product Count  Product Count increments via PE Repeat e.g. Hopefully I have not 'run' at the mouth, wanted to give as much info upfront                I included a picture Any thoughts, help would be great. thanks,
  22. I have a new PC that is running Windows 10, I have RSLogix 500 loaded and working no problem, along with RSLinx, Factory Talk Activation... etc. I also loaded the Studio 5000 package and it loaded without a problem however will not run. It starts and allows you to pick a project to work on, then will display the Logix 5000 splash window for a second, then just close. No error message, crash or idea of what it is doing, just closes. So far no help from AB, perhaps someone here is running this on Windows 10 or has an idea how to figure out why it is closing. Thanks
  23. Add On Instructions Parameters

    I am trying to learn how to use add-on instructions, and to get a better understanding I am trying to do a simplified example. I am trying to make two separate add on instructions that alter an integer tag in different ways. I would like one AOI that multiplies the input integer by 3 and another AOI that adds 3. The integer tag is a InOut parameter.  I named these AOIs "Mult3" and "Add3". When trying to use the AOI's it requires me to have an additional input with datatype the same as the AOI ("Mult3" or "Add3"). I have a couple of questions about this: 1. Why is this data type required? It seems to me that I would only need the InOut integer that I want to modify. 2. I want to use these AOI's in a number of places throughout my code on a number of tags. Would I be able to just use one "Mult3" tag for all the AOI's, or would I need a seperate tag for each use of the AOI?  For Instance if I am using the Mult3 AOI in 3 separate places in my code, two times using "Int1" as the InOut parameter and another time using "Int2" as the InOut parameter, could I just make one tag of "Mult3" datatype and use that for all the instances of the AOI, or would that screw it up in some way. Thanks for any help.
  24. Sequencer Input

    I have a program using the SQO instruction. However, I am looking to control my program with a sequencer input. I have never used the sequencer input before and I have 16 sensors to move cylinders using the sqo.
  25. Hello, I am new to this forum and I am looking for some help. I have to create a block mover system using the controllogix , I know that I must use a SQO as I have done this process without a Flex I/O on a SLC 500 before. Currently I am getting a error while dealing with the array can anyone show me an example of a SQO in 5000?   Thanks