Search the Community

Showing results for tags ' you cannot use chan0 for any other user mode activity. you can use it for non-user mode activities -tcp/ip interface modules from rockwell/ab supported'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 102 results

  1.   Mail me for Help if anyone is stuck during coding and settings.
  2. Hello, On our DCS we have a button that will open an RDP connection to our PLC server and open the .mer file connecting the DCS to the PanelView HMI. This is supposed to be used for troubleshooting purposes only, but that is not the case. Is there a way to prevent operators from operating the HMI through the RDP while still allowing them to have read only access?   Thanks, Michael
  3. Hello, denizens of Mr.PLC. I'm trying to talk to an old TSX17-20, and have acquired the DOS files for PL7 22. However, when installing via floppy drive, I'm getting a fatal error saying that the User Interface is missing. FATAL ERROR: 251 Your Telemecanique system in incomplete. Ensure that User Interface is correctly installed.   I'm aware that PL722 (and PL7-1/2/3, etc.) require Telemecanique's DOS User Interface to run, but I can't for the life of me find installation files, and, as it is no longer supported by Schneider, no luck getting it from their site. Apparently, it used to be hosted there. Would any of you wonderful folk have the links or files to this user interface? Apparently, PL7 22 5.0/5.1 have never required/no longer require a license. It was a drag to find these files, so I'm posting the PL722 files (in two zips, representing the two floppies) so that there's an easy to find reference for them. PL722D1.ZIP PL722D2.ZIP
  4. I have a 2 CompactLogix PLCs running right now, communicating CIP Safety and Standard data over Ethernet I/P.  For reasons I can't explain right now, the IP address of the second one HAS TO change semi-randomly (the 1st PLC is static).  Setting the 2nd PLC's IP to static or assigning it a static DHCP address is the obvious solution, but for the purpose of this question, that cannot be done. Is there a way to programmatically change its IP address on the 1st PLC's program?  (There is an HMI attached to the 1st PLC and adding a screen to enter in the new address would be trivial.)  The only bit I'm still missing is how do I change the IP address on the module in the 1st PLC so that it's pointed at the right IP address of the 2nd one when it changes.    I found instructions on how to use msg instructions, but that hasn't worked yet.  Any help would be appreciated. Thanks!
  5. I have an analog output card 1734-OE2V and there is in the fault/actions page parameters for program mode. What is program mode and when it is activated? Fault mode is clear but... Program should be written the value, but when this happens?
  6. Kinetix 6000 drive Gurad

    Hi,  Can someon help me with the following question. Like what makes a Kinetix 6000 drive a Guarded drive ? What type of safety stuff can you set to make it more safe.  Is it some parameter ? I am bit confused, by the manual. Should I active it in the PLC program or how ? Or it is some setting like a safe speed or torque.  I would really appreciate any help. Thank you so much ahead.  Have a great day, thanks for the reading.
  7. HMI user

    Hi! I would like to ask your help. I have a problem with an allen bradley touch panel. I would like to know which user is active. Like maintenance, administrator... Is there any dedicated tag to decide and  to convey it toward the plc (also ab). If there is none. Can anybody suggest an alternative solution ?  Thanks ahead in advance. 
  8. I have a Siemens HMI 6AV2 124-0MC01-0AX0 in my machine. I want to clone the display on the HMI to PC/Laptop. My question is: 1. What software that I need for this task? 2. What kind of interface that I need between the HMI and PC/Laptop (for example ethernet cable, etc)? 3. Do I need to communicate with PLC connected with HMI or can I just connect with the HMI? Thanks in advance for the answer.
  9. I want to take data from an AllenBradley SLC 505, and send it to an Omron NX102-9000. Specifically F8: 46 from my SLC 505, which is a temperature sensor. Both PLCs are on the same Ethernet network, each with its own IP address. Have you tried it?
  10. MDS instruction would not complete

    Hany any you of guys dealt with MDS instruction not completing and being stuck on .EN bit but the motor itself just stopped running out of nowhere? I did read the tech note on this on Rockwell's website. Am mostly wondering if any of you have dealt with this and what you did to fix this.
  11. I am looking for how others have set up vertical axis motions using the Kinetix 5700 servo system. I have a 2 axis pick/place unit with a horizontal axis (X @ 2500mm) and vertical axis (Z @ 1200mm) that works as designed during normal operation. X axis has no holding brake and Z axis has a factory installed 24vdc to unlock brake. There is a GuardLogix L81ES control system that handles the safety and control. On pressing E-stop/opening Gates the vertical axis will stop the motion, apply the brake and hold with no problems. (2198-D032-ERS3 Drive, 2198-P031 Bus Power, MPL-B430P-MJ72AA X Axis, MPL-B330P-MJ74AA Z axis) The issue that I ran into was an accidental download of the program without activating the e-stop and the vertical axis dropped unexpectedly when entering program mode on the processor. I am aware that this instance was my fault as the programmer, however I am also concerned that this might occur again in the future if the controller ever enters fault mode or someone else completes a download. I have done some investigation with the "ProgrammedStopMode" parameter on this single motion axis and attempted all 5 options and the vertical axis still has a free fall drop for a second before the brake grabs hold - so evidently this is not working for me. (Page 24 of Vertical Load/Holding Brake manual - https://literature.rockwellautomatio...t003_-en-p.pdf) I am curious if there needs to be something done elsewhere as the X and Z axis are set up as coordinated axis? I also am unaware if I need to preform some action/parameter with the bus power supply for this? The current state of the machine as it sits now is preforming a MSF in manual mode after 5 seconds of inactivity or 30 seconds in auto mode. This axis is usually in demand every ~22 seconds. This will shut down the axis after preforming a brake test on the vertical load and seems to function OK, however it is still in the back of my mind the issues mentioned previously if we ever enter a controller fault while indexing. Thanks for your insight
  12. Square Wave Problem With Micrologix

    Hello all, this is my first post. I am using an AB Micrologix 1400 (1766-L32BXB Ser C FW 21). I was trying to generate a pulse train using the PTO instruction. I have modified PTOX funct. file. The ladder is just a simple XIO followed by PTO, (The Quick Start ladder from 1766-RM001). When I looked at the output waveform on my oscilloscope, I noticed that it wasn't a square wave. I decided to run it at several different frequencies to see how the wave form would change. At 10Hz i got a square wave. As I increased the frequency the falling edge became sloped and almost horizontal. Is this how the output should behave? The data sheet indicates a max frequency of 100kHz, but at frequencies over 150 Hz. The wave form looks like the output of SMPS. 
  13. Simatic logon

    hello everyone I have a problem with Simatic logon..  in startup window i have some buttons that have authorization according to their work.. when i work with only user administrator every think is going according to me.. when i enable logon after that login was successful but when i click on button there is messages " not operator authorization " plz help me... wincc user administrator or Windows user name both are identical..
  14. I'm working on simple structured text program which takes in DWORD values, does some math on them and then outputs in DWORD type. What data type should I be using and how can I make this work?  This is one of the lines from the code(everything DWORD) and I get 'operator not supported by DWORD data type' XPos3 := XPos1 + (2*XIncrement);  
  15. UNABLE TO MAKE CONNECTION

    TRENDS ARE NOT SHOWING ON MY FTVIEW SE V8 . AS DATALOG MODEL STARTS IT SHOWS UNABLE TO MAKE CONNECTION IN DIAGNOSTIC VIEWER .  YOU CAN CHECK THE SCREENSHOT FOR THE SAME . I THINK DATALOG MODEL IS NOT ABLE TO CONNECT TO SQL DATABASE . WHAT MIGHT BE THE PROBLEM ? Please Help Guys .....
  16. Can anyone explain to me what this would mean in a COP instruction? Source: #N[N187:4]:[N187:5] Dest: #N[N187:1]:0 Length: 20 I am doing a PLC5 conversion to rslogix5000 and some (most) of it has been a nightmare -.-
  17. Connection cable for Sinumerik810

    Hi, I am trying to connect my M2 pg with a Sunumerik 810 cnc.    does anyone have the part number or pin out of the 25 pin-25pin tty cable that’s needed for this.    thanks   
  18. Dear automation friends,   I just like to put some issue in the clear that I have seen no reported issues on yet, but it is killing me. Maybe some other people in the world also have this issue. We use Windows 2016 on FT View v10. All patched with all compatible patches (both Windows and Rockwell). We install this software a lot but we only got this issue seen/reported on windows 2016. I never had a Rockwell issue that took so long without getting it fixed. Support is also not really helping.   We just have a setup of Windows 2016 with 2x redundant FT View Servers and about 10x Clients with each 4x screens. The HMI clients run perfectly but every few days, 1 application (on 1 of the 4 screens) just crashes "DisplayClient.exe application crash...". That closes the HMI interface and then the users needs to click on the hmi.cli file to launch that screen again. Refering to ntdll.dll in the windows events. No additional info except for the windows error reporting that is unable to contact the internet to send the crash report. Looking in the FT Diagnostics, it happens while the operator is operating the hmi screen. Not when there is no activity.   We reinstalled 1 client completely from scratch, including the OS, domain integration, everything brandnew. And 10 hours later: crash on 1 of the 4x screens. In a control room with almost 30 screens, this is very annoying and unacceptable.   If you have a similar issue or got the issue fixed, please let me know. If you have a similar issue and don't have it fixed, we can share more detailed logs.   Best Regards,
  19. Does anyone have any tips or tricks for generating UDT Templates from an excel spreadsheet? It says in the help files you can copy/paste from excel into the UDT Template, but it seems to only allow that cell by cell, instead of the whole table of data. This is painfully tedious when building larger interfaces. I've tried saving the spreadsheet in various formats (CSV, PRN, tab delimted txt) and I've tried various versions of RSLogix from 23 to 31. I can't seem to find any detailed info on how to do this. I've seen some other forum posts regarding using scripting to generate the XML to import the UDT, but I don't understand why I can't simply copy and paste the info in. Is this really that difficult? Any help would be greatly appreciated. Thanks Otto
  20. Hello everyone, I have a problem with packing machine. There are some issues with one of the axis, when axis actual position is near to 1800000 some error appear and operator has to turn off machine on main contactor. This axis is working in Linear mode. I think that rotary mode would be better for this axis. And here is my question. Which instructions, and what options i should change/check when i change count mode in axis's options. Can any1 point me some manuals to read or give me some advice ? Thank you in advance.  
  21. Hallo.  Can someone shed some light on how much memory st takes ? does it use more that traditional ladder? i find that a routine with a couple of thousands of lines uses over 500kB is there any tricks to lower the usage? Or is it just what it is, and buy bigger cpu’s
  22. PLC occasionally going out of Run mode?

    Has anyone had an issue with Siemens plc's occasionally going out of run mode? I was doing some research and found that it could be due to a bad analog input. Is there a way to tell which input or output is causing this fault? I know I can create a hardware diagnostics error organization block but that only correct from what I've read.     Edit: I've added a screen shot of the diagnostics report. The fault that may be the problem is: Temporary CPU error: Serious firmware exception  CPU changes to DEFECTIVE mode (system reaction)  This plc / system was installed 2 year ago and we've had this problem occasionally since. I'm guessing the wrong firmware was used during the install. Will try upgrading firmware this weekend.   
  23. CompactLogix E/IP to Kuka KRC 4

    Hello everyone,   I need to communicate a CompactLogix to a Kuka KRC 4 by Ethernet/IP but I do not know to generate the EDS file..... any clue please ?
  24. Hi all I have a project where i am building a bread softness tester.  To do this i am using a smc electric actuator and an A&D scale. The electric actuator will push down on a slice onto an A&D scale.  A micro830 plc is then reading the data from the scale and storing the real variable in an array 80values long.  I would like to display on the hmi (panelview800) the peak/maximum value in the array. I am struggling on how to do this though and have not found much information online. any help would be much appreciated Thanks in advance Trevor
  25. I keep getting a 404 whenever I try downloading anything. Is anyone else having this problem?