Search the Community

Showing results for tags ' architecture design this driver can be conviniently used with visual studio in development of complete large scale complex hmi/scada systems. it can be used to perform advanced reporting mes'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 344 results

  1. Hi:         I am planning to use NX with Encoder Card  couple with Omron Rotary Encoder for measuring product length. ( GX-EC0211 /EC0241) or may be (NX-EC0112, I read there is proble with this card , here https://forums.mrplc.com/index.php?/topic/34896-problem-pulse-reading-with-fast-counter-card-in-nx2/ ), but whatever it is I need to know is there any specific Instruction in Sysmac Studio that is tailored for Fast Counter or Encoder (something Like PRV in CX Programmer or special function in CJ-CT021 where start/stop counter and changeable preset counter are available).  The Length measurement is straight forward and is only a small part of the overall program.  Basically is Start ---> measure to length----> Cut --->Repeat again.  I read through the Instruction Reference Manual and I am unable to find one.   Anyone have any idea or any sample program (Sysmac Studio only ) that I can refer to ?    Thanks     
  2. Ok, so I was tasked with setting up a virtual for our development team to be able to use to quickly deploy projects hmi, emulated plc, and studio 5000 project together on one virtual.  The main reason for this is when we get a project, many times we have to wait for an available plc.  We have plc’s in our rack but they can’t be used because they are being used for other projects.  I’ve used the compatibility matrix that Rockwell has but my boss wants to stick with Windows 10 Professional like we do in most our projects but according to the matrix, it looks like having FactoryTalk View SE Enterprise version 10, Studio 5000 Logix version 33 and Studio 5000 Logix Emulate version 33, FactoryTalk Gateway 6.11 and RSLinx 4.11 (mainly for communication to the emulated plc) but in the matrix says Windows 7 and Windows Server 2012  is the best choice.  I’ve ran into issues with Emulate opening, it takes up to 20 minutes to open.  Our licenses are on a server and accessed using FactoryTalk Activation Manager and all the activations are there.  Any suggestions would be appreciated.
  3. ROTARY AXIS POSITION ERROR

    Our C axis which is a rotary axis doesn't perform commanded postion, for eg if we give command of 360 deg, then it will only rotate 359 deg and for next time it will rotate 358 and so on for every rotation. i.e for every rotation its complete degree is reduced by 1 deg.  And system doesnt show any error.  By providing command of 360 deg, if we rotate or axis for 15 times then the last position at which it will stop will he 345 deg.    Please share valuable inputs to resolve that problem.
  4. Datamap Tests

    Hi All, Bit of a noob here. I started a new project where the client is upgrading their SCADA system, and as such every discrete needs to be toggled, and every analog range needs to be tested. I've created an excel database with every register, however, changing the value in the tag is too manual for me and I'm trying to find a way to increase the automation. I am looking for a solution where I can write directly with the tags instead of fumbling through the horror which is Proficy. I've seen some mentions of using the trial version of Ignition but I am struggling to get that to a useable state.    Any ideas greatly appreciated.
  5. Mitsubishi PLC with Fernhill SCADA

    Hi, Has anyone here has experience of using Fernhill SCADA with Mitsubishi PLC FX3U Series? I want to monitor PLC's data in real time through FX3U-ENET-ADP ethernet adapter using Fernhill SCADA software. Thanks in advance for the answer.
  6. Hello, I am trying to have single press and double press etc. functionality in my PLC program where for example, single press will turn on the motor whereas double press will turn on the motor for 5 seconds. Is it possible to achieve using ladder logic in sysmac studio, if yes, how? Thank you in advance.
  7. This is my first post so let me know if there is anything wrong with my post. I am learning Studio 5000 right now for an internship and created a simple project involving a pushbutton and some LEDs. Now I am trying to create an HMI for it in View Designer. My problem now is that I cannot establish a connection to the project because I do not have a physical HMI connected to my plc (Logix 5380). I can't find any way to emulate an HMI module so that I can get it to run. When I emulate my HMI project it tells me "Unable to reach controller TEST" where test is the name of my plc program. I added a module that matched the model in my HMI program (panelview 5510 2715p-t7wd) which I arbitrarily picked at random. But when I go into references and try to add HMI to Controller Path it does not show up (I'm assuming it's because it is faulting in the plc program since it doesn't actually exist). Is there not a way to emulate an HMI or add a virtual HMI to my studio 5000 program that I could connect to from View Designer?
  8. OMRON SYSMAC STUDIO

    In omron Sysmac Under configuration tab --- axis setting----- Operation Setting  Under Monitor Heading there is a term " In-Position Range" and " Zero Position Range " what does these term means and what happen if we increase or decrease value under these term.  Image was not attached, as it was failed due to some reason 
  9. DWord to Data Types

    Hello everyone, In Siemens and Rockwell I am used to transferring a double word to a tag that has a UDT data type of 32 bools. Which the binary bits (31..0) of the double word would align with the bits in a UDT data type of bool. If it was in a function block in Siemens I would call the double word address and move it to Area Register Address and transfer data to a tag of udt data type internal of the function block or could call a Move Block as well which will byte swap the bits but can be fixed with an STL call instruction (CAW). Since I am new to Sysmac Studio, how would I be able to do this? Looking at every Data Movement and Data Type Conversion functions all want a form of an array or elementary type, some wanting source and destination to be the same type. Any ideas?
  10. I am pretty new to the SCADA world. I wanted to know what are the advantages of using a paid proprietary SCADA software such as WinCC, Wonderware, cimplicity over free software such as OpenSCADA, OpenAPI, IndigoSCADA and so on. I have read, there are more layers of security in the paid one. What does that mean? What are the other main differences between the paid and free ones out there in the market?
  11. Union

    Hello! I am trying to get hold of the bits in a word, i have read that union is the way to go. My problem is that i cant figure out how union works. I have made a union between a word (16bit) and an array(0...15). The way I understood this was that the word now automaticly updates the array so that when the least significant bit in the word should update array[00] and so on. This is not happening. When I monitor the variables I can see the word change, but nothing happens with the array. Have I misunderstood the consept and what should I do to get hold of the bits?
  12. Our IT department is on their annual crack down on administrator access and 'unauthorized' software. This year they are demanding to know why I need to run my laptop with administrator access. Besides the Simulator, what other functions will I not be able to use without administrator access? 
  13. CPU to Advaced HMI slow response

    HI all,  I have connected my CJ2M-CPU13 to Advanced HMI software via Hostlink (19200,7,2,E ) .  I connected to the serial port in CPU and just used ( didnt write any code or formating).   The HMI response is very slow ( almost 2+seconds).  I am not sure whats is wrong, Is it because i am using more words?  Anybody had this encountered this problem? Appreciate all suggestions and advices.    
  14. Hi guys, I just starting to use Sysmac Studio. Its a bit confusing as I am currently used to CJ series PLC. Usually, we can use P_1sec, P_0_2s and so on to create a simple clock pulse timer function. However, I couldn't find the command or FB to do that in Sysmac Studio. Anybody could explain on how to do that in Sysmac? Thanks 
  15. I am having a very weird issue that Rockwell was not able to help with.  I have a new SE application that I converted from RSView32 and I re-wrote some VBA code associated with the project.  The code works fine on the server while the screen is running in studio.  Once I deploy a Client it no longer works.  It just sits there like its waiting for my trigger to go off, but I am seeing it sit there with a 1 so i know it should be executing the code because as soon as i open the screen in studio and press play the code executes and my data is there.  Does anyone have any ideas for me?   Thanks
  16. Ok so I recently got the Factory i/o software to practice plc programming more in depth.  I got it working easily enough with the siemens TIA software and I am now trying to get it to work with the Omron Sysmac Studio software.  I am not sure if it is possible or not.  I have access to the hardware but I was really hoping to use the simulation like I can in TIA.  Any insight would be appreciated on the subject.
  17. Sysmac Studio 1.31.0.10 crash sometimes, often when copying things like color palettes, string in the Output Window, etc. It's always with NA not NX. I have a corrupted project because Sysmac Studio crash and save the project. NEVER use this file, restarts with the old file is better. The text fields does not appear on all objects on the HMI and it's never the same object each time your download to HMI! Check images below. Font is "No Value". Do you know how to resolve this problem?
  18. I am trying to display the time from an Accumulation timer. Using a data display object I am able to see the time in the following format 00:00:00.0000000. Is there a way to format the time without the decimal seconds I just want to see 00:00:00 (hours:minutes:seconds)
  19. As the title says, Studio 1.40 crashes if I try to run it in VMWare Workstation (version 14.1.8). I had to disable the "Accelerate 3D graphics" option in VMWare in order to install this upgrade, this has never been an issue before on earlier versions of Studio. I thought I could then re-enable it but this causes Studio to crash as soon as you start it up. I've not spent any time running it with 3D graphics disabled to know if it can run stable. Or if having it disabled causes problems with Studio or other software on my Omron VM. Has anyone else experienced this issue or have any insight?  
  20. Hi All, Hope you all doing well in this pandemic life.  I would need your expertise with an issue I have been struggling with for past few days and thought to reach out here. I am working on a migration project with GE PLC and Citect SCADA 7.10. The GE PLC is migrated to ControlLogix L74 Rev24.10 while Citect SCADA is retained. For testing I only have L71 and L82 and could not managed to organise L74. When the code the loaded in L71 and connected to Citect, I cannot see tags in Graphic page but I see the subscription.txt in Debug folder shows all tags good . The same code when loaded in L82, the Citect works instantly.  Does anyone know this behaviour of PLC and SCADA? Regards, DeeEngr    
  21. Hello all,   My coworker is running into an issue where his version of Sysmac Studio has been updated, but this is causing a version mismatch from an existing project.  He has called Omron, and they are saying that there's no way to downgrade the OS.    Project operating system version = 7.4.0 Device Operating System version =  7.3.0   So the OS on the NA5 would need to be upgraded to match the version of Sysmac.  Does anyone have any suggestions to revert the automatic upgrade that has occurred? Any help would be appreciated!
  22. Hi guys I am trying to connect a Mitsubishi FX5U PLC to a Siemens WinCC RT Advanced. I did find a document on the Siemens side on how to configure the HMI, but I can't seem to find any instructions on how to configure it on the Mitsubishi side. Any help, sample will be appreciated.   Kind Regards Morne
  23. Hello All, First time working with PLC. Get the hang of it from stuff I researched. Having an issue with an axis setup for a servo motor.  When I try to do an auto tune it gives me an error that axis is not configured.  Source: Config Fault    Condition: MotorDeviceCode- INvalid attribute      ACtion: Immediate Stop Fault Entry: Type 8, code 9 subcode: 1314 stopaction: 4 Statechange: 3   I was wondering what am I doing wrong? Any leads or source information I can use to solve this. 
  24. Hi, I'm fairly new to motion applications and I have an interesting (to me) problem to solve. I'm using Kinetix 5700 with MPL motors to drive a pick&place carousel and a conveyor belt. I have a virtual master that driver the carousel in 1:10 ratio. The virtual master also drives the conveyor belt, the ratio is given by the carousel diameter and the conveyor driving cylinder diameter +  2x the belt thickness. And I'm using MAJ to drive the master and the MAG instruction to drive the carousel and the conveyor. This all works well. BUT: the carousel does not pick the product in the same place every time. That creates irregular gaps, or pitch, between the product on the conveyor which causes some issues down the line. Is there a way how to superimpose a value to the conveyor axis to ensure the pitch is regular at all times. Something like the ADDAX instruction it Trio motion controller for example? I'd want to have a sensor that detects the edge of the product and compares he encoder value to an expected value and slows downs or speeds up the conveyor accordingly. Thanks a milion.
  25. Hello Guys, I am very new to CIP messaging and in our project, we are trying to Controllogix to SCADA server using CIP messaging: What I understand from the process right now is : 1. SCADA Opens a connection for Large forward Open ( Connection size set at 2500 bytes) 2. PLC responds and establishes a connection 3. SCADA send an MSP request to access tags from PLC 4. PLC responds to this request The problem we are facing is the PLC doesn't send out a response of more than 240 bytes, Have any of you guys have faced a similar issue or can help me with troubleshooting?   Thanks in advance Attached screen captures from wire