Search the Community

Showing results for tags 'omron cj2m cpu32'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 212 results

  1. Hello all, I have a Omron 3G3MX2-AB004-V1 Inverter (VSD) connected via EtherCAT that I need to reference (home) and also perform a relative move. I am looking for a Function Block with the following Inputs/Outputs for my Omron NX1P2-1140DT1 PLC for use in Sysmac Studio. Inputs - Takes the Encoder signal as a Position obtained via a Motion Control Axis (setup as an Encoder axis) - Takes a Homing sensor input (Sensor triggers on each conveyor belt cleat) - Take either a Reference or RelativeMove signal (to Home the inverter or MoveRelative respectively) - Takes the distance to move for a RelativeMove Outputs - Forward - Reverse - Velocity - Done - Busy - Error Has anyone done this before from a PLC FB for this inverter who could help me please? Many thanks, Richard
  2. cpm1a and ns5

    how to connect cpm1a to ns5 hmi? cant do it
  3. Here is a link to a thread on a recent post showing how to communicate serially to an Omron PLC using VB.Net. This uses the Omron Host Link serial protocols. (C-Mode Commands) It will read 10 DM registers and display them on the form.   http://accautomation.ca/implementing-the-omron-host-link-protocol-vb-net/ Here is the source program that can be downloaded. Other links: VB6 Program: http://accautomation.ca/how-to-implement-the-omron-plc-host-link-protocol/ VBA Program: http://accautomation.ca/how-to-implement-the-omron-host-link-protocol-part-2-vba/ Regards, Garry www.accautomation.ca
  4. Retain Memory CJ2m-CPU31

    Hi All, Just to verify if the "memory card" , in attached document Page 4 highlighted area ,  provides Omron CJ2M CPU21 to retain memory when powered off? If yes, for how long can the memory lasts without being charged? Isit capacitor or battery? Thanks in advance. Regards, Summer cj2m-cpu31.pdf
  5. Hi, I have some trouble with a CJ2M-CPU33. My client did a backup to memory card earlier today, and after this we did some changes through remote link. Now the client wanted to restore the previous backup to the PLC and has done so, but the system would not function correctly. After going online on the PLC it seems like the PLC is stuck in "Stop/Programming Mode". When trying to change to "Monitor" or "Run" mode a dialog comes up containing the following message: "Failed to change the operating mode. The operating mode may be still changing in the PLC."  - All the dip switches are set to off after restoring backup - The PLC has been rebooted  - I have downloaded the application again through CX-programmer  - Verified that the PLC is set to start up in "Monitor mode" But nothing helps. The same message comes up when trying to change the operating mode.  Hoping anyone can help to resolve this issue as it is very critical for us and the client. In advance, thanks for any tips or help received. Best regards Stian
  6. Hello         I'm new for PLC, I need to set pump turn ON/OFF  in 4 time/day every day => [8:00-8:10]a.m, [11:00-11:20]a.m, [2:00-2:10-14:10[p.m, [5:00-5:20]p.m ** I have Omron PLC CP1E-N30 , Could you advise me, please ?  
  7. My apologies for being a newbie on this, but could someone save me on this... I have a Viper 650 and an eMB-60R controller which I want to control by ePLC connection using an NJ501-1300 PLC unit, SYSMAC Studio with EIP Adept Library for Robot... All are starting up well, and I connect all components to a switch hub...  But following the ePLC guidelines, the IP Address showing on the controller is 172.16.132.111 I change the IPV4 IP Address on the PC settings to 172.16.132.10 and the subnet to 255.255.0.0 but the Adept IP Address Setting Tool on SYSMAC doesn't detect the Robot IP Address, also i tried ipconfig on command prompt which shows a different IP Address IPV4 169.254.197.75 and subnet of 255.255.0.0, I changed the previous setting on the PC setting to 169.254.197.10 with the same subnet. But still PC doesn't recognize. I tried both configurations if ACE Software can detect it but the same ACE can not detect it also... Appreciate any thoughts on what's wrong in my configurations. Thank you.
  8. I am using CJ2M PLC.I want switch on a output for certain time by a timer and holding bit if interlocks satisfied.If interlock not OK timer has to hold the time and output should be off. if again interlocks OK again output has to ON upto balance time completion and has to give timer done output for reset holding bit.please suggest.
  9. Hi, I am trying to do a merge move on 1S Servo. The condition are as follows: Task: Move 2 in(absolute value) and then Move back to 1 in (absolute value). I have to do this move 10 times in a row.  The application is material leveling after dumping in the mold. The only question i have is if I use just MC_MoveAbsolute command, the only buffer mode for transition available is velocity. Is there a way i can do it with position. I dont want to stop when I can go from 1 to 2 and 2 to 1 again and again. Its time consuming. But rather a nice oscillation motion without stopping to mimic leveling. Can anybody please help me out with this problem.   Thanks
  10. CP1E-N30DT with Hyperterminal PC

    Dear Expert, i'm issue to do communication CP1E with PC via RS232. im try to use plc for sending information and receive by hyperterminal pc. after googling some information there have multiway to success. by the way until now cannot settle. please expert share completed setup that's work: 1. communication cable from PLC - PC (my information use pin (2,3,9 jumper 4&5) - (2,3,5 jumper 7&8) 2. sample program that works (im using TXD & RXD with memory D1000 to keep data) 3. connection cable to PC using MOXA Serial to USB converter. 4. plc serial setting (default: 9600,7,N,1,Host link) my target to give instruction to printer to start print. printer need ACSII code. if this communication success i'm will convert all data to ACSII by ACSII convert function.   thanks,
  11. PC send data to PLC

    Hello, i'm newbie for plc. i want to ask about PC/computer send data to PLC CP1E with serial communication (RS232). my wiring cable is: PC                         PLC 2                             2 3                             3 5                             9 4&6    7&8                               4&5 and if i send data from PC to PLC, my indicator in COMM is blinking. i think the cable have no problem. but if i send data from PC to PLC, the memory is not same as what i send and whatever i send data, the memory didn't change. i will attach my ladder diagram. what should i do?    New folder.rar
  12. So I did this simple Function Block, pretty simple, and yet it keeps giving me this error, after a bunch of failed combinations the error persists, without telling me whats wrong. And therefore won't even allow me to download the program to the PLC (CJ2M CPU31) or even simulate.   I heard it's a simple thing to fix but I really dont know how to, since I'm quite new to this. Here's the function block  itself in the picture and the programming inside it, although since it gives me no errors, i don't think that would be the problem
  13. Hello, I need to Synchronize two 4kW motors connected to their own individual AltiVar VSDs. To put it simply the two motors are pulling cables on a pulley and when loaded the motor's slip and the speed varies. I have an Omron CP1L-EM PLC and 2x Omron Rotary Encoders ( E6C2-CWZ5B encoders - 360 PPR) - connected to each motor,   What is the best way to read the pulses from the two rotary encoders then convert to RPM? 1) Using  PRV or PRV2(883) instruction,  - this would be the best option as it would convert the value to RPM - however, can I use this instruction on both Counter 0 & Counter 1? 2) Or read the raw value from  Counter 0:  A270 (connected to motor one's encoder) Counter 1: A272 (connected to motor two's encoder) Convert the pulses to RPM - then compare and adjust? 3) Or using CTBL. - is this a useful instruction for this application?   Once I get the RPM speed from each motor - I can then do a compare instruction - see if there is a mismatch and if so send a scaled analogue output to the VSDs to correct the speed if required. (10-50Hz) What would be your recommendations? any help would be most helpful. Thank you.
  14. Homing servo motors

    Hello everybody, I have a question about homing servo motors. I have a project with new servos from Omron and I would like to know what is the best way to do homing for the servos and how often. Before when we have servos with encoders I was making special homing sequence and was calling by some event. I heard that new servos from Omron pretty smart and remember own position without batteries. So with this 'new generation' of servos what is the key to keep machine robust, easy for motor replacement without useless programming stuff. Regards, Scotty
  15. ANALOGIC BIPOLAR OUTPUT - HELP

    Hello everyone,   I'm a student who recently started programming, and I could really use some help.  I have a CPU-31 CJ2M OMRON PLC and a ADO41-v1 analogic card. I need help programming an analogic scale with a bipolar signal -10V to +10V to then control a drive, which will then control the motor. If anyone could help me out of give me some examples I'd be really thankfull.   Thanks!
  16. CX-Designer

    Hi Brothers! I need your help, currently I'm trying to connect the PLC Omron CP1E  to CX-programmer and it works, but my problem is in cx-designer, as I test the program, I have trouble in selecting connect to PLC, please see attached file. What should I do?  Answers would highly appreciated. Thanks
  17. I currently have certain amount of Recipe data located in form of Excel file on to a PC with static IP address. Is there a way to get that data inside the Nj501 without using an SQL server as I currently have NJ501-1300 which doesn't support SQL. I am okay to send data to the SD card I currently have on NJ PLC as it is easy to get data from SD card to the NJ501.  If there is any example code or a link that helps me create i would be helpful. Thanks in advance. FYI: I am currently using NB10 HMI with NJ PLC.
  18. Omron cp1e power indicator turns off

    The plc runs for a minute and then the power turns off while the supply voltage is ok. I was sure that it is for the power circuit problem inside the plc. As I had a spare power circuit of cp1h and I checked it had same voltages output (5vdc, 24vdc & 0), I replaced it. Now I cannot connect it with my laptop to change to run operating mode. Could anyone help me?
  19. Adept Omron Smartvision MX

    Hello, new user here also a new user to all Adept Omron products as well. I have seen a lot of information based on the Omron Smart Controller EX - mainly connecting the controller to the Adept Ace program. I do understand that the dongle is needed to enabled into the controller, but can this same process be the same for the Omron Smartvision MX?  Thanks.
  20. Who Have Someone connected Citect with Omron CJ2M CPU32 ? Can i use it? Device communications wizard -> CJ Seres PLCs -> Ethernet    or need to Finsgateway software.    [Setting] 1. Boards TCPIP / 0(Address)  2. Port -I192.168.100.10 -P9600 -U (*PLC: 192.168.100.1 , PC: 192.168.100.51) 3. I/O Device 0/1/1/      /   OMFINS3    [MANUAL]  ----> Fallow the manual ONLY CS1, CV Need to setting  w/n/u/V  or w/n/u/S CJ2M do not need to this setting ?       I/O Devices Form Complete the I/O Devices form as instructed, with the following specific information. I/O Device Address The station address for an Omron CV Series PC is specified as follows : w/n/u/V for CV mode or w/n/u/S for CS1 mode where w is the FINS network address (1-127) n is the FINS node number (1-126) u is the FINS unit address (0) There are no defaults for w, n, or u, but if you do not specify a mode (with a V or S), it will default to CV mode. The FINS node number should be the same as the IP address node number. The FINS network number should be the same for all ETNs on the Ethernet segment. There is no relationship between FINS network numbers and IP network numbers.   Thank you..
  21.  Hello    I need to sent data between PLC CP1L-M30 and  Hyberterminal with serial port (RS232C port 1) ,but there isn't data show up . something is wrong? Could you advise me? my ladder as below  
  22. Hello Omron programmers, have a nice day to you all. I just need your help in this, i hope you have explanation.  I added a few sequence to the machine with compare instruction D2255 and D2259 as memory data. I really wonder what’s going on. D2255 a decimal value of 9, when it transferred to compared instruction it’s 9, but when D2255 become 10 or above, when it transferred to compared instruction it will become 16 or above, there is an additional of 6 to the decimal value when it more than 9. I attached the photos of it for more details. Can somebody please help me? Thank you.            
  23. I am trying to use FINS/UDP network to communicate with a Siemens device (at a customers site over seas from my home office), today I attempted to set up a SEND command based on information my customer received from a local Omron representative but had no luck.  I feel like I am missing something in a setting somewhere, does anyone have experience doing this?  I am using a CJ2M-CPU35's built in Ethernet IP port which is also communicating to 5 other Omron devices over Ethernet IP, so I am wondering if there is an issue having both networks. Thank you!
  24. Any tool to simulate Ethernet/IP for omron PLcs? I need to know the complete packate structure for Omron Ethernet/IP over Omron PLCs. I have read that we can use FINS command inside Ethernet/Ip packet . But how to get full pacakte structure.   Please help , it is urgent.
  25. Struct as FB input

    Hello,  I am trying to define a struct as an input variable for a Function or Function Block. For example the function AddDelimiter (This is a standard Sysmac function), has a input variable with the variable type Struct, an it is possible to couple a struct to this input (See picture below). If i try to make my own function block with a struct or Structure as an input data type, i get the following error (See picture below). When I try to define a struct from the data types (In this case struct: Test) it doesn't give a error. But when I try to couple a struct to this input, that is a layer deeper than the function block struct i get the following error (See picture below). How can i define a struct as an function/ function block input? Thanks in advance.