Search the Community

Showing results for tags 'sysmac studio omron'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 545 results

  1.   Mail me for Help if anyone is stuck during coding and settings.
  2. Hi everyone, To explain the problem a little bit: I have 2 systems that are equal, they have 1 PLC, 1 Inverter and 1 Servo Axis (Image01). The devices are connected via EtherCat. The thing here is tht in these systems the PLC and Servo Axis is the same but the inverter is different. My goal is to have the same project on both systems and depending on the inverter detected use the correct program. What worked: If I add the 2 Inverters and 2 Servo Axis on the project on different nodes (Image02), I can detect which is present using the variable _EC_EntrySlavTb[n]. My issue is that if I want to make more replicas of the systems using different inverters I will eventually hit the Axis Number limit for the PLC while in reality I am only using on Servo Axis at a time. What I wanted: I would like to be able to control 1 Servo Axis with 2 different inverters (only one active per PLC) (Image03). What I tried: The axis parameters can be set using a variable of the type _sAXIS_PARAM, however it seems that the option to change the axis basic settings is not available (Manual: NJ/NX-series Motion Control Instructions Reference Manual (W508) page 5-58) (Image04). The axis basic settings is where the definition of the output device plus control words are set (Image05). Is there a work around to solve this issue? I would really like to avoid having to manually change the output device for the Servo Axis every time I make an update on all the systems.   Best Regards, BR  
  3. Hi All,  I am trying to limit the number of character for user to key in data edit . However, I put numbers inside it shows me invalid number of character. Anyone know how to solve it ? Note; My variable is in String Type   
  4. "PLC No Response" NB HMI Omron

    Hello Everybody, I continued to work on project this morning but I seem to be plagued with the "PLC No Response" error. This error will only come up when I assign a PLC address to a particular object.  I have followed the steps in the post(https://forums.mrplc.com/index.php?/topic/39885-nb-designer-hmi-plc-no-response-error-solved/) to try and clear the error but am having no luck. In the screenshot I have assigned the large "Start Process" as a bit button with the write address being W50.00. When the button is pressed it should trigger a bit in the PLC but this is when the error appears. During this test I am connected to the PLC and in run mode with the PLC and HMI address assigned correctly. I have read and followed the section in the manual regarding "PLC No Response" but still no positive results.  I just want to check that there is nothing I have done at a programmer end that could cause these issues. I am happy to provide files. Thanks, Ryan  
  5. Hi there I am working on a project where Omron servo drags a part to a certain position using belt mechanism, But to avoid any slippage we decided to put an external encoder directly on the part. I was wondering what is the best to approach to drive the servo using the position of this external encoder. Is there any way that it can be configured directly with the servo? I am fairly new to coordinated motions, any help will be appreciated. Thanks
  6. Hello! I am working on a quote for a new project that will use EtherCAT but also requires DeviceNet for some legacy components.  Has anyone successfully used the Beckhoff EtherCAT coupler (EK1100) with the DeviceNet Master Terminal (EL6752) and an Omron PLC as the EtherCAT master? My concern is that the coupler will only communicate with the Beckhoff EtherCAT master, but since it is so much more expensive to get the new Omron parts to communicate DeviceNET i am hoping this could be an option.  The equipment is extremely simple and price is a major consideration.   Thank you!!!
  7. Good Afternoon, I am wanting to do two things with and ORMON PLC and HMI with CX-Programmer and NB-Designer. 1. I want to display the current time from PLC on HMI with the real time clock. 2. I want to be able to enter a time on the HMI which will be compared to the PLC time and will stop a process when when the entered time is equal to the actual PLC time.  If I can have some help with this that would be a great help. Thanks,
  8. CP1E won't connect or run program

    Hi there! Today a CP1E-E10DR-D suddenly stopped working. RUN led was off and I couldn't connect to it via USB getting this error: "Selected port does not exist. Select proper port number from Change PLC dialog and press OK button", and automatic online function didn't work as well(it's not a cable/driver problem since I successfully connected to a CJ2 CPU using same cable and PC). Since I also tried to connect with the CPU outside the control cabinet with no success, I asume there is something wrong at hardware level.  My question is, have you ever faced something like this? My plan is to try to revive it somehow (maybe trying to locate any defective component in the PCBs or something). So I was just wondering if you have any advice in order to achieve it.  Thanks in advance!
  9. How to use NB Data Logging

    Good Afternoon All, Just wondering if anyone would have any example code of using the Data Logging on NB designer? I am wanting to use a PID controller and display set point and process variable etc. I have looked in the manual but a coded example would be extremely helpful.    Hope you have a good weekend. Thanks
  10. Hello Everyone, I am writing one logic and need some help regarding that logic.   CURRENT LOGIC -  -There are two timers TON_1 and TON_2. -TON_1 timer will start as soon as PLC turns on. -After the done bit of TON_1 timer, the TON_2 timer goes on. -After the done bit of TON_2 timer, again the TON_1 timer will start. -This logic cycle will run continuously, both timers will run turn by turn. Code (Codesys/Schneider Eco Structure Machine Expert)- PROGRAM POU_1 VAR      TON_1: TON;     TON_2: TON; END_VAR TON_1(IN:=(NOT(TON_2.Q)) , PT:= T#100S); TON_2(IN:=(TON_1.Q) AND (NOT(TON_2.Q)) , PT:= T#20S);   Actual Requirement -  -There is a BOOL tag. -If the BOOL tag gets high during the TON_1 running, the logic should move to the TON_2 immediately. -If the BOOL tag does not get high during the TON_1 running, the logic should move to the TON_2 after completion of TON_1. -after the completion of TON_2, again restart TON_1. -Logic Runs continuously in a cyclic mode.   Give me your valuable idea to fulfill the logic requirement.
  11. hello Every one,    I am using a CP1-L PLC and want to communicate to domino ax350i printer over TCP/IP socket programming. For socket programming, I used Omron Function Block CPU012_SendCommand.  I defined network ID and node address. However, I am getting 0502 error which means routing table is not set yes. So, how can I set routing table for both devices?. my PLC on 192.168.250.1 and Printer is on 192.168.250.123 node 7000.    Can any one suggest me best way to do.  Thank you   attached file is for what I did in setting and program for the communication.      
  12. Good Afternoon, I am new to CX-Programmer so excuse this question.  I have written a FB in ST to trigger BOOL and Integer variables. Within the FB I have written ST with a case statement which is working correctly. The issue I am having is that It seems the integer variables in the FB (HMI_Q_FAN_STATUS) are not being passed to the assigned global variable (assigned to D register) on the output of the FB.  In the attached screen shot, the FB is in case 3 therefore the integer variable should display HMI_Q_FAN_STATUS=3, however is still displaying 0. Any help with this would be great. Thanks and have a good day.  
  13. Hi all, currently I'm using NX1P2 PLC for my project. So I'm just using it to transfer data from PLC to my PC but I faced 1 major problem right now which is the connection. I have few experience working on PLC but this time I faced an issue which I don't know how to solve it. So the problem here is, my NX1P2 can't connect stable to my my PLC, initially I thought it was the cable problem, after I changed several cable it's still the same, so I thought it was my ethernet port problem but I can connect it to the internet and also Delta PLC, at last I thought it was PLC problem so I connected it to my colleague PC, they got a stable connection and able to program it. My ethernet keep on displaying "Enabled > Identifying > Unplugged", I check my Ethernet port, it using Intel(R) Ethernet Connection (6) I219-V. Tried to solve it for few days already, anyone faced this problem before? 
  14. Firmware Update

    I am looking help with an issue I have trying to connect to a 5370 Controller 1769-L33ER. The controller firmware is 20.014 and my studio does not have 20.014 firmware. I have downloaded the firmware and do not know how to get it extracted to my PC. Any help with this will be grateful.  Regards
  15. How do I communicate between an Omron NX1P2 Automation Controller and Indusoft Web Studio. This is the first time using an Automation Controller. I am familiar with communicating between Omron PLC's and Indusoft using OMETH drivers. What driver should I use?
  16. Hello everyone! I am quite new to communications between different brands of PLC's. As I have mentioned in the title, machine has a siemens s7-300 series pn/dp PLC with no CP modules (programmed in Simatic Manager). And they are adding an another machine with an OMRON NX102-9000 model PLC (Sysmac Studio). Siemens side also has PC connection over winCC flexible. Somehow i need to communicate between these two devices. Now, I have been looking into this for a while. There are mentions of sockets, but i have no prior experience with them. From what i ve researched omron has "Send" and "Rcv" blocks, but i cant find my way through on how to use them. For example, i dont know "where" to write in the siemens plc. I feel lost to be honest. Can anyone point me to the right direction? Sample program snippets, documents ?
  17. Hello guys, I experience interesting behavior on NX102 PLC. I have an application with NX102-1200 v1.41 and 7 R88*-1S servos in total. All axes were added as a single-axis position. During servo set-up and tuning we periodically experience a communication error. Connection between laptop and PLC over ethernet. Did anybody have similar problem?  Error message #1: -MC Test Mode was interrupted in the controller. The MC test run is terminated. Error message #2 following error: -A communication error has occurred. 
  18. Virtual Machine Setup

    Dear Colleagues,   I require some help with regards to setting up virtual machines, We have some ControlLogix 1756 PLCs scattered around site running on different version (v20, v21 & v32). My company requires all software installations on company computers to go through IT. Installing all these versions on single PC is really a pain (going through IT)  for new hires and for new PCs. I am trying to suggest using virtual machines for each version that can be shared/distributed among the engineers and also to give engineers some autonomy in the VM environment.    How do I go about this especially with respect to licensing without violating the terms of use both the operating system and the automation software? 
  19. Dear All. I have the issued with NX1P2 when read data from Modbus RTU. the Slave data using 2 INT for Real data. but in the Sysmac Studio I get the data is OK, 2 INT but can not convert to Real data. Can you pls help me to solve this issued. also I want to convert from Real to 2 INT to send the setting to salve. Many thanks.
  20. CP1L-EM40DT-D

    Hi there... I'm working on my final project using PLC CP1L-EM40DT-D. I want to set the stepper motor output pulse to match the 3 types of height I want. I used the PLS2 instruction but the simulation results showed the stepper motor rotation did not match the number of pulses and also the frequency I entered. Has anyone here ever used a stepper motor before? If yes, please help by sharing the exact pulse calculation formula on a stepper motor with a load. I really had a hard time finishing my final project because of this. I beg your help. Thank you
  21. plc-plc via internet

    Hello all, I wonder that is it possible to communicate 2 CJ2M plcs or 2 NJ controllers via internet? Those are far from each other. There is WE70 wirelles unit however distance between them more than 5 km. Any idea how can i solve this issue? Thanks in advance. Have a nice day.
  22. Crane Positioning

    Hey folksI'm trying to make a Ladder program in Sysmac Studio to control a Crane.The crane gets via a HMI a position that it must drive to, first at high speed then in low speed this is controlled via encoder signal for fine positioning there are several sensors.For all this I have an NX1P2-9B24DT1, NX-EC0222 and 3G3MX2-A4030-ESomeone here who can help me with an example of how this can be done in Ladder.Many thanks in advance for your help.
  23. Friends kindly help me I need to create ton and counter macro function in factorytalk view studio 
  24. Hello! I have been working with a Factory Talk Studio V8.0 and my computer was crashed, "blue screen". After this, I can not open my panel project anymore, I only get information Failed to open factory talk private directory for the application. How to save my project?  
  25. Hi. I have a decent workstation I work on when i do my programming. I have been using Sysmac studio for couple of years now and I have always notice it that sysmac studio is very slow.   Have you guys notice that sysmac in general is slow ? /Best regards.