Search the Community

Showing results for tags 'Compare Instruction'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 35 results

  1. I have a problem trying to scale a floating number coming from an HMI to a value to use on PID instructions.My problem is on the scaling instruction.Whenever i try to run on cx simulator it gives me an error My setup of the scale parameters are (using SCL3(487)) D616 #0000 D617 &350 D618 #FFFF D619 #FFFF D620 #0000 My ladder to use the float number is: *F(456) Value +10,0 D2120 FIX(450) D2120 D2062 SCL3(487) D2062 D616 D2072 The error that throws is 0x80F0 Thanks in advance for any help PS Also tried all Scaling instructions.I think my problem is the setup of parameters for scaling instructions  
  2. Hi there! I recently discovered this forum and I find it pretty useful for sharing and learning about PLCs. The thing is I'm trying to make a Stack using the SSET(630) instruction in a CJ2M PLC. Reading Omron's W340 manual I saw that PLC memory address for the different stack channels is represented as "00010000" to "0001000F". So, in order to set the last stack word address as well as the pointer's address, how do you know those values? Or am I just misunderstanding something? Thanks in advance!   Edit: Solved, the definition of the stack was wrong!    
  3. RS2 instruction

    Hello Expert,   I've problem regarding Instruction RS2. I can receive and send data, but my problem is each time I send data it will always add 0 at the back. I define array data for sending:    POU_01/DATA_SEND[0]    769       00000011 00000001    H0301    --    #0301    --    Word[Unsigned]/Bit String[16-bit]    VAR    D2235    %MW0.2235        --   POU_01/DATA_SEND[1]    0            00000000 00000000    H0000   --    #0000    --    Word[Unsigned]/Bit String[16-bit]    VAR    D2236    %MW0.2236        --   POU_01/DATA_SEND[2]    2560     00001010 00000000    H0A00    --   #0A00    --    Word[Unsigned]/Bit String[16-bit]    VAR    D2237    %W0.2237        --   POU_01/DATA_SEND[3]   50637  11000101 11001101      HC5CD    --   #C5CD    --    Word[Unsigned]/Bit String[16-bit]    VAR    D2238    %MW0.2238        --   Data receive on Serial Terminal : "01" "03" "00" "00" "00" "0A" "CD" "C5" "00"  ==> "00" last value I tried to figure out how can it get there ?   I already check for terminator character already set off. I use channel 2 using FX-485-ADP-MB. I set my serial D8420 ==> "0C81".      
  4. RS2 instruction

    Hello Expert,   I've problem regarding Instruction RS2. I can receive and send data, but my problem is each time I send data it will always add 0 at the back. I define array data for sending:    POU_01/DATA_SEND[0]    769       00000011 00000001    H0301    --    #0301    --    Word[Unsigned]/Bit String[16-bit]    VAR    D2235    %MW0.2235        --   POU_01/DATA_SEND[1]    0            00000000 00000000    H0000   --    #0000    --    Word[Unsigned]/Bit String[16-bit]    VAR    D2236    %MW0.2236        --   POU_01/DATA_SEND[2]    2560     00001010 00000000    H0A00    --   #0A00    --    Word[Unsigned]/Bit String[16-bit]    VAR    D2237    %W0.2237        --   POU_01/DATA_SEND[3]   50637  11000101 11001101      HC5CD    --   #C5CD    --    Word[Unsigned]/Bit String[16-bit]    VAR    D2238    %MW0.2238        --   Data receive on Serial Terminal : "01" "03" "00" "00" "00" "0A" "CD" "C5" "00"  ==> "00" last value I tried to figure out how can it get there ?   I already check for terminator character already set off. I use channel 2 using FX-485-ADP-MB. I set my serial D8420 ==> "0C81".      
  5. AVE instruction Error

    A little background information here, I am trying to create a moving average so I accomplished it with the code (imaged attached) The problem i am having is the AVE instruction error bit goes true. it leaved me with a result of 1.#QAN  I did some googling and it said this is typically done when dividing by zero?? so i added a NEQ to 0 prior to loading the array. then it happened again. so i put the error bit in front of the FFL so it will stop loading the array when i get the error bit so i can see what values are in the array when it errors out. Has anyone else had this issue and what could you do to resolve it? I haven't had any luck find something that points me in the right direction. Thanks in advance for your help.
  6. I am controlling the powerflex 527 drive with MSO instruction, first setting the drive on and then running the motor with MAJ instruction. After MSO instruction, motor is rotating about 2 sec and then stops to wait the  MAJ. I have not find any solution for this. My configuration is frequency control, no feedback, sensorless. One hint i found from the rockwell pages but it did not help me. Rated slip speed is set to zero.  
  7. Motion Servo Axis

    Hello everybody,   I have the following situation:   I use the MAM function to move a servo axis; It also moves and stops  correctly when the condition before turns flase. The result is actually good, except that sometimes a readjustment takes place (but only disturbs as I said sometimes). I have been sitting in front but didn't notice anything, only the Operator meant that this happens sometimes   Now I would like to know how this can be stopped. Thank you   What information do you Need to help me further
  8. Hi,   I'm pretty new to allen Bradley and wanted to know if there was a function that could help me out. I have a rotation sensor which feeds back to the PLC via a digital input, once every half second or second once machine is up to speed - I want to record the off time of this DI (how long it is off between pulses, essentially how long it takes for drum to rotate once). Is there some way to record this time and use this value for compare logic? any help would be greatly appreciated.   PLC: Micrologix 1400 series B RSLogix 500 version 11.00.00 (CPR 9)
  9. Hello everybody,   I have the following situation:   I use the MAM function to move a servo axis; It also moves and stops  correctly when the condition before turns flase. The result is actually good, except that sometimes a readjustment takes place (but only disturbs as I said sometimes). I have been sitting in front but didn't notice anything, only the Operator meant that this happens sometimes   Now I would like to know how this can be stopped. Thank you   What information do you Need to help me further
  10. MITSUBISHI FX3UC

    HEY, I'm kinda working on my own label machine and i am stuck on deriving its speed. I have already set the interrupt and acceleration parameters. but the problem i am facing is that i can't understand the ddvit's output pulse and output frequency relation to speed. If you guys know something, please do help. thank you,
  11. FFL problem

    Hi Guys! I have a problem.  I have a leaser sensor, I already set the sampling frequency to 0,1 s. So 1 second I will get 10 data. I need to use the average of the datas. My problem is I dont know how can I solve that, after the 10. data every new data I have to  recount, the last 10 data's average. I think maybe I have to use the FFL instrucion or something like that. I need to solve this problem in ladder diagram. I use RS-logix 5000 software. Anyone can help me?  Unfortunatelly I havent the the software, so I cant show you what am I think.    Maybe the sliding window solution is the right, or is it not related to this? Im a bit confused.
  12. ZCP Instruction

    Hi group! I am struggling to figure out what I am doing with the Limit instruction (ZCP 088).  I want to turn on a permissive if the compared word is between 1 and 12.  Rockwell makes this so much easier!!! It looks like my "=" instruction is not correct but this is how they show it in the manual???????    
  13. Hi my problem may have a simple solution but i cant work it out. I need to use the Divide function but it wont let me use a decimal point in either Source A or Source B. Is there a way to use a decimal point in Logix 500 Math instructions? Im using an AB Micrologix 1400 PLC. Can you only use math instructions with whole numbers? is there a way around this? Thanks James
  14. Hi my problem may have a simple solution but i cant work it out. I need to use the Divide function but it wont let me use a decimal point in either Source A or Source B. Is there a way to use a decimal point in Logix 500 Math instructions? Im using an AB Micrologix 1400 PLC. Can you only use math instructions with whole numbers? is there a way around this? Thanks James
  15. Block Compare Instruction

    Is there a Block Compare Instruction like the one in Omron PLC for Mitsubishi PLC? If the Omron PLC is BCMP (68), then what is the name of the instruction on the Mitsubishi PLC? I tried to use BKCMP in the Mitsubishi PLC, but the way it works is not the same as the one in Omron PLC
  16. RS logix 5000 motion control

    Hi Guys! I have a problem with Motion axis move (MAM) command. There is an Allen bradley servo motor what is working well. But I need to add a new program section, wich is in  a specified moment, the axis should move a certain distance. I think I need to use the mam command, just I dont know how can I configure the motion control part. I need to make a new tag ? or what ? I need to use a user define ? PLS help me.   
  17. Hello Omron programmers, have a nice day to you all. I just need your help in this, i hope you have explanation.  I added a few sequence to the machine with compare instruction D2255 and D2259 as memory data. I really wonder what’s going on. D2255 a decimal value of 9, when it transferred to compared instruction it’s 9, but when D2255 become 10 or above, when it transferred to compared instruction it will become 16 or above, there is an additional of 6 to the decimal value when it more than 9. I attached the photos of it for more details. Can somebody please help me? Thank you.            
  18. Compare not working

    We have this logic (on a CP1E) the desired outcome is as follows: When a bad part is detected, force the operator to index the machine 6 times, using a holding register to prevent a power cycle from resetting the count. once 6 cycles are recorded output that the bad parts are removed AND reset the count to zero.   What has actually happened so far: the count has gone to 6 and not reset. I have used CX Programmer to set the H0 value to zero but the compare still says it's equal (to 6)   I have read everything i can get my hands on regarding holding registers and compare functions and i can't see what is wrong. I have no formal training on this so i'm sure it's something simple. can anyone point me in the right direction?   Thanks guys    
  19. Hi there, I am trying to create an Add=On Instruction to help me manage some alarm conditions in my application. My AOI has one Boolean output that is used for messaging on the HMI, but I'd like to also have another output (Boolean or integer) that would be attached to o global parameter so that if any alarm is activated, it will create a master alarm that can be used for machine control, and possibly messaging. The reason for this is that I may have numerous alarms and I'm trying to avoid having to create a series chain of all those alarms to turn on a master alarm. My thought was that if I can get any alarm to make a global parameter go true, then I don't have to manage other bits if I delete or add an alarm block. I'm having trouble coming up with a way to create that output that I can have load a TRUE value into a global parameter, though.  I was trying to use an integer so that I could just load a '1' into the variable if any alarm goes off, and a master reset would reset the value to zero. But I'm apparently not setting up the AOI parameters just right. Has anyone got a suggestion of how I can do this? I can share my block if that would help, it's nothing special, just a way for me to condense alarming features and this one seems to be a little tricky. Thanks for your suggestions!
  20. GOT 2000 and GT Designer 3

    Hi All, I want ask, maybe only basic thing. But I don't know... Now I'm using GX designer 3 and GOT 2000. has program inside it. Now like this.. I want to know how we can compare to make sure current running program in GOT is same with my current program in my laptop.   2. How to download / Upload program GOT 2000 3.Is possible to download Only which page or screen we needed? Thanks, That's all for now..
  21. Hi everyone, I want to compare 2 programs with RS logix 5000 compare but logix opens the 2 ACD in L5K, with only tags.... thx for your help
  22. Hex instruction is not working

    Hello everyone,  I have a code [HEX D100 D200 k6] data is coming in d100-d105 but in d200 it is zero Data in d100-32, d101-32, d102-50,d103-50, d104-52, d105-32  PLC is Fx 3g And I m also not getting value on simulation in d200. Thanks in advance  
  23. Input number from user to Compare?

    Hello! I want to make a really simple PLC program that compare 2 number. How can I load 2 numbers from user and send to PLC compare operand? Now I go to CMP and with mouse set values. There is any "imput" component in CX Designer? Sorry my poor english :S Thank you!
  24. Can any one tell me how to use FOR instruction in RSlogics 5000 for looping my 36 step runs ...for example I have attached a program containing subroutine having 8 steps in it ...can any one help...? subroutine_loop.ACD Ladder of 36 steps.rar
  25. Hardware config doubt

    Hi guys, I received two different versions of the SW for the same machine. One is saved with the name Q100UDEH and one with Q50UDEH. I was expecting the Q100 to have insite the I/O assignment a Q100 CPU but is has still a Q50. My problem is that I tried to compare the two projects using Project verify and it gives me an error saying that the PLC's are different. Do you know where else I can look to see if the Q100 in set as a CPU besides I/O Assignment? Thank you :D