Search the Community

Showing results for tags 'omron modbus'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 547 results

  1. Hi ! I have to Control and Read an Masss Flow Controller (MFC) MKS MF-1, I have give this one an IP Adress (10.46.103.75). How can I Control it over Modbus TCP? I found in GX Works 3 in Tool/Predifined Protocol Support function the Modbus Menue, but i have no Idea how to Config it, i have no Idea how Modbus works..... Have someone an Example for a Configuration? 
  2. Hello         I'm new for PLC, I need to set pump turn ON/OFF  in 4 time/day every day => [8:00-8:10]a.m, [11:00-11:20]a.m, [2:00-2:10-14:10[p.m, [5:00-5:20]p.m ** I have Omron PLC CP1E-N30 , Could you advise me, please ?  
  3. My apologies for being a newbie on this, but could someone save me on this... I have a Viper 650 and an eMB-60R controller which I want to control by ePLC connection using an NJ501-1300 PLC unit, SYSMAC Studio with EIP Adept Library for Robot... All are starting up well, and I connect all components to a switch hub...  But following the ePLC guidelines, the IP Address showing on the controller is 172.16.132.111 I change the IPV4 IP Address on the PC settings to 172.16.132.10 and the subnet to 255.255.0.0 but the Adept IP Address Setting Tool on SYSMAC doesn't detect the Robot IP Address, also i tried ipconfig on command prompt which shows a different IP Address IPV4 169.254.197.75 and subnet of 255.255.0.0, I changed the previous setting on the PC setting to 169.254.197.10 with the same subnet. But still PC doesn't recognize. I tried both configurations if ACE Software can detect it but the same ACE can not detect it also... Appreciate any thoughts on what's wrong in my configurations. Thank you.
  4. I am using CJ2M PLC.I want switch on a output for certain time by a timer and holding bit if interlocks satisfied.If interlock not OK timer has to hold the time and output should be off. if again interlocks OK again output has to ON upto balance time completion and has to give timer done output for reset holding bit.please suggest.
  5. Hi, I am trying to do a merge move on 1S Servo. The condition are as follows: Task: Move 2 in(absolute value) and then Move back to 1 in (absolute value). I have to do this move 10 times in a row.  The application is material leveling after dumping in the mold. The only question i have is if I use just MC_MoveAbsolute command, the only buffer mode for transition available is velocity. Is there a way i can do it with position. I dont want to stop when I can go from 1 to 2 and 2 to 1 again and again. Its time consuming. But rather a nice oscillation motion without stopping to mimic leveling. Can anybody please help me out with this problem.   Thanks
  6. Please find listed below the NModbus4 console code.  The DataStoreWrittenTo event is not firing when I do the write to PLC C0 relay coil.  Can anyone tell me how to get the event to fire?  using Modbus.Data; using Modbus.Device; using System; using System.Collections.Generic; using System.Linq; using System.Net; using System.Net.Sockets; using System.Text; using System.Threading; using System.Threading.Tasks; namespace NModbus4ListenerDemo { class Program { #region "Properties" static TcpClient tcpClient = new TcpClient(); static ModbusIpMaster PLCModbusMaster = ModbusIpMaster.CreateIp(tcpClient); static string C0_RelayCoil_Address = "3073"; static ushort C0_RelayCoil_BitAddress = Convert.ToUInt16(Convert.ToInt16(C0_RelayCoil_Address) - 1); #endregion #region "Setup Listener" static IPAddress MiddlewareSlaveIPAddress = IPAddress.Parse("10.95.11.34"); static TcpListener MiddlewareSlaveTcpListener = new TcpListener(MiddlewareSlaveIPAddress, Convert.ToInt32("502")); static ModbusSlave middlewareslave = ModbusTcpSlave.CreateTcp(Convert.ToByte("255"), MiddlewareSlaveTcpListener); #endregion static void Main(string[] args) { string PLCMasterIPAddress = "10.95.11.32"; tcpClient.BeginConnect(PLCMasterIPAddress, 502, null, null); Thread.Sleep(100); #region "Set Relay Coit C0 to false" PLCModbusMaster.WriteSingleCoil(C0_RelayCoil_BitAddress, false); Thread.Sleep(50); bool[] C0_RelayCoil_BitValue = PLCModbusMaster.ReadCoils(C0_RelayCoil_BitAddress, 1); string C0RelayCoilBitValue = C0_RelayCoil_BitValue[0] ? "True" : "False"; Console.WriteLine("C0 Relay Coil = " + C0RelayCoilBitValue); Thread.Sleep(50); #endregion #region "Create DataStore and start listing" MiddlewareSlaveTcpListener.Start(); middlewareslave.DataStore = DataStoreFactory.CreateDefaultDataStore(); middlewareslave.DataStore.DataStoreWrittenTo += ModbusDataStore_DataStoreWrittenTo; middlewareslave.Listen(); Thread.Sleep(50); #endregion #region "Set Relay Coit C0 to false" PLCModbusMaster.WriteSingleCoil(C0_RelayCoil_BitAddress, true); Thread.Sleep(50); C0_RelayCoil_BitValue = PLCModbusMaster.ReadCoils(C0_RelayCoil_BitAddress, 1); C0RelayCoilBitValue = C0_RelayCoil_BitValue[0] ? "True" : "False"; Console.WriteLine("C0 Relay Coil = " + C0RelayCoilBitValue); Thread.Sleep(50); #endregion Console.ReadLine(); #region "ModbusDataStore_DataStoreWrittenTo" void ModbusDataStore_DataStoreWrittenTo(object sender, DataStoreEventArgs e) { Console.WriteLine("ModbusDataStore_DataStoreWrittenTo event fired!"); } #endregion } } } I've attached ladder logic screen shots showing the C0 relay coil being set on by the console application. The console application displaying the messages.  Note the absence of the "ModbusDataStore_DataStoreWrittenTo event fired!" message. WireShark showing the TCP Modbus traffic between the modbus master and slave over port 502.   The PLC NetEdit3 Modbus information Paul  
  7. So I did this simple Function Block, pretty simple, and yet it keeps giving me this error, after a bunch of failed combinations the error persists, without telling me whats wrong. And therefore won't even allow me to download the program to the PLC (CJ2M CPU31) or even simulate.   I heard it's a simple thing to fix but I really dont know how to, since I'm quite new to this. Here's the function block  itself in the picture and the programming inside it, although since it gives me no errors, i don't think that would be the problem
  8. Jiskoot modbus

    Does anyone have experience with a Jiskoot Insight controller? Im trying to establish communications between it and a MVI69-MCM. I have checked and rechecked all my settings. I am not sure what I am doing wrong. Thanks
  9. Hello, I need to Synchronize two 4kW motors connected to their own individual AltiVar VSDs. To put it simply the two motors are pulling cables on a pulley and when loaded the motor's slip and the speed varies. I have an Omron CP1L-EM PLC and 2x Omron Rotary Encoders ( E6C2-CWZ5B encoders - 360 PPR) - connected to each motor,   What is the best way to read the pulses from the two rotary encoders then convert to RPM? 1) Using  PRV or PRV2(883) instruction,  - this would be the best option as it would convert the value to RPM - however, can I use this instruction on both Counter 0 & Counter 1? 2) Or read the raw value from  Counter 0:  A270 (connected to motor one's encoder) Counter 1: A272 (connected to motor two's encoder) Convert the pulses to RPM - then compare and adjust? 3) Or using CTBL. - is this a useful instruction for this application?   Once I get the RPM speed from each motor - I can then do a compare instruction - see if there is a mismatch and if so send a scaled analogue output to the VSDs to correct the speed if required. (10-50Hz) What would be your recommendations? any help would be most helpful. Thank you.
  10. Homing servo motors

    Hello everybody, I have a question about homing servo motors. I have a project with new servos from Omron and I would like to know what is the best way to do homing for the servos and how often. Before when we have servos with encoders I was making special homing sequence and was calling by some event. I heard that new servos from Omron pretty smart and remember own position without batteries. So with this 'new generation' of servos what is the key to keep machine robust, easy for motor replacement without useless programming stuff. Regards, Scotty
  11. ANALOGIC BIPOLAR OUTPUT - HELP

    Hello everyone,   I'm a student who recently started programming, and I could really use some help.  I have a CPU-31 CJ2M OMRON PLC and a ADO41-v1 analogic card. I need help programming an analogic scale with a bipolar signal -10V to +10V to then control a drive, which will then control the motor. If anyone could help me out of give me some examples I'd be really thankfull.   Thanks!
  12. Hello, I want control ATV320 inverter through MODBUS protocol. I found, that ATV312 inverter have IEC 61800-7 status chart. I attached picture. I want to ask, maybe ATV320 inverter have same IEC 61800-7 status chart and where need find it. Yesterday I try to find all evening, but don't successful. Somebody could help to me.
  13. CX-Designer

    Hi Brothers! I need your help, currently I'm trying to connect the PLC Omron CP1E  to CX-programmer and it works, but my problem is in cx-designer, as I test the program, I have trouble in selecting connect to PLC, please see attached file. What should I do?  Answers would highly appreciated. Thanks
  14. I currently have certain amount of Recipe data located in form of Excel file on to a PC with static IP address. Is there a way to get that data inside the Nj501 without using an SQL server as I currently have NJ501-1300 which doesn't support SQL. I am okay to send data to the SD card I currently have on NJ PLC as it is easy to get data from SD card to the NJ501.  If there is any example code or a link that helps me create i would be helpful. Thanks in advance. FYI: I am currently using NB10 HMI with NJ PLC.
  15. Leuze MSI430 Safety PLC help??

    Hi all, My Task: To control write to registers to my MSI430 safety PLC from Leuze Electronic using a HMI as a master. Protocol: Modbus TCP MSI430 (Modbus TCP - server/slave) Generic HMI (Modbus TCP - client/master) I'm reading Okay from the Register address 401101-40110 But I'm not able to write to the MSI PLC to address 402101-402109 Please see the attached images for gateway description for the device. Please advice/guide on how this could be done. I have tried using MBPoll and it says Illegal Data Address. Kind Regards NarkO Please find the below link for the manual   
  16. Omron cp1e power indicator turns off

    The plc runs for a minute and then the power turns off while the supply voltage is ok. I was sure that it is for the power circuit problem inside the plc. As I had a spare power circuit of cp1h and I checked it had same voltages output (5vdc, 24vdc & 0), I replaced it. Now I cannot connect it with my laptop to change to run operating mode. Could anyone help me?
  17. Adept Omron Smartvision MX

    Hello, new user here also a new user to all Adept Omron products as well. I have seen a lot of information based on the Omron Smart Controller EX - mainly connecting the controller to the Adept Ace program. I do understand that the dongle is needed to enabled into the controller, but can this same process be the same for the Omron Smartvision MX?  Thanks.
  18. Who Have Someone connected Citect with Omron CJ2M CPU32 ? Can i use it? Device communications wizard -> CJ Seres PLCs -> Ethernet    or need to Finsgateway software.    [Setting] 1. Boards TCPIP / 0(Address)  2. Port -I192.168.100.10 -P9600 -U (*PLC: 192.168.100.1 , PC: 192.168.100.51) 3. I/O Device 0/1/1/      /   OMFINS3    [MANUAL]  ----> Fallow the manual ONLY CS1, CV Need to setting  w/n/u/V  or w/n/u/S CJ2M do not need to this setting ?       I/O Devices Form Complete the I/O Devices form as instructed, with the following specific information. I/O Device Address The station address for an Omron CV Series PC is specified as follows : w/n/u/V for CV mode or w/n/u/S for CS1 mode where w is the FINS network address (1-127) n is the FINS node number (1-126) u is the FINS unit address (0) There are no defaults for w, n, or u, but if you do not specify a mode (with a V or S), it will default to CV mode. The FINS node number should be the same as the IP address node number. The FINS network number should be the same for all ETNs on the Ethernet segment. There is no relationship between FINS network numbers and IP network numbers.   Thank you..
  19.  Hello    I need to sent data between PLC CP1L-M30 and  Hyberterminal with serial port (RS232C port 1) ,but there isn't data show up . something is wrong? Could you advise me? my ladder as below  
  20. Hello Omron programmers, have a nice day to you all. I just need your help in this, i hope you have explanation.  I added a few sequence to the machine with compare instruction D2255 and D2259 as memory data. I really wonder what’s going on. D2255 a decimal value of 9, when it transferred to compared instruction it’s 9, but when D2255 become 10 or above, when it transferred to compared instruction it will become 16 or above, there is an additional of 6 to the decimal value when it more than 9. I attached the photos of it for more details. Can somebody please help me? Thank you.            
  21. I am trying to use FINS/UDP network to communicate with a Siemens device (at a customers site over seas from my home office), today I attempted to set up a SEND command based on information my customer received from a local Omron representative but had no luck.  I feel like I am missing something in a setting somewhere, does anyone have experience doing this?  I am using a CJ2M-CPU35's built in Ethernet IP port which is also communicating to 5 other Omron devices over Ethernet IP, so I am wondering if there is an issue having both networks. Thank you!
  22. Any tool to simulate Ethernet/IP for omron PLcs? I need to know the complete packate structure for Omron Ethernet/IP over Omron PLCs. I have read that we can use FINS command inside Ethernet/Ip packet . But how to get full pacakte structure.   Please help , it is urgent.
  23. Struct as FB input

    Hello,  I am trying to define a struct as an input variable for a Function or Function Block. For example the function AddDelimiter (This is a standard Sysmac function), has a input variable with the variable type Struct, an it is possible to couple a struct to this input (See picture below). If i try to make my own function block with a struct or Structure as an input data type, i get the following error (See picture below). When I try to define a struct from the data types (In this case struct: Test) it doesn't give a error. But when I try to couple a struct to this input, that is a layer deeper than the function block struct i get the following error (See picture below). How can i define a struct as an function/ function block input? Thanks in advance.
  24. What is the Use of Number data type for CJ2 Omron PLC? it takes integers as well as float values . we can not map it to D or H memory area.
  25. After getting my logic to work. I went in and implemented the logic with my plc. It worked but in order for me to test part 2 of it, I have to turn the machine off and turn it back on as part of a reset feature. When I turn the machine back on, it wipes out my logic and goes back to its default logic. It's almost like I never changed anything. I connected my pc to the plc and connected to plc, pulled up the code and ran it on "Online Mode" where i can make changes and send them to the plc and yet again it wipes out whatever changes I had made and goes back to its default. Any suggestions?