Search the Community

Showing results for tags 'cx-designer'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 102 results

  1. Hello everybody, I've been searching for a solution for this problem, but haven't found it yet. When the user is done with a task, a certain bit turns ON. Then a poppup should popup. I tried using alarms, but that won't work, because I have to initialize an alarm display on every window I've made.  Can somebody help me?  Thanks,  
  2. Varying Versions

    I have an NS5-SQ01-V2 that i pulled a program from. I am reloading the same program back onto the PT but i keep getting an error code that the "Program is V1, PT is V2. Continue Transfer?" I know this means that the versions obviously differ but this is the first time ive come across this. Will it do any harm to anything to continue with the transfer and see how the machine reacts? 
  3. Error Compiled

    Sir, i can't compile my file that i have made. It say " The compiled file is not found. Please compile the title first". So, because of that i can't do offline simulator on NB Designer
  4. Good day everyone, I recently got NB HMI and program it together with my NX1P2 PLC. I got 2 questions I would like to ask. What I'm trying to achieve is to lock all the button after I start my system or during the pop up screen for confirmation. I tried different methods and it doesn't work. Currently I'm using a direct window Pop-Up screen to cover all the button behind it, but I noticed if I drag the pop up screen, it'll move together. So I wonder, is there any correct methods of doing it? Also, the function key for change screen, I use it for Pop up screen but why it only spawn on the top left of the screen instead of the center? Thanks in advance guys!
  5. Hi  I want to use in sysmac the number of the active page in nb designer. for example if I am in page number 5, the program in sysmac recovers in a variable the value 5 THANKS
  6. Hello everybody, I continued my project this morning and my HMI gives the 'PLC No response 00-02-3" error... I haven't changed anything since last Friday, so in theory it should work. I used this tutorial a few weeks ago and that worked. I also tried so use some old programs which used to work, but they don't work now...  HMI IP: 192.168.250.1 (the addresses from the tutorial) PLC IP: 192.168.250.2 (the addresses from the tutorial)   Does anyone know what could be the problem? I already tried using another switch, but that didn't work either. EDIT: I just saw that I posted this in the wrong subforum, excuse me EDIT2: I found the solution. I cleared the data memory before... So what I did was transfering the settings to the PLC, then completely power off the PLC and then power it on again. That worked for me! Thanks, Olivier
  7. setting date cp1l

    Hi all im currently using the DATE instruction to set the PLC's date and time via the HMI which is an NB7W which i have working but i am currently setting each byte of the words being used in DATE by using numerical inputs in NB designer and entering integer and decimal to set these bits in DATE and its a bit ugly to say the least. is there a way on nb designer to only modify bytes or am i going to have to used full words on nb designer and use MOVD in cx programmer to assign them to their correct byte CURRENT SETUP always on DATE using d50=d53  
  8. Keypad in GT Designer

    I need a key pad which can be used for numeric input, can anyone provide any sample program.   Thank you.
  9. Hi there! I've been working with NB HMIs with good result. But today I loaded a project to a NB7-TW01B and it feels slow, both offline and online. Switching screens and reading/writing take around 1sec or more. It first had some bmp images created with .bmp and .png files, so I tried using vector graphics instead, but didn't get any better. I don't have another NB to try it right now so I'd like to ask you if you've been in this same situation before or what could be causing this. PLC is CP1L and communication it's via Ethernet. Both devices are actually pretty close (cable is less than 3m) and the previous HMI (Pro-face GP) felt a lot faster. Thanks in advance!
  10. My Compact Logix PLC is connected to my computer by USB. When I try to create a new view designer file, I can not connect my view designer with my controller. "OK" button of the HMI to controller path remains INACTIVE. Please see the attached.  How can i solve this issue?
  11. String shift register

    Hello all thanks to bits n bytes's date and time to string converter here https://forums.mrplc.com/index.php?/topic/31786-write-plc-time-as-text-to-memory-card/#comment-149418 i have made a nice string output function block for the PLC date and time that i will attach. I'm now wandering how to shift this into a memory card as well as display it on a NB screen. for the NB screen i think i can just used a text box to display the code using 8 words, i sadly dont have a CJ2M plc with me at the moment so i cannot test. for the memory card i have not used these at all yet, is there a special shift register for strings? i cant seem to find it. i will be using this simply for a checklist on the HMI where an operator goes through the list of tasks to perform and ticks them off on the HMI which then logs the time and date they were completed at. do i need to create a shift register using MOV$ with a @destination and increase the count of the destination witch each input? Thanks in advance Date_and_time_string_convert.cxf
  12. This is my first post so let me know if there is anything wrong with my post. I am learning Studio 5000 right now for an internship and created a simple project involving a pushbutton and some LEDs. Now I am trying to create an HMI for it in View Designer. My problem now is that I cannot establish a connection to the project because I do not have a physical HMI connected to my plc (Logix 5380). I can't find any way to emulate an HMI module so that I can get it to run. When I emulate my HMI project it tells me "Unable to reach controller TEST" where test is the name of my plc program. I added a module that matched the model in my HMI program (panelview 5510 2715p-t7wd) which I arbitrarily picked at random. But when I go into references and try to add HMI to Controller Path it does not show up (I'm assuming it's because it is faulting in the plc program since it doesn't actually exist). Is there not a way to emulate an HMI or add a virtual HMI to my studio 5000 program that I could connect to from View Designer?
  13. HI everyone i was wondering if i could connect a cp1l-el to 2 different NB screens running 2 different programs. we have a main line HMI which displays the health of the entire line with its own cj2m plc, we also have a machine which is part of the line that has its own plc(CP1l-EL) and HMI. is it possible for me to include the cp1l in the main lines HMI so that it can display the status of that machine? or will it cause issues because it already has a program attached to it. i dont know exactly how the NB program works does it just read the bits of data it needs to or is it constantly looking at the whole plc data list?
  14. Hello, can we do the simulation between sysmac and nb designer thanks
  15. I have one project on which the offline test works nicely. However if I "Save as" and give it another name, the offline test stops working. I click on offline test, the loading hourglass appears for a few seconds, then nothing happens... Does anyone know why, and/or how to get offline test working again? I am running NB Designer version 1.3. I always compile before trying the offline test.
  16. Hello,  Sorry I'm newbie with omron plc programming. I'm wondering how can i simulate plc program on sysmac studio with Hmi on Nb designer without hardware. because I want testing my program and my plc and hmi connection before buying hardware. Thanks in advance !
  17. HI all i was wondering if it might be possible to edit the name of a word switches state. I'm creating blank presets for a machine lets say 1-10, i would like to use the drop down word switch which would display preset 1-10. is it then possible to edit preset 1's name to something like "8mm diameter" by using the notepad function on nb designer and directing that to some location on the plc? any idea or different methods would be great, or even if its not possible. thanks
  18. Hi. In GT Designer 3 i am using a template for motor control and status in a panel. Due to changes in control philosophy a button was added for STOP. This has been added and registered in the template. But how do I also update the objects? Should this have been done automatically if I had done it correctly? Cheers  
  19. GT Designer 3: Label import error

    Hello. When trying to import the labels from GX3, i keep getting an error saying the project cannot be opened. Has anyone encountered this error? Cheers
  20. Hello everyone,  Someone know, how to read timer data from omron PLC CP1E in HMI NB3Q-TW00B? I tried write macros for HMI program, but I have some error about macro in program. How I understand, this HMI model don't support data reading from plc timer TIM in cx programmer? But how I can write macros and set it for recognizing in HMI?   
  21. Hi ya,  can someone please advise if it is possible to add a text box that the user can enter a name / description to.  I am hoping the user can select the text box and a pop up keyboard will appear for them to enter a description on a magelis hmi.  I look forward to your advise. 
  22. Pls any one help me to simulate my omron HMI program with CPM 2A PLC  Means help me to communicate cx designer with CPM 2A plc Or with NT- series  support tool
  23. Has anyone come across this error on windows 10 with fonts freshly installed and NB Designer freshly installed
  24. Hello. I can't find any related bits wich would indicate PLC offline / online status. I'm using two PLC's. PLC0 Modbus TCP (Ethernet) PLC1 Modbus RTU (Serial) Please help me to get online status. BR, Andrej. 
  25. Axis Attribute Error

    Hello All, First time working with PLC. Get the hang of it from stuff I researched. Having an issue with an axis setup for a servo motor.  When I try to do an auto tune it gives me an error that axis is not configured.  Source: Config Fault    Condition: MotorDeviceCode- INvalid attribute      ACtion: Immediate Stop Fault Entry: Type 8, code 9 subcode: 1314 stopaction: 4 Statechange: 3   I was wondering what am I doing wrong? Any leads or source information I can use to solve this.