Search the Community

Showing results for tags 'ab studio'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 111 results

  1. Hi Everyone! I try to read Analog Data in PLC Master through Salve Module (ECT-21) but i dont see any data, with an Digital Module i can read and write, but with analogic module i can't do anything. The analog module works perfect, i have 4-20ma Simulator and work fine. Modules: PLC: NJ501-1300 Slave: ECT-21 Analog: ADO81-V1 Can u help me? Regads..
  2. In Sysmac Studio, is there a way of addressing Array of for argument sake 100 INT. For ex: TEMP[array 0..99 of int]- AT %W0  If I do that will TEMP[1] be %W1 or I cannot address array. PS: I am currently using NJ501-1300 and Omron NB Screen. I am reading/writing total of 450 variable all comprise of either INT or WORD. I would like to group them together for easy access and keeping my variable table neat. Is there a better way of doing this. Any help is much appreciated.
  3. Indirect Addressing NA Terminal

    Hi. ¿Is there a way to use indirect addressing on a NA Panel?  I need to use a motor operation template for several motors and i think is not very smart doing the same panel over and over. I have always created a screen and then reused it (on FactoryTalk View, Intouch, Schneider Vijeo) The problem is that we don't find any article about indirect addressing on NA panels. So we dont know how to do it. On CXDesigner we used DM addressing so we could use a template instead of creating many button panels when we need to operate a motor, for example. Its like when you use indirect tags on Intouch or Parameter files on FTV. I fear that indirect Addressing is not possible, but in that case ¿Which method do you recommend? ¿Got an example or an article mentioning it? Thanks in advance.
  4. I am using FactoryTalk View Studio SE 8.20 to develop SCADA Application, and whenever I tried to open Tag Database it shows error "an error occurred while attempting to open the tag database editor" and not able to Open Tag database. Does anyone know solution for this? Error Screenshot Attached
  5. Sysmac studio network configurator

    hi could you help me to find sysmac studio network configurator? from where i can start it?
  6. I'm printing extracts of my code for change control records. The print quality is terrible as it seems to output low-resolution JPEGs to the PDF or XPS files rather than vectored graphics and TrueType (or other vectored) fonts. See the attached close-up showing the artifacts. Exporting in this fashion also makes the resultant PDF unsearchable. I can't find any configuration options for this. Is there a fix?
  7. Studio 5000 no From Upload option

    So my company recently purchased a new Allen Bradley PLC Demo kit from Amatrol (CompactLogix L16ER) and I installed the Studio 5000 v24 onto our company computer and started going through the Amatrol Lesson Plans. But then I had a bit of a snag. The lessons required that I open the files from the From Upload option on the Studio 5000 start up screen. Only, it wasn't there! There is no From Upload option on the start up screen. Anyone have any ideas how or why it's not there, and most importantly, how to get it there? It's kind of important!   Thanks!
  8. I have version 1.17  .. and when I tried to import a file from a friend, I got this instead: Is there anything higher than V1.17? 
  9. Good morning i want to know how i can recognize into the compactlogix 1769-L24 ER the micro 850 (2080-LC50-24QBB), because i want to communicate this two devices with MSG, i already i can see these two equipments into RSlinx but when i start Studio 5000 i don't know whick module i have to use it to recognize the micro 850, please help me
  10. I am new in sysmac studio programming. I used WSFT function (word shift) in cx-programmer. What function I will use in Sysmac studio? Thanks.
  11. Hi, I'm a long time lurker and would like to start by saying thanks for all the help over the years, much appreciated!  This is my first post, please be gentle. I'm working through a large project with an L83 (V28) including 75 EIP nodes & 5 servos.  We have a need for quick real-time response of 2 cameras during a quick servo move (taking several pictures).  I've broken my program up into a few event driven tasks (allowing me to chose the execution time interval (5 to 8 ms for more important tasks and 20 ms for less important tasks, etc.)), along with these I have 2 periodic tasks: 1 for my HMIs & faults running every 30ms and 1 for this quick real-time response camera situation running at .5ms which contains my camera and servo logic.  Everything is running well and seems responsive and repeatable enough, but I am now adding the second half of the logic which will essentially double everything (2 up system).  This has made me consider the best structure approach: Is it better to have a few larger routines within a few larger tasks or better to have more smaller tasks containing an abundance of smaller routines or some other different mix? Thanks, JD43    
  12. pc to plc

    I'm making a plc interface tasks using vb serial communications, I used omron plc CPM2A and Visual Basic 2013 to control and monitor the plc, but I do not understand how to transfer to plc vb command, and the response from the plc to vb. please help me, I'm sorry if my english language is not good
  13. Dialog File Browsing

    Hello, I am looking for a way to use the OpenFileDialog in VB to be able to select a recipe file to import. I read this forum: and thought that maybe I could access the OpenFileDialog function from the code, but System.Windows.Forms namespace is unavailable.  Is there any other way to access the dialog box to let the user select a file? I am using Sysmac Studio with an NA5 series HMI. Thank you for your help.
  14. Has anyone been able to produce screenshots of an NA project via File/Print menu option on Sysmac Studio? All this does for me is produce an image of a page showing objects or controls on the page itself, but it does not include anything from pages that are setup as 'background' for the page. This makes producing documentation a real pain. Am I missing something? Thanks for any help.
  15. Hi, I'm working on a projects where i need the button text to be dynamic.(assigned by a string variable) i have not been able to figure out how to accomplish this easily. I made a workaround with placing a label over the button and have the label refer to a string, but it would be soo much easier and smoother to just have the button text assigned a variable. I would think i could access the the text field through code ,like: Btn_1.Text=My_Btn_String_1, but have had no luck with this. Would Greatly appreciate any help. Thanks, Frank.  
  16. I'm editing a dual language project for an NA5 HMI. It's working fine except for the message at startup. To modify the project I've had to update the firmware on the HMI. I'm using Sysmac Studio 1.15. Startup language seems to be set correctly. Any ideas?
  17. I'm modifying an existing NA5 HMI program and can find my way around the program OK except for assigning text to buttons. Every time I add a new button it assigns the same Resource ID for the button text as was used on the previous button. If I copy and paste a button it also uses the same Resource ID. This is to be expected but there doesn't seem to be a way to change the Resource ID associate with an object. Note that the Resource ID value is greyed out and not changeable. Editing the text on this button will affect the other two visible in the screengrab even though they were created separately (and not by copy and paste). Has anyone any ideas on the correct way to set individual Resource IDs on the buttons?
  18. RsView Studio Tags problem !

    Hello everyone ! The plant where i work uses allen bradley CompactLogix 5000 controllers. It has three controllers, each one controlling a seperate production line. So my superior asked me to add a functionnality to the existing program, and after a little research, i found that it is better to edit the program in "Online Mode", and that's what i did. After that, i wanted to associate the new tags i created with some views in RsView Studio, but i cannot find any tags in the online folder associated to the controller, even though the connection shortcut is set and is working, and the online folders of the other two controllers contain all their tags ! Any suggestions please ?
  19. CJ2M-CPU33 >> FINS >> PC

    Hi all,   I have a challenge and I'm hoping for some feedback from all the smart folks on this forum   First some background  about this post:   I work for a company that builds switch panels for the food industry. All these panels use the same PLC unit CJ2M-CPU33. As of today we manually test these switch panels by checking if the wiring is correct with a DM (digital multimeter), but we do not check component functionality, such as powering relays or testing E-stop circuits. The reason is that we do not have a PLC program to control all these elements.  The ultimate goal is to automate these switch panel checks as much as possible, the only time user input is necessary would be to flick a switch on the front panel. The flow of information would be as follow: PC sends command to PLC (output Q0.00 - High) PLC sets output Q0.00 High (via terminals and some circuitry) PC gets signal back PC checks information PC sends command to PLC (output Q0.00 - Low)   Everything has to be controlled via a windows application  (Visual Basic) because that is what I understand. About PLC programming I don't know much about ladder diagram programming, I know how to build simple programs but that's all. But I will learn a lot more by doing this challenge   To get started I have search the forum on topics that relate to FINS command and Visual Studio. I've found some interesting topics one of which had a  ActiveX component for visual basic named INDAFINS so I will investigate what the possibility's are. Also I have downloaded some FINS command reference documents I need to study does because as it stands I'm a total noob when it comes to FINS commands. I hope that some of you want to think with me on this and share your thoughts about the subject.   My current test setup looks like this     COMPOTENT PSU 24V= 5A Weidmuller Switch Omron PA202 PSU CJ2M-CPU33 Omron OC211 (outputs) 6x 24V weidmuller relais  
  20. Hi, This is going to be a long question, but I want to be thorough so please bear with me. We have a system consisting of ABB equipment for motion control and IO handling. In order to simplify the overall architecture, we want to replace the motion control part of this system (which at present consists of a bunch of different CPU cards and PCBs) with one Omron NJ controller an use its SW library for motion control instead. With regards to IO handling we want to leave the IOs as they are now and just map them from the ABB PLC to the NJ controller and back using an Anybus X-gateway (i.e. the ABB PLC will collect the IOs from its modules, send them via Profinet to the Anybus, which will map them on EtherCAT to the NJ controller). Now, in the NJ controller, rather than putting all the IOs in the global variable list, I want to create structures (one Digital Input structure consisting of booleans, one Analog Input structure consisting of long reals and so on). The reason I want to use a structure rather than an array, is that the structure let's me specify variable names, which is nice. Here is my problem: How can I map the digital inputs from the Anybus to the Digital Input structure? The data from the Anybus is packed into bytes of data, so I want to find the most convenient way to take these bytes from my IO-table, split them up and map them to the bools of my structure. I can't seem to find good solutions to this problem online. From the Omron Instruction docs W502, the function AryByteTo seems to do exactly what I want, but it seems like my output variable in that case needs to be an array instead of a struct. If I don't find a good solution to this I am stuck with just hard coding every DI to its variable in my struct, which is time consuming to say the least considering well over thousand IOs. Hope someone will help. Thanks in advance.
  21. I am experiencing a serious problem. Everything went fine in my project for month. Yesterday when I "Transfer to Controller" (like I use to do several time a day) I got this Message : "Build is not complete. Process was aborted". So I build again, I Rebuild controler, I restart SysmacStudio, restart the computer, reset the hardware on the project ... nothing worked. Always the same message. So I opened a previous version of my code. Since it was allready built when saved, I had no problem transfering it in the controler. However, the moment I change a line (have to rebuild) on this backed up version... same problem appear. I finally got to the "output windows" (Alt+3) where I saw ALL build are failed. I've contacted my Omron representative and he is trying to help but he seem as lost as I am. Please help if you can, I am using Sysmac Studio 1.13 on Windows 10. I also have a HMI wired to the project and everything work fine with it.  
  22. Hi all, I need to edit the hardware configuration of an existing system on B&R 2005 system. but when I upload program from plc to my computer and trying to open it on Automation Studio so Software is not recognizing this uploaded file from PLC. Actually Digital Mix module is malfunctioning in existing system, and this module is out of stock. What I want to replace it with one Digital Input and one Digital Output Module which is available. Please help me Thanks & Regards    
  23. Programmatic Timer/Delay

    Howdy, Wasn't sure the best place to post this Programmatic Timer/Delay question. I need to create a Timer whose 'time' will change programmatically. I am having trouble coding this in RSLogix/Studio 5000. I need to delay a little more every time 1 Product passes through up to a certain count then reset and start over. Basically during a conveyor transition, via a pop=up conveyor, I don't want the product in the same place every time. I want each successive product to be in a little bit different spot, call it the Conveyor Land Point. The product will land a little further each product, then start back at the first land point I have no code to share as all attempts were FAILs Inputs: > Product Count (Count up or down counter) > Product Count Cycle (Number, constant, set able, currently = 4) > Delay Time Sequence Interval (Number, constant, set able, currently = 0.25 seconds) Outputs: A sequencing delay, based on Product Count > Delay Sequence:  1st delay 1 second. 2nd delay 2 seconds, ... up to Product Count Cycle (4) then reset back to 1. Program: (As I was thinking) Set Product Count Cycle, Product Count Cycle = 4 (May change could be 3,4,5, or 6) (Might be hard code, might be an HMI input) Set Delay Time Sequence = 0.25 seconds (May change could be 0.5, 0.75, 1.0 etc.) (Might be hard code, might be an HMI input) Line start, Product Count at one (1) Calculate Delay     Delay   = Delay Time Sequence Interval * Product Count Cycle * Product Count  Product Count increments via PE Repeat e.g. Hopefully I have not 'run' at the mouth, wanted to give as much info upfront                I included a picture Any thoughts, help would be great. thanks,
  24. I am working on re writing a PLC program from CX Programmer to Sysmac Studion and i have run into a few issues of not being able to find the same instructions. Does anyone know of an instruction in Sysmac Studio that is the same as a XFER and a BSET in CX Programmer.
  25. Hello Everyone, haven't roamed here for a while.   So I'm having a little trouble using the Structure Data Type in Sysmac Studio/NJ. As an independent tool, it is powerful to create user data types, such as Ethernet/IP Tag Link to V680S RFID or any other EIP equipments. And it is way more powerful than the CJ2, since it has the ability for user defined offset, which CJ2 can't do.   But the problem is we cannot move/copy the content of the members to any other standard types. For example, I have a structure with 8 BYTE type members. Then I need to send those out via UDP or TCP/IP comms, which Function Block requires BYTE[] data type. Unfortunately data movement instructions such as MemCopy and AryMove didn't work at all to do the job. This was easily done in CJ2 since we can access each memory content directly. Currently I already resort to use customized Functions which will translates the Structure into BYTE[], but that would mean for every different protocols, I need to create a different Function.   I have seen this problem posted somewhere in the SS/NJ Improvement Request section, so I wonder has anyone know any update about this matter? Haven't checked the latest update yet (SS v1.14), but I'm certain that in SS v1.13 this feature is still unavailable.   Thanks!!!