Search the Community

Showing results for tags ' subnet and gateway. any remedies/advice is most welcome. please provide a guide on the communication/configuration setup. thanks'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 226 results

  1. RJ71EIP91 Configuration mismatch

    I have several machines that use the RJ71EIP91 module. I have not had any issues until now. I do not have the original apa file. I upload the configuration and try to restore it from the configuration.apa file, it does not show everything that is connected to the card or programmed in the PLC. when I verify this it says that the configuration is a mismatch. I have several of these scattered throughout the factory and I don't have this problem anywhere else. Is there a solution to this problem?
  2. Hi all,  I am trying to modify the date and time of several PLCs from other PLC. Them are all CJ2M, and they are all in the same ethernet network (192.168.100.xx) and in the same FINS network (#1). I am doing it using the FINS command 07 02 ("CLOCK WRITE") with the CMND2 instruction. It is not working entirely: the clock time is being modified at the specified node; however, I do not get the FINS response (expected 07 02 00 00). If I modify the number of retries of the CMND2, the command is repeated all the specified retries though the clock was already written on the first try.  The D+0 and D+1 (response channels) are always #0; nevertheless, the I+1 ("Communication Completion Code" channel) allways receives #205. Acording to the manuals, this code is for "Response Timeout". I have tested it with 10 retries and with 10.0 seconds of monitoring response time, but it is working in the same way: the clock is modified fast enough, but I am not getting the FINS Response and the I+0.00 bit is ON after 100 seconds...  I have been also doing tests with the OMRON's Etherway Software, sending the same FINS command, and here I am getting the response properly. (???) I would say the FINS network was set-up correctly. All the PLC were set in network #1 with Cx-Integrator. In fact, they are currently sharing several channels using the SEND command on this network #1. I don't know what I am not doing right... Any idea?  The ladder is attached as .cxp and as .png. Thanks a lot.  Best regards.  CLOCK_WRITE.cxp
  3. Festo PLC

    Hi!  I'm new and was wondering if anyone here has experience on Festo's PLC? I'm looking for recommendations and guides to start using their software. Any help will do. Thanks, Summer
  4. Error **03 Special Parameter Error

    Hello I have a problem whit PLC mitsubishi FX3U thernet communication, we have a module  FX3u-ENET-ADP. and we have the error "**03 Special Parameter Error".  
  5. Communciation Error plc with PC

    Dear All,   Am new to Siemens plc. i have CPU 315-2DP. but when i try to communicate with pc through simatic Manager . i receive the Following Error. " Unable to establish a connection with module ." Sometimes it gives error as attachments. kindly help me out.    Through control panel , i have selected the PG / PC interface to S7 Online with PC adapter Auto 1.   Kindly help me out. you will be a life savoir.   Regards, ZUbair
  6. Hi All,Cx-Supervisor, NJ501-1340, Sysmac Gateway.I have been writing an update for a project and converting to this new controller.It's a pretty big project.Using a combination of Ladder and ST.Using Cx-Supervisor 3.5.I created some new Variables in Studio and made them Publish only.Started to create Points in Supervisor and made them I/O connected to the variables in Studio. No problems everything was connecting and working just fine.Then one of the points would not update. I could change it in the PLC and it would not change On the HMI.I deleted it and recreated it and it did the same thing. (sometimes points in Supervisor just stop working and recreating them fixes it).I then copied the control and pasted the old point into it and it did the same. Then other started to fail. Showing no reaction.I stopped the gateway and restarted, no help, I rebuilt the HMI, nope.The can check the tags in Sysmac gateway and they always change when the PLC changes but not the HMI.I checked the point maintenance in Supervisor and it would not change.I dumped all the affected variable in the PLC and in the HMI and recreated them. Then it got stranger.I could change some on the HMI and it would show in the PLC but not the other way.This is on Bools and UINTS.Stopped CX-server, tried using it with Win8 compatibility. nope.Pulling my hair out now. I should be coding but I'm trying to get the apps to work.Any ideas will be used with thanks.Peter
  7. I am trying to POST API to a meter in Maximo using a socket in a 5069-L320 controller. I am able to successfully create and open the socket. The write and read instructions get the DN bit but I do not see the meter updating in Maximo. I was able POST successfully using Postman, so I know I am sending the correct information. Do I need to be formatting the POST differently? I'm not getting errors so don't have a direction to go from here. (I will fix the obvious username and password vulnerability, one step at a time) Thanks
  8. Hi all, I'm new here and need an opinion from you guys on how to set the Gateway for PLC CP2E in CX Programmer ? From my discussion with supplier (OMRON), they mentioned it was unable to set any gateway for CP2E model but I found on some sources that for previous model for CP1L is able to set the gateway. Supposed to be the Gateway function can be supported by latest model, am I right ? Need an explanation on this, Thank You
  9. Hmi modbus TCP/IP device communication

    Hi all; I have Delta DOP110 IS hmi and i have a modbus tcp device. I want to communicate hmi and device with modbus tcp/ip but i didnt understand device's register address. For example, input bytes 0,1 analogue control word, What is the register address? 40.000 or 40.001 can you help me ?  
  10. Hi All, I just start to setup a rotary servo (rotary transmission load type) and the designer pass me the spec of gear ratio 1:100. In my motion scaling page, I set Transmission I:O as 1:100  and then scaling unit is just position unit with 1:1. However, when i jog my rotary servo, it does not reflect the actual position in degree, so I went to read through the manual but still cant quite get how should i configure my scaling so that I can see that when the motor is rotating, i can see it rotate how many degrees? I try to set scaling 360 degree to 1.0 load rev, and the position feedback seems like much more finer....
  11. j’ai un probléme au niveau Unité DRM21 via Network Device Net et aussi l’un des paramétré(température, Résistivité) qui n’est pas affiché dans la partie supervision(Remote), mais il s’affiche localement.
  12. HOSTLink read multiple DMs

      Hello,    I am using Hostlink protocol to read data from PLC units. for example @00RD22220001..., will return DM2222's value. But I want to know, if I could read multiple DM values at the same time. for example: DM2222, DM3000, DM4000, reading these DMs with one communication. Please note that these are not continuous DM areas. I know a sequence of DMs can be read by specifying starting address and count.   Many thanks in advance.   Ting              
  13. Here is a post that we recently completed on the Automation Direct USB to RS485 Adapter.  The USB-485M is a 2-wire USB to RS-485 serial communication adapter for RS485 use. It does not require an external power supply or complicated configuration. It has a Type A (plug) USB connector for the computer side and a universal female RJ45/RJ12 modular connector. This will accept RJ12 and RJ45 plugs.  The USB-485M supports multiple baud rates and is USB V2.0 Compliant. Read the rest of the post... YouTube Video on the installation and communication to a Solo Process Temperature Controller via Modbus RTU. https://www.youtube.com/watch?v=aWE05ZNZNXw Let me know what you think, Garry www.accautomation.ca  
  14. RS485 COmmunication

    Hi all, i am looking for a solution to connect 7 plc with a single scada. is it possible according to my topology diagram ?   Kindly make me suggestion and if you have any information regarding the solution then share .   Thanks in advance. 
  15. Good Morning,   My name is Joseph Rhodes, I work as an electronic technician for the City of Tuscaloosa at the wastewater treatment plant. I work to keep the plant up and running as well as 64 lift stations spread out around Tuscaloosa, Alabama. A majority of our lift stations utilize Verizon Cell Modems, RV50s to be exact. It's rather easy connecting remotely to these lift stations as I can configure a driver as an ethernet / ip driver then associate an IP of that lift station (ex. 10.181.3.104 is lift station 104, 10.181.3.105 is lift station 105, etc). However, for the lift stations that do not utilize cell modems. We use GE MDS 9710 and 9810 radios. It is these lift stations that I have yet to figure out a way to connect remotely to the LS RTU PLC. All of our lift stations use Allen Bradley MicroLogix 1200s or 1400s. These lift stations that use the MDS radios communicate information to water tanks then that information is sent back through other channels. I was wondering is there a way to associate these lift stations on RSLinx that use GE MDS radios ?   
  16. Hi all, I am trying to communicate KEPServerEX with FX3GE vis UDP protocol. I have tried but unable to get data on Kepserver. While configuring communication properties in PLC we have configured PLC IP, PLC Port, Destination IP, but unable to find correct Destination Port. Although we tried various port nos like 49320, 57412, 57512, 56233, 1025, 32402, 57212, 57012, 57612, 57812 but there was bad quality data using UDP For same PLC using TCP/IP we were able to read all tags properly. This change in communication protocol is required as there are some PLCs whose communication port drops after few days of connection establishment (no error logged; can be re established with just restart). Someone from Mitsubishi said to try communication via UDP as it continuously fetch data regardless of kind of response received. If anybody has tried or have any solution, please do share.   Thanks
  17. I'm trying to develop an email application that will run an a PV+7. I've gotten it far enough that the email activex control quit posting error strings, but my mail server is not receiving anything. I realized that the HMI doesn't know how to get outside via a gateway address. I know I can set it in the HMI itself but it isn't available to me right now so I'm trying to test using the 'test application' feature.  I guess I just don't know where to setup a gateway address in factorytalkview me.    
  18. Hi, I managed to communicate a Kinco HMI with a Xinje PLC (XC3-48R) using RS-232. Also, I've established connections between the both equipment and my personal PC, for programming purposes. Currently the uploading and downloading, PLC bits reading and writing happens normally. But, when I disconnect any of the equipment from the PC, (HMI or PLC), the communication is lost between the PLC and HMI.  How can I solve this and, remove my PC from the network by making the HMI master and PLC slave ?    The software I use for programming is, (XCP Pro, Kinco HMIware)  
  19. FX3GE Communication issue

    Hi all, There's an issue I am facing for multiple FX3GE PLCs in a plant. Communication breaks between a PLC and OPC server. PLCs after few days (4-10) does not respond over ethernet. No ping response is received over network as well as when checked one to one direct connection. If I restart the PLC the connection is resumed and again after some days it goes down. Error LED on ethernet port does not glow red (no indication for error). If anybody has faced similar issue and has resolved, please share.
  20. Serial communication with KINCO PLC

    Hello to everyone. Nice to meet you all. I am programming a KINCO PLC model HP043-20DT using ladder on KINCO BUILDER. I need to establish a serial communication with my PC. The PLC has a RS485 port which I adapted it to USB to connect with my PC. The PLC allows, at least, two ways to establish serial communication: MODBUS or free-protocol. I've read the software manual and tried to reproduce the examples it provides using the instruction blocks for MODBUS (MBUSR and MBUSW) and free-protocol (XMT and RCV) communications. However, I could not receive the data on the PLC. I could effectively transmit data with XMT from the PLC to the PC and I could verify through a tool called Access Port. In relation to MODBUS, I am using a simulation tool called Multiway from OMRON, however, I get no response from the PLC. If any of you have some experience with this software or this device, I would like to ask you how could I solve the problem. Thank you for your attention. Kind regards.
  21. Memory registers on KINCO PLC

    Hello to everyone. I hope you are doing well. I have a KINCO PLC HP043-20DT. I'm communicating through free-protocol instructions XMT and RCV. The manual states that memory registers SMB86, SMB186 and SMB286 contain information about the state of the reception instruction. I would like to ask if any of you know of the existence of an analog register but with respect to the transmission instruction, instead of the reception. The manual does not indicate it and I could not find any information online. I've sended an email to the manufacturer but, until now, I have not receive any answer. Otherwise, how could I search for this information? I tried through the manual providede by the manufacturer, but maybe there is other way. I would appreciate any information. Thank you so much. Kind regards.
  22. First time posting. I'm upgrading an old Panelview Standard to a PanelView Plus on DH+ using a ProSoft gateway.    My question: I believe I do have comms established but I'm getting a host of errors  "Data Table N7:100 in SLC at 10.10.10.100 is too small or missing" It seems as though I'm getting the error for every data table in the old program. I used the import conversion on FT View Studio to replicate the screens and tags and so on. I am diligently doing my research trying to figure out what's going on but thought I'd throw this one into the great ether and see if anyone has an insights. 
  23. C# - Compolet missing

    Hi.  I have the CD with SYSMAC Gateway Runtime V1.6 and installed the full CD. I still cannot add a reference to Omron.Compolet in Visual Studio 2019. And the project i am trying to open, complains about OMRON.Compolet is missing. Any idea whats missing to get the OMRON.Compolet to show up in VS.Net 2019?
  24. Hi Guys, I need to send temperature data from PLC to LED Display through RS-485 communication, so How can I proceed further in this. Please guide me Thanks in advance
  25. Fatek PLC Communication Problem

    hy all. i am having an error while communicating with fatek plc. when i communicate it gives an error. " Com port open fail, plz check if this port is used by other programme when we online the PLC (Fatek/ WinProLadder). kindly Guide me   as it looks like port is already used by another program . and i dont know how to kill that program ..