TigerLily

NX1P EtherCAT Master to Beckhoff EtherCAT Coupler

19 posts in this topic

Hello!

I am working on a quote for a new project that will use EtherCAT but also requires DeviceNet for some legacy components.  Has anyone successfully used the Beckhoff EtherCAT coupler (EK1100) with the DeviceNet Master Terminal (EL6752) and an Omron PLC as the EtherCAT master? My concern is that the coupler will only communicate with the Beckhoff EtherCAT master, but since it is so much more expensive to get the new Omron parts to communicate DeviceNET i am hoping this could be an option.  The equipment is extremely simple and price is a major consideration.

 

Thank you!!!

Share this post


Link to post
Share on other sites

If the device is truly compliant with EtherCAT, the brand of master should not matter.

Share this post


Link to post
Share on other sites

I would think it would be compliant since Beckhoff created the Ethercat standard.

Share this post


Link to post
Share on other sites

So I ended up using the NJ CPU with an Omron DeviceNet card, Beckhoff was not sure that the Omron EtherCAT Master would communicate with the DeviceNet Master card on the Beckhoff EtherCAT coupler, they were certain that we would have no issues communicating with the Beckhoff EtherCAT coupler, but the issue was then communicating to the DeviceNet Master since that was designed to work with their PLCs, since I already have the Beckhoff components laying around I am hoping to try it some time, but I just didn't have time on this project and had to go with what I knew for certain would work!

Thank you for your input and if I ever get time to try it out I will let you know the outcome!

Share this post


Link to post
Share on other sites

Did any of you had the chance to try this?

At this moment I'm trying to connect an OMRON NX1[]2 EtherCAT Master with a Beckhoff EtherCAT Coupler EK1100, with some digital input/output cards EL1809 and EL2809 (in the ECT coupler). I'm able to install the .esi file for the coupler, but it brings the PDO empty, so in the I/O Map, I can't have any input/output variables to access the digital points of the cards attached to the coupler.

I've managed to use in the past some Beckhoff EtherCAT modules (like the EP1008 and EP1009) where the .esi file brings the correct PDO (I/O Map Variables available), but this is a different scenario, because it's not modular (like a card expander coupler mentioned above).

Thank you all!

Share this post


Link to post
Share on other sites

Hey,

correct me if I'am wrong but it sounds like you have only installed the esi file of the coupler itself.

There are esi files for the cards too. These should have the correct PDO map settings that you are looking for.

 

greetings.

Share this post


Link to post
Share on other sites

Hey!

You assumed correctly! I've found that I only had the coupler esi file, yes.

I've installed already each card .esi file and it already appears the PDO and respective variables in the I/O Map. I didn't have updated before this topic because I didn't tested it yet.

 

But it appear something strange after this. For each coupler's card, it's requesting an EtherCAT node address, as you can see in the picture attached, wich for me doesn't make that much sense, since this cards are not in the EtherCAT network. Do I really need to supply each card an unique node address? Or is it just some "bug" in the SYSMAC, and should just put some value so it "stops nagging me"? :-D

 

Thank you!

Best Regards!

 

SYSMAC ETHERCAT.jpg

SYSMAC ETHERCAT.jpg

Share this post


Link to post
Share on other sites

This is correct.

It seems ( at least thats what I think ) that the coupler works as an EtherCat Hub and the cards act like an own line of nodes.

This works for me but I'am new to the beckoff coupler and sysmac topis as well. I'll add information if I have any new things to say about this.

 

greets

Share this post


Link to post
Share on other sites

Dear Friends.

Can you pls share how to connect NX1P2 with Beckhoff Ethercat coupler? I tried but can not connect.

Thank you so much.

Share this post


Link to post
Share on other sites
11 hours ago, cuongvcs said:

Dear Friends.

Can you pls share how to connect NX1P2 with Beckhoff Ethercat coupler? I tried but can not connect.

Thank you so much.

What do you mean by can't connect? Did Sysmac accept the ESI file? Do you see the coupler when you do a compare and merge? What is the model number of the coupler?

Share this post


Link to post
Share on other sites
12 hours ago, cuongvcs said:

Dear Friends.

Can you pls share how to connect NX1P2 with Beckhoff Ethercat coupler? I tried but can not connect.

Thank you so much.

The last several messages here explain how to do it.  Did you read it before posting?  What more information do you want?

Share this post


Link to post
Share on other sites
On 10/1/2021 at 7:40 PM, photovoltaic said:

What do you mean by can't connect? Did Sysmac accept the ESI file? Do you see the coupler when you do a compare and merge? What is the model number of the coupler?

Dear.

the Beckhoff coupler is EK1100. I has add ESI to Sysmac and add to Ethercat network. but not set address to EK1100. 

Share this post


Link to post
Share on other sites

To set the address of the EK1100 you likely need to go online with the PLC and right click on the ethercat master and choose "Write Slave Node Address".

Never used the EK1100 but I don't see mention of any physical switches to set it.

1 person likes this

Share this post


Link to post
Share on other sites
6 hours ago, photovoltaic said:

To set the address of the EK1100 you likely need to go online with the PLC and right click on the ethercat master and choose "Write Slave Node Address".

Never used the EK1100 but I don't see mention of any physical switches to set it.

Hi.

Thank for your info.

I tried to write slave node add. But can not write to EK1100. It show wrong connect. But I connect from Ethercat port of NX1P direct to EK1100. And tried connect to ethernet switch but the result is the same.

I don't know correct the revision of EK1100 but not show in the label.

The led of Ethercat port flash. 

Can you pls advise to me more if you have any idea to solve this issued. Im new with Omron and Beckhoff.

Many thanks.

 

 

Share this post


Link to post
Share on other sites

Well for starters ethernet switches don't work with ethercat. Just go straight from the ethercat port on the PLC to the IN port on the coupler.

I'm not sure I'll be of much assistance on this one as I've never used that coupler.

1 person likes this

Share this post


Link to post
Share on other sites
37 minutes ago, photovoltaic said:

Well for starters ethernet switches don't work with ethercat. Just go straight from the ethercat port on the PLC to the IN port on the coupler.

I'm not sure I'll be of much assistance on this one as I've never used that coupler.

Dear 

Thanks.

Has tried direct from PLC to IN port of EK1100. Let me check something and try again.

Thank you so much.

 

 

Share this post


Link to post
Share on other sites

Posted (edited)

Dear all.

I found this issued cause by 3 module analog. Node 6,7and 8. The Sysmac studio show " not checked" and download not ok. If remove 3 module and download back and work is OK. I dont know why? It ok only digital module not for analog module.

Can you pls advise to me how to solve this issued. 

20211003_180819.jpg

Edited by cuongvcs

Share this post


Link to post
Share on other sites

I tried connect EK1100 direct with TC3 and check all IO module OK.

but connect to Omron PLC error.

Pls help me to look this issued.

Many thanks

 

Share this post


Link to post
Share on other sites

Hi ,

Anyone have try  communication between Omron NX plc   and beckhoff bridge? EL6692 or 6695? its communication between KRC 4 to PLC.

I have tried few times ,but show state transition may have failed . unable to communicate

WhatsApp Image 2021-12-01 at 4.11.27 PM.jpeg

WhatsApp Image 2021-12-02 at 9.03.43 PM.jpeg

Edited by Mohan1984
Attached picture to get more info,thx

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now