Search the Community

Showing results for tags 'kinco serial communication'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 240 results

  1. Serial question

    I have a cell phone modem connected to my Omron CP1L on serial 2   Here is the issue  I need to pull the phone number out of the msg received (receiving text messages)  I receive a text msg and a lot of other crap like time and date ect. RDX says store in D100 the problem is that after I receive the SMS I see the phone number and copy the number to D200 to D2xx The next text comes in and it is added to the length of the previous text and the new phone number is not in the same D area as the first.  It seems the only time the serial port works is if you declare 20 characters and you get 20 characters Works every time. But sometimes I may get 12 characters and other times I can get more than 100. I have used the restart and clear port command with no luck.  If I set RDX to a large number and receive complete will not come on and the next receive will be added to the first.  I need a clear buffer for each receive.  How do I get around this?  If you set the RDX to 10 but 12 characters were received the 2 extra characters will be in the buffer and added to the next receive.  I can’t use end receive if x because there is nothing that is always available in the msg. And even if I do any characters received after end code is left in the buffer and screws up the next receive. I have never seen anything like this. Any ideas? Thanks Rob  
  2. Hi all,  I am trying to modify the date and time of several PLCs from other PLC. Them are all CJ2M, and they are all in the same ethernet network (192.168.100.xx) and in the same FINS network (#1). I am doing it using the FINS command 07 02 ("CLOCK WRITE") with the CMND2 instruction. It is not working entirely: the clock time is being modified at the specified node; however, I do not get the FINS response (expected 07 02 00 00). If I modify the number of retries of the CMND2, the command is repeated all the specified retries though the clock was already written on the first try.  The D+0 and D+1 (response channels) are always #0; nevertheless, the I+1 ("Communication Completion Code" channel) allways receives #205. Acording to the manuals, this code is for "Response Timeout". I have tested it with 10 retries and with 10.0 seconds of monitoring response time, but it is working in the same way: the clock is modified fast enough, but I am not getting the FINS Response and the I+0.00 bit is ON after 100 seconds...  I have been also doing tests with the OMRON's Etherway Software, sending the same FINS command, and here I am getting the response properly. (???) I would say the FINS network was set-up correctly. All the PLC were set in network #1 with Cx-Integrator. In fact, they are currently sharing several channels using the SEND command on this network #1. I don't know what I am not doing right... Any idea?  The ladder is attached as .cxp and as .png. Thanks a lot.  Best regards.  CLOCK_WRITE.cxp
  3. Error **03 Special Parameter Error

    Hello I have a problem whit PLC mitsubishi FX3U thernet communication, we have a module  FX3u-ENET-ADP. and we have the error "**03 Special Parameter Error".  
  4. Serial Port issue

    Sorry its long !! I am recieving text from a GSM modem for text msg Send and receive (SMS) works ok but would be better if I could make use of the start code and end code. This way I could cut down on all the crap that is received when a text arrives. I get this  CMTI: "SM",0 I have it stored into D80 and I have that trigger a TXD that sends AT+CMGRD=0 and that tells the GSM to send the msg (The 0 is the current msg in memory) ------ The problem is that there is Carriage  Return and Line Feeds in the received msg ----      AS below ((AT+CMGRD=0 +CMGRD: "REC UNREAD","+19028991212","","22/10/20,16:57:54-16"  Hello this is the msg  OK)) When the PLC sees the carriage return it stops receiving data. And I have no start code or end code setup. (I am using characters received) The way around this is to set a high  character count in the RXD (More than the actual msg (More than the msg length)   The main issue with that is I get garbage in as the msg gets bigger. Its unreliable. I clear the port after each receive and that helps but still get the odd garbage. (Never get garbage when connected to a terminal prg). Any Ideas???? ps Even the Start Code is unreliable as it will start receiving a few characters late. Rob  
  5. Serial Ports not working

    I have a CP1L-EM and the serial ports - both of them have an issue with the port ready flag will not turn on. Power cycle still no port ready flag In settings both ports are set up as 15200 8N1 CR/LF Verified and power cycled and still no port ready flag. Is there someplace in the PLC where the ports can be disabled? Rob  
  6. Communciation Error plc with PC

    Dear All,   Am new to Siemens plc. i have CPU 315-2DP. but when i try to communicate with pc through simatic Manager . i receive the Following Error. " Unable to establish a connection with module ." Sometimes it gives error as attachments. kindly help me out.    Through control panel , i have selected the PG / PC interface to S7 Online with PC adapter Auto 1.   Kindly help me out. you will be a life savoir.   Regards, ZUbair
  7. I am trying to POST API to a meter in Maximo using a socket in a 5069-L320 controller. I am able to successfully create and open the socket. The write and read instructions get the DN bit but I do not see the meter updating in Maximo. I was able POST successfully using Postman, so I know I am sending the correct information. Do I need to be formatting the POST differently? I'm not getting errors so don't have a direction to go from here. (I will fix the obvious username and password vulnerability, one step at a time) Thanks
  8. Until recently, I haven't had to connect to a piece of hardware using a serial connection in quite sometime. Well, that all changed yesterday when I needed to connect to a Watlow F4T Controller. I dug around in the bottle drawer of my desk and pulled at not one, but two USB-Serial Converters that I saved for just such an occasion! My old ones worked on everything from Allen Bradley SLCs, to Schneider Drives. Unfortunately, neither appear to work in a Windows 10 environment. Searching the internet, I was not able to find any drivers for these old converters, but did find some posts in another forum stating that Microsoft changed how it manages its USB ports from Win 7 to Win 10. Thanks Microsoft! Sorry, I will cut this rant short and just ask my question. Can anyone recommend a USB-Serial Converter that works in a Windows 10/11 environment?  Respectfully, Shane 
  9. I'm trying to understand the basics of using a serial to ethernet converter such as this Comtrol DM-EIP-2101, with Studio5000 code. Basically I have a weighing machine that only outputs data via RS-232 and I need to send that data to a PC that will process it through a Studio5000 program and have the data displayed on an HMI using FTview SE. Is it as simple as just connecting the serial and ethernet to the converter and it does all the work? Obviously checking ip addresses and firmware will need to be verified. The main thing I am unsure of is the process of passing the individual data packets from the machine to the Logix code on the PC,  things like what the weight of the item was, was it over weight or under, etc....  Would there be an AOI or tags built into the software for a machine like this Checkweigher? I've worked with much smaller items like Cognex Dataman cameras and I know you can just use their AOI that allows you to simply call a tag if you want to display information like if a scanned barcode was correct or whatever. If anyone has done something similar I'd appreciate any guidance. It can be difficult getting the information from the manufactures so I'm looking for answers anywhere I can. EDIT: I guess I should also clarify that only using one or the other (serial or E/IP) is not an option. It will be a serial connection from the Weighing machine to the converter and then Ethernet to the PC.
  10. Dear forum, I am facing a trouble at the moment and hoping somebody can assist. I have one HMI software, GT Designer 3, HMI: GS2107 and/or GT2107, the software works so far so fine. The software is used on several products, I dont want to maintain two or even more software versions. Two serial devices are connect: 1x MODBUS RS-485 1x MODBUS RS-232. The data transfer is done via DDT, no direct calls. The DDT transfer the MODBUS address to the internal GD-Registers. The GD-Registers are used within the HMI. My trouble is that in some cases, there is no RS-232 device connected. This creates time outs, slows down the HMI and its just not nice looking (I have a warning implemented "WARNING NO CONNECTION TO SERIAL DEVICE RS-232". Is there a way, that I can select (retained) that the RS-232 is connected / or not? Once the software is configured "NO RS-232 CONNECTED" I can handle the rest of the software.   Anybody an idea how to do this? Many thanks.
  11. Hmi modbus TCP/IP device communication

    Hi all; I have Delta DOP110 IS hmi and i have a modbus tcp device. I want to communicate hmi and device with modbus tcp/ip but i didnt understand device's register address. For example, input bytes 0,1 analogue control word, What is the register address? 40.000 or 40.001 can you help me ?  
  12. G9SP Configurator

    I am at a client site that has a line with multiple Omron G9SP-N20S safety controllers installed and I need to make a modification to the system.  I tried to install the Omron Configurator and it asks for a serial number, and will not install without one.  Omron said that it is on the CD that ships with the unit, but the equipment manufacturer did not supply any of the CDs.  The only Omron solution is to order a replacement CD, that will take 5 days, which is 5 days too long as there is a hard stop in 2 days.  I have tried entering numbers found on the controller, with no success.  Does anyone have a better way, special contacts at Omron, to et it faster?
  13. Output polarity selection

    Hello to everyone. Nice to meet you all. How are you? I hope you are doing well. I’m developing a program with the purpose of make something similar to a pulse train in the output. However, sometimes I need the output to be a “positive” pulse and sometimes a “negative” one. By positive and negative I mean the polarity in relation to the pulse train source. I’m trying to use a pair of bits in order to switch between the two choices of polarities. I attach a simplified version of the ladder diagram I’ve made. When I thought about the logic, it seemed logical to me, however, it isn’t working as supposed. SM0.4 is a pulse train source. According to the software manual, it is a pulse train with 50% duty cycle and a cycle time of 2 s. That it to say it says at TRUE for one second and return to FALSE for another second. I assign the value of that variable bit to the M0.0 memory bit. I get the negative version of the pulse train logically negating it in the Network #2.                 I assign the value of two inputs, I0.0 and I0.1, to other two memory bits, M0.1 and M0.2. ·         When both inputs are in a FALSE state, the output stays FALSE, disregarding the state of SM0.4. (Case #1) ·         When I0.0 is TRUE, M0.1 is TRUE. However, Q0.0 stays at FALSE no matter SM0.4 is TRUE or FALSE. I attach a pair of pictures. (Case #2) ·         On the other side, when I0.1 is TRUE, M0.2 is TRUE. In this case, the output shows the correct behavior. It is the negated version of the pulse train source. (Case #3)                 Has any of you experienced something similar? Is there a better way to execute my purpose?                 I’m not executing the program, just simulating it with KincoBuilder from Kinco. However, it has always worked fine for me. Thanks for you attention. I look forward for your responses. Kind regards!
  14. j’ai un probléme au niveau Unité DRM21 via Network Device Net et aussi l’un des paramétré(température, Résistivité) qui n’est pas affiché dans la partie supervision(Remote), mais il s’affiche localement.
  15. HOSTLink read multiple DMs

      Hello,    I am using Hostlink protocol to read data from PLC units. for example @00RD22220001..., will return DM2222's value. But I want to know, if I could read multiple DM values at the same time. for example: DM2222, DM3000, DM4000, reading these DMs with one communication. Please note that these are not continuous DM areas. I know a sequence of DMs can be read by specifying starting address and count.   Many thanks in advance.   Ting              
  16. Here is a post that we recently completed on the Automation Direct USB to RS485 Adapter.  The USB-485M is a 2-wire USB to RS-485 serial communication adapter for RS485 use. It does not require an external power supply or complicated configuration. It has a Type A (plug) USB connector for the computer side and a universal female RJ45/RJ12 modular connector. This will accept RJ12 and RJ45 plugs.  The USB-485M supports multiple baud rates and is USB V2.0 Compliant. Read the rest of the post... YouTube Video on the installation and communication to a Solo Process Temperature Controller via Modbus RTU. https://www.youtube.com/watch?v=aWE05ZNZNXw Let me know what you think, Garry www.accautomation.ca  
  17. I am trying to get a G9SP taking over serial to a NX1P2 using a NX1W-CIF01.  I have the details in Manual P545-E1 and it uses a example file which i am unable to locate OMRON_G9SP_SERI232_LD_EV100.SMC I have got the coms working with a CP1L using the example in Manual Z922-E1.  I was wondering if anyone has the example file or a working example they can share for Sysmac Studio. The serial comms will take a little bit to get going but it is the code for the checksum for the sending data that i would rather not have to translate from CX Programer fort he CP1L to Sysmac Studio...... P545-E1-01.pdf.lnk Z922-E1-07.pdf.lnk
  18. Sorry for my bad english speaking. I want to change the baud rate to 19200,38400,.... for send it via Programmer-Serial-Port. The software GX-Developer can do it!.  
  19. RS485 COmmunication

    Hi all, i am looking for a solution to connect 7 plc with a single scada. is it possible according to my topology diagram ?   Kindly make me suggestion and if you have any information regarding the solution then share .   Thanks in advance. 
  20. Good Morning,   My name is Joseph Rhodes, I work as an electronic technician for the City of Tuscaloosa at the wastewater treatment plant. I work to keep the plant up and running as well as 64 lift stations spread out around Tuscaloosa, Alabama. A majority of our lift stations utilize Verizon Cell Modems, RV50s to be exact. It's rather easy connecting remotely to these lift stations as I can configure a driver as an ethernet / ip driver then associate an IP of that lift station (ex. 10.181.3.104 is lift station 104, 10.181.3.105 is lift station 105, etc). However, for the lift stations that do not utilize cell modems. We use GE MDS 9710 and 9810 radios. It is these lift stations that I have yet to figure out a way to connect remotely to the LS RTU PLC. All of our lift stations use Allen Bradley MicroLogix 1200s or 1400s. These lift stations that use the MDS radios communicate information to water tanks then that information is sent back through other channels. I was wondering is there a way to associate these lift stations on RSLinx that use GE MDS radios ?   
  21. Hi all, I am trying to communicate KEPServerEX with FX3GE vis UDP protocol. I have tried but unable to get data on Kepserver. While configuring communication properties in PLC we have configured PLC IP, PLC Port, Destination IP, but unable to find correct Destination Port. Although we tried various port nos like 49320, 57412, 57512, 56233, 1025, 32402, 57212, 57012, 57612, 57812 but there was bad quality data using UDP For same PLC using TCP/IP we were able to read all tags properly. This change in communication protocol is required as there are some PLCs whose communication port drops after few days of connection establishment (no error logged; can be re established with just restart). Someone from Mitsubishi said to try communication via UDP as it continuously fetch data regardless of kind of response received. If anybody has tried or have any solution, please do share.   Thanks
  22. Hello, I've been using Mitsubishi and Omron systems separately (in their own environment), and I am fairly new when it comes to connecting these two brands together(plc and hmi). I've been scouring the net for wiring diagrams for the cable connections and also the parameters to be set for a successful communication between those two components. can anyone point me at the right direction as everything I've tried so far has been a failed attempt of making these two communicate. here are the parts and my current settings if this helps: FX3U-64M FX3U-232-BD NB5Q-TW00B or better yet, is there a proper cable that I need to buy for this to work?
  23. Hi, I managed to communicate a Kinco HMI with a Xinje PLC (XC3-48R) using RS-232. Also, I've established connections between the both equipment and my personal PC, for programming purposes. Currently the uploading and downloading, PLC bits reading and writing happens normally. But, when I disconnect any of the equipment from the PC, (HMI or PLC), the communication is lost between the PLC and HMI.  How can I solve this and, remove my PC from the network by making the HMI master and PLC slave ?    The software I use for programming is, (XCP Pro, Kinco HMIware)  
  24. FX3GE Communication issue

    Hi all, There's an issue I am facing for multiple FX3GE PLCs in a plant. Communication breaks between a PLC and OPC server. PLCs after few days (4-10) does not respond over ethernet. No ping response is received over network as well as when checked one to one direct connection. If I restart the PLC the connection is resumed and again after some days it goes down. Error LED on ethernet port does not glow red (no indication for error). If anybody has faced similar issue and has resolved, please share.
  25. KINCO PLC as MODBUS RTU slave

    Hello to everyone. I hope you are doing well. I'm trying to establish a communication between my PC and my KINCO PLC. The manual states it supports MODBUS RTU protocol, so I downloaded two different Modbus Master simulator I found out: Multiway from OMRON and qModMaster. None of them seem to work properly. I attached some pictures of the messages I get. https://ibb.co/f1mCSNt Multiway message https://ibb.co/bP5cX1t qModMaster message I include the configuration of the communication parameters. https://ibb.co/nMty8D9 PLC parameters https://ibb.co/6RTqVfC Multiway parameters https://ibb.co/N1XTccd qModMaster parameters According to the manual, in order to play the role of Modbus master with the PLC it's necessary to configure some instruction blocks (I'm programming in ladder). However, I could not find any block to configure as Modbus slave. I don't know what else I can do. I'm in trouble with this task. Am I making some mistake? Thanks for your attention.  Kind regards!