Sign in to follow this  
Followers 0
Oliver Micka

2080-LC30-24QWB - firmware download failed

5 posts in this topic

Hi all,
I have problem with this PLC.
I have Micro 830 ( 2080-LC30-24QWB series A ).
Yesterday i tried download PLC code in to the PLC,
CCW wanted to upgrade firmware on this PLC,

I did chose - OK,
Original FW was 6
I chose a new : 12

During the process "downloading firmware" CCW in the half proces CCW freeze and showed me "connection failure" and after this failure CCW show me loss communication with the PLC.

If i tried repeat this process CCW showed me fault -- "can´t connect to the PLC", then i did try " disconnect power, wait a half hour and connect power again " to the PLC.
After i connect the power i have same status " Flashing Fault LED".

RsLinx see this PLC only through VBP-1 , and if i "click" to + on the station, nothing found..

I try use ControlFlash (v15.04) to re-flash firmware, but if i chose a correct type of PLC "2080-LC30-24QWB/A" and chose direct way to the PLC via RsLinx -> VBP-1 -> 08.Micro 830, ControlFlash showed me " device is different, please chose a correct device"
( i tried chose 2080-LC30-24QWB and 2080-LC30- 24QWB/B -i have same fault - device is different, please chose a correct device" )

I think, my PLC is "Bricked" but i don´t know, how can i "Unbrick".

Does anyone know, what is the better solution for this fault?

I found a several similarly situation, but nothing helped me.

CCW - 13.00
RsLinx - 4.20.00 - CPR 9 SR 12.0
ControlFlash - 15.04

Note: I tried use a DF1 port ( cable 1761-CBL-PM02 ), but if i connect to the RS232 port in the PC, nothing gonna happen.
DeviceManager dont showed me any info for new device on COM port.

The only one way, where my PC react to the connected device ( my PLC ) is only throught USB cable.

I would be very grateful for any help.

Share this post


Link to post
Share on other sites

You have encountered the one nightmare of AB PLCs , the "bricked" unit. 

To the best of my knowledge, these are only repairable by returning to RA Tech Support through your distributor.

That said, the next time you flash a PLC make sure you are in the following conditions:

1.  PC is on AC Power and Not Battery

2. All Screen Savers and Power Save feature are turned off.

3. You have a direct connection by USB Cable.  I PERSONALLY DO NOT TRUST ETHERNET FOR FLASHING UNITS.

All this said, the most reliable guru on this site when it comes to Micro 800 Family is @TimWilborne.  I'm tagging him here to see if you get some help.

Share this post


Link to post
Share on other sites

I've also had issues with firmware updates via USB when using virtual machines. During the process, the device reboots and doesn't always automatically re-connect to the VM, which causes problems. In general, I think it's best to use the host PC for this.

Share this post


Link to post
Share on other sites

Posted (edited)

@BobLfoot I had PC powered from AC power, 
screen  saver was a off.

Micro 830 have only USB or Serial ( DF1 ) port. 

What i remember is:
ControlFlash ( after sended a several data from PC to PLC ) wanted restart the PLC. And from this moment I have had  blink "Fault" LED and I don´t find any solution for this situation until now.

Does this PLC have a posibility to hard restart or hard reset ?

Edited by Oliver Micka

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0