Djoko

How to configure modbus tCP /IP Qj71mt91 with 3 slave QJ71MT91

41 posts in this topic

Dear sir,  all the master plc in the world.

I'am newbie about modbus TCP/IP qj71mt91 modul mitsubishi.

I have problem to configure   qj71mt91 with master and slave .I have 3 qj71mt91 and one of them  for master slave. I connect with switch ( hub)

Please suggest me how to set up or configure parameter for master and 2 slave 

Slave first = d0 to  d300.( Read by master)

                   = m100 to m300 ( write from master )

Slave 2nd = D500 to D1000 ( read by master )

                  =  M400 to m500 ( write from master)

Master Ip addres.192.168.3.45.( CPU )

                                192.168.3.50.( QJ71MT91)

Slave 1st = 192.168.3.39( CPU )

                 = 192.168.3.40 (QJ71MT91)

Slave 2nd = 192.168.3.60 ( Qj71mt91)

Thanks for your attention and support.

Best regards .

Udjojojo

Edited by Djoko

Share this post


Link to post
Share on other sites

IF all the components are Mitsubishi why use modbus ???
If you have a QnUDVCPU you can use simple  PLC comm.

Anyway for the slave modules you only have to setup the IP adresses.
With the default setting:
D0 is Holding register 0  so D500 is Holding register 500.
M0 is coil 8192 so M400 is coil 8592.

This is just some basic you need to know.

Are you using GX Works 2?

Lets start with the first step:
Add the QJQ71MT91 modules to all your projects.
Give all the modules the correct IP address in the Switch setting.
For the master system change the BASIC PARAMETER STARTING METHOD to USER SETTING PARAMETER.
Reset all the PLC's and check if you can ping them.


 

 

1 person likes this

Share this post


Link to post
Share on other sites
39 minutes ago, Gambit said:

IF all the components are Mitsubishi why use modbus ???
If you have a QnUDVCPU you can use simple  PLC comm.

Anyway for the slave modules you only have to setup the IP adresses.
With the default setting:
D0 is Holding register 0  so D500 is Holding register 500.
M0 is coil 8192 so M400 is coil 8592.

This is just some basic you need to know.

Are you using GX Works 2?

Lets start with the first step:
Add the QJQ71MT91 modules to all your projects.
Give all the modules the correct IP address in the Switch setting.
For the master system change the BASIC PARAMETER STARTING METHOD to USER SETTING PARAMETER.
Reset all the PLC's and check if you can ping them.


 

 

39 minutes ago, Gambit said:

IF all the components are Mitsubishi why use modbus ???
If you have a QnUDVCPU you can use simple  PLC comm.

Anyway for the slave modules you only have to setup the IP adresses.
With the default setting:
D0 is Holding register 0  so D500 is Holding register 500.
M0 is coil 8192 so M400 is coil 8592.

This is just some basic you need to know.

Are you using GX Works 2?

Lets start with the first step:
Add the QJQ71MT91 modules to all your projects.
Give all the modules the correct IP address in the Switch setting.
For the master system change the BASIC PARAMETER STARTING METHOD to USER SETTING PARAMETER.
Reset all the PLC's and check if you can ping them.


 

 

39 minutes ago, Gambit said:

IF all the components are Mitsubishi why use modbus ???
If you have a QnUDVCPU you can use simple  PLC comm.

Anyway for the slave modules you only have to setup the IP adresses.
With the default setting:
D0 is Holding register 0  so D500 is Holding register 500.
M0 is coil 8192 so M400 is coil 8592.

This is just some basic you need to know.

Are you using GX Works 2?

Lets start with the first step:
Add the QJQ71MT91 modules to all your projects.
Give all the modules the correct IP address in the Switch setting.
For the master system change the BASIC PARAMETER STARTING METHOD to USER SETTING PARAMETER.
Reset all the PLC's and check if you can ping them.


 

 

 

39 minutes ago, Gambit said:

IF all the components are Mitsubishi why use modbus ???
If you have a QnUDVCPU you can use simple  PLC comm.

Anyway for the slave modules you only have to setup the IP adresses.
With the default setting:
D0 is Holding register 0  so D500 is Holding register 500.
M0 is coil 8192 so M400 is coil 8592.

This is just some basic you need to know.

Are you using GX Works 2?

Lets start with the first step:
Add the QJQ71MT91 modules to all your projects.
Give all the modules the correct IP address in the Switch setting.
For the master system change the BASIC PARAMETER STARTING METHOD to USER SETTING PARAMETER.
Reset all the PLC's and check if you can ping them.


 

39 minutes ago, Gambit said:

IF all the components are Mitsubishi why use modbus ???
If you have a QnUDVCPU you can use simple  PLC comm.

Anyway for the slave modules you only have to setup the IP adresses.
With the default setting:
D0 is Holding register 0  so D500 is Holding register 500.
M0 is coil 8192 so M400 is coil 8592.

This is just some basic you need to know.

Are you using GX Works 2?

Lets start with the first step:
Add the QJQ71MT91 modules to all your projects.
Give all the modules the correct IP address in the Switch setting.
For the master system change the BASIC PARAMETER STARTING METHOD to USER SETTING PARAMETER.
Reset all the PLC's and check if you can ping them.


 

 

 

 

Yes Sir.

I want to read data from several machines

Thank you for your replay .

Iam using Gx work2  , I have setting IP address each modul Qj71mt91 with different  in last number .

Master.192.168.3.40.

Slave 1st .192.168.3.50.

Slave 2nd.192.168.3.60.

And then  I have tried pinging each of the modules successfully.

How to configure or setting AUTOMATIC Communication master with two slave.

Please suggest me 

Thank you very much

 

 

 

Share this post


Link to post
Share on other sites

The next step is to create the comms requests.
So go tot Automatic comm parameter tab.

Lets make this one ( Slave first = d0 to  d300.( Read by master)

Specify the ip adress of slave 1 (192.168.3.50)
select 500h read holding registers
Head buffer memory adress 1000
modbus Head Dev 0
Acces points: 301

Download this into the PLC. Reset and check if it is working
 

Share this post


Link to post
Share on other sites
19 minutes ago, Gambit said:

The next step is to create the comms requests.
So go tot Automatic comm parameter tab.

Lets make this one ( Slave first = d0 to  d300.( Read by master)

Specify the ip adress of slave 1 (192.168.3.50)
select 500h read holding registers
Head buffer memory adress 1000
modbus Head Dev 0
Acces points: 301

Download this into the PLC. Reset and check if it is working
 

Thank for your  replay.

Acces point can't input 301,and  message  pop up ( "entering value is invalid.please confirm the range if entering .Range  1-125")

according to the photo I sent

imagecompressor.zip

20200218_080249-min.jpg

Share this post


Link to post
Share on other sites

Sorry that is right you can only do 125 max. so you would have to define one 2 extra.

But first just do the first 125 Datapoints. When that works make three
D000-D101
D100-D201
D200-D301


 

Edited by Gambit

Share this post


Link to post
Share on other sites
14 hours ago, Gambit said:

Sorry that is right you can only do 125 max. so you would have to define one 2 extra.

But first just do the first 125 Datapoints. When that works make three
D000-D101
 

Good morning Sir  continuing the discussion yesterday

after I tried what you suggested was successful then, what about the second slave for setting the parameters

Share this post


Link to post
Share on other sites

how arrangement this parameter for automatic communication for second slave?

 

20200218_190713-min-min.jpg

 

Edited by Djoko

Share this post


Link to post
Share on other sites
15 hours ago, Gambit said:

Sorry that is right you can only do 125 max. so you would have to define one 2 extra.But first just do the first 125 Datapoints. When that works make three

D000-D101
D100-D201
D200-D301

I only trial with 10 access points successfully ,D0 -D10  and setting auto refresh Device Do with transfer word counta 4096.

How to setting when 300 point with three arrangement like your suggest.

D000-D101
D100-D201
D200-D301

20200219_094656-min-min.jpg

Edited by Djoko

Share this post


Link to post
Share on other sites
23 hours ago, Djoko said:

I only trial with 10 access points successfully ,D0 -D10  and setting auto refresh Device Do with transfer word counta 4096.

How to setting when 300 point with three arrangement like your suggest.

D000-D101
D100-D201
D200-D301

 

Can Anyone help me ,please?

Edited by Djoko

Share this post


Link to post
Share on other sites

Which error do you get when you try 100 acces points?

Share this post


Link to post
Share on other sites
2 hours ago, Gambit said:

Which error do you get when you try 100 acces points?

No Errors if set 100  acces point.

Share this post


Link to post
Share on other sites

there are 2 problems, the first is how to read 300 points in the first slave and read 300 in the second slave, but if only to read one slave is successful but only 125 points

Share this post


Link to post
Share on other sites
Just now, Djoko said:

there are 2 problems, the first is how to read 300 points in the first slave and read 300 in the second slave, but if only to read one slave is successful but only 125 points

That is correct that is why you will need to make three read commands.
Juts make sure to also increase the BFM of the buffer memory. (be carefull this is in Hex!!!)
 

 

Share this post


Link to post
Share on other sites
1 hour ago, Gambit said:

That is correct that is why you will need to make three read commands.
Juts make sure to also increase the BFM of the buffer memory. (be carefull this is in Hex!!!)
 

 

How to set parameter with automatic communication  second Slave ? 

Share this post


Link to post
Share on other sites

is it necessary to make a ladder program manuall to read the first and second slaves or just parameter settings in automatic communication

Share this post


Link to post
Share on other sites

😇😇😇🤕🤕...

Share this post


Link to post
Share on other sites
27 minutes ago, Djoko said:

is it necessary to make a ladder program manuall to read the first and second slaves or just parameter settings in automatic communication

You don't have to write any code. the requests are handled automatically.

Share this post


Link to post
Share on other sites
33 minutes ago, Djoko said:

How to set parameter with automatic communication  second Slave ? 

juts make the second one. Juts different IP adress and head BFM adress 

Share this post


Link to post
Share on other sites
46 minutes ago, Gambit said:

juts make the second one. Juts different IP adress and head BFM adress 

I have make automatic communication parameter 2 with different IP and BFM,But  Still problem ,Cannot communication with second slave ,Alarm appears on diagnosis system monitor

20200220_170648-min.jpg

Edited by Djoko

Share this post


Link to post
Share on other sites

port cannot be opened. Check the IP adress on the 2nd slave module.

 

Share this post


Link to post
Share on other sites
16 hours ago, Gambit said:

port cannot be opened. Check the IP adress on the 2nd slave module.

 

Slave 1st .192.168.3.60.      

Slave 2nd.192 .168.3.50.

If slave 2nd ( qj71mt91) test ping direct with straight cable to PC has success,but if through switch cannot responding.

Whats wrong ?

Edited by Djoko

Share this post


Link to post
Share on other sites

Did you try another port on the switch ?
Maybe the cable between de slave and the switch isn't a straight cable.
Try the cable which worked on slave 1

Edited by Gambit

Share this post


Link to post
Share on other sites
15 hours ago, Gambit said:

Did you try another port on the switch ?
Maybe the cable between de slave and the switch isn't a straight cable.
Try the cable which worked on slave 

Thank you sir.

I have move cable slave 1st and slave 2nd, it's Working and success.but still problem when connect to second slave.there may be an automatic communication parameter error between master and slave, and I haven't found a way to set it

Share this post


Link to post
Share on other sites

Honestly, This sounds like a typo. I'd retype everything into the config.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now