CP1E-N40 + CP1W-TS102

9 posts in this topic

Hi ! I have a question regarding the handling of the signal from the TS102 connected to my PLC.  

I downloaded a .pdf  LINKED from "my omron", read it and put together a small program just to test the expansion unit and sensors.

But I cant get any readings from the sensors and can't figure out why.

I have never used a TS102 expansion unit before and would be glad if someone have an idea of what I'm doing wrong.

Everything is brand new, so I'm quite sure I am the problem here.....:-1

If someone have an answer and maybe even an programming example to upload I would really appreciate it.

Best Regards! 

PT100 sensor test 3.cxp

Share this post

Link to post
Share on other sites

You did not mention, what values are you seeing in your CIO2, 3, 4 and 5 ?

Share this post

Link to post
Share on other sites

I get 7FFFhex  in all four CIO2, 3, 4, 5 and they never change, thats just it.

They are static. 7FFFhex and &32767

PT100 sensors seems OK when measuring ohm's.

TS102 dipswitch set to OFF - OFF  rotary switch  set to 0


Anything else you need, let me know.

Thanks! // Arrowsmith74



Share this post

Link to post
Share on other sites

Your dip-switches and rotary switch seem OK. The ladder is not a problem, since you don't need any ladder at all to read values in your 4 channels. (CIO2, 3, 4 and 5)

What about the wiring?


Share this post

Link to post
Share on other sites

I will do my wiring explanation by both words and some pictures.....

I have all 4 sensors hooked up to the TS102.

I measured the sensor wires to make a desicion which wire is which.

yellow-green is not the sensor output was my decision, so I went for the red one

as output and green -yellow as "loop" wires.

Here's some pictures of how I measured and how I connected them.

20160131_132001 (Large).jpg

20160131_132010 (Large).jpg

20160131_132023 (Large).jpg

20160131_132125 (Large).jpg

20160131_132155 (Large).jpg

20160131_132211 (Large).jpg

Share this post

Link to post
Share on other sites

I can't help with this, I only worked with thermocouples, but everything else seem OK so maybe you should try to connect otherwise.

Share this post

Link to post
Share on other sites

I have done that now, while waiting. No difference. :-(

Switched places for all 3 wires of first sensor, no luck.

Edited by arrowsmith74

Share this post

Link to post
Share on other sites

Your wiring is perfect.

From the manual:

Handling Unit Errors

• Expansion Unit and Expansion I/O Unit errors are output to bits 0 to 6 of word A436. The bits are allocated from A436.00 in order starting from the

Unit nearest the CPU Unit. CP1W-/CPM1A-TS002 and CP1W-/CPM1ATS102

Temperature Sensor Units are allocated two bits each. Use these flags in the program when it is necessary to detect Expansion Unit/Expansion

I/O Unit errors.

• When an error occurs, the Temperature Sensor Unit data becomes 7FFF hex (the same as for an open-circuit detection). With an open-circuit

detection, it is not reflected in word A436.

Please tell us the following:

Value of Auxiliary Word A436

Provide picture of dip switch and rotary switch.  We may be assuming wrong on/off positions.  Also rotary position for 0 is not directly up.  Check rotary switch to be slightly to the right from up.




Share this post

Link to post
Share on other sites

Hi everyone! Problem solved! :-2

Today i brought my PLC with me to another office and prepared to contact Omron support.

Connected everything and powered up, and suddenly it worked perfectly without doing any changes......

I was crestfallen..... This is the worst thing I know.  I have to be able to rely on this PLC that means I have to locate the problem

and now it was gone.... I called the support as I had contacted one specific guy by mail with this matter earlier and he was waiting.

Explained the situation and he checked by Teamviewer and we came to the conclusion that it was hard to do anything else than let it be. 

Stuffed everything back in the box and took it back to the workshop. Powered up and guess what, problem is back and there are no values

to read again. :dance: Didn't know if i should be mad or happy, but i decided to be happy and started ruling out the potential culprits and 

It took me less than 1 minute to go through what was different now  compared to the other situation when it works, 

and I ended up changing out the power supply which was left in place before.

Problem solved. Values back.

It was the powesupply that caused me this problem! 

Obviously there is something wrong with the Power supply but it provides the right 24VDC when measuring, so I guess the problem is

 the quality of the power combined with a very sensitive expansion unit.

Well I am not all that familiar with the english technical terms (I'm from Sweden) but "electrical ripple and harmonics" or such things

might be the term I'm after. Well, it works beautifully ever since and the old powersupply is in the bin.

Thanks to everyone involved here for taking your time to help me!

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now