diraemon

QJ1C24N to barcode Omron V400-R2. Connection HELP...

17 posts in this topic

Greetings everyone. I'm new here.
Hoping to get help to operate the Omron V400-R2 barcode to the Mitsubishi QJ71C24N so that they can communicate the two devices with the correct method. PLC: Mitsubishi: Q03UDVCPU; barcode: Omron V400-R2; serial communication module: QJ71C24N. I use RS 232 communication cable, I have tried using predefined protocol and non protocol procedures but still can't communicate the two devices.
I really appreciate your help.

Share this post


Link to post
Share on other sites

Can you be more clear about your problem ?

I would use pre-defined protocol.

Share this post


Link to post
Share on other sites

thank you 

On 9/10/2018 at 0:50 AM, Gambit said:

Can you be more clear about your problem ?

I would use pre-defined protocol.

Thank you Mr. Gambit for seeing this thread,
I'm just still confused by how to communicate these two devices, 

I use barcode omron V400-r2 to PLC mitsubishi. 

I have followed your advice and fixed the ladder but both devices still not connected.
Like the picture I attach, the protocol status only "sending".. NO error but why the SD and RD indicators in the QJ71C24N series module are not ON.. ?

 

Untitled.thumb.jpg.6848a33807c628dbfce3b correction and.

Untitled1.jpg

Share this post


Link to post
Share on other sites

Looks to me that  you have send a string but there is no reply.
In your pre-defined protocol you can set the wait time. This is probably on default infinite wait.
You should change this to 5 sec or so. So you will get an error after this time when there is no answer.

You should see the SD let lite up once when you activate X30

 

Edited by Gambit

Share this post


Link to post
Share on other sites

Maybe you should hyperterminal software (e.g. hercules) and connect V400-R2 to your computer to see that how data frame send from baecode scanner

I have ever use COGNEX Dataman to QJ71C24N that use only G.INPUT instruction to to recieve data from barcode scanner use non procedure protocol

for V200-R2 there are default parameter as below

 

Communication speed   9600 bps

Data length                             8 bits

Parity                                       None

Stop bit                                    1 bit

Header                                    None

Footer                                        CR

 

if you need to connect with QJ71C24N CH1 (RS-232)  you should config as shown below

 

1. Set switch setting with parameter 9600/8/none/1/Non Procedure protocol

 

QJ71C24N_G_Input_01.jpg

 

2. Adjust Footer Receive from 3338 (<CR LF>, [H0D0A]) to 13 (<CR>, [H0D]) then Save parameter to PLC

 

QJ71C24N_G_Input_02.jpg

 

3. G.INPUT program describe as below (This program has set QJ71C24N at Slot 0 Start Address 0000)

 

D0 - Channel No. of QJ71C24N that you use

D3 - Allowable number of receive data

X3 - CH1 Normal Read

X4 - CH1 Abnormal Read

 

QJ71C24N_G_Input_03.jpg

 

4. Receive data management

 

M0 - Flag Read

M1 - Flag error read

D2 - Receive data count

D110 - Destination receive data

 

QJ71C24N_G_Input_04.jpg

 

5. Error clear

 

X0E - CH1 Error Occurrence

Y0E - CH1 Error Clear Request

 

QJ71C24N_G_Input_05.jpg

 

for more information please check link below

http://dl.mitsubishielectric.com/dl/fa/document/manual/plc/sh080006/sh080006u.pdf

https://industrial.omron.us/en/media/V400-R2_UsersManual_en_201303_Z333-E1-01A_tcm849-114187.pdf

Edited by Wasan

Share this post


Link to post
Share on other sites
20 hours ago, Gambit said:

Looks to me that  you have send a string but there is no reply.
In your pre-defined protocol you can set the wait time. This is probably on default infinite wait.
You should change this to 5 sec or so. So you will get an error after this time when there is no answer.

You should see the SD let lite up once when you activate X30

 

I've tried giving the monitoring time = 7s and try different time too. Its respon with error in module. But i cant see indicator the SD lite up when I activated X30. I dont know if I do something wrong with this predefined protocol ?

Untitled2.thumb.jpg.49af94beb3f3ea0749cc

Edited by diraemon

Share this post


Link to post
Share on other sites
18 hours ago, Wasan said:

Maybe you should hyperterminal software (e.g. hercules) and connect V400-R2 to your computer to see that how data frame send from baecode scanner

I have ever use COGNEX Dataman to QJ71C24N that use only G.INPUT instruction to to recieve data from barcode scanner use non procedure protocol

for V200-R2 there are default parameter as below

 

Communication speed   9600 bps

Data length                             8 bits

Parity                                       None

Stop bit                                    1 bit

Header                                    None

Footer                                        CR

 

if you need to connect with QJ71C24N CH1 (RS-232)  you should config as shown below

 

1. Set switch setting with parameter 9600/8/none/1/Non Procedure protocol

 

QJ71C24N_G_Input_01.jpg

 

2. Adjust Footer Receive from 3338 (<CR LF>, [H0D0A]) to 13 (<CR>, [H0D]) then Save parameter to PLC

 

QJ71C24N_G_Input_02.jpg

 

3. G.INPUT program describe as below (This program has set QJ71C24N at Slot 0 Start Address 0000)

 

D0 - Channel No. of QJ71C24N that you use

D3 - Allowable number of receive data

X3 - CH1 Normal Read

X4 - CH1 Abnormal Read

 

QJ71C24N_G_Input_03.jpg

 

4. Receive data management

 

M0 - Flag Read

M1 - Flag error read

D2 - Receive data count

D110 - Destination receive data

 

QJ71C24N_G_Input_04.jpg

 

5. Error clear

 

X0E - CH1 Error Occurrence

Y0E - CH1 Error Clear Request

 

QJ71C24N_G_Input_05.jpg

 

for more information please check link below

http://dl.mitsubishielectric.com/dl/fa/document/manual/plc/sh080006/sh080006u.pdf

https://industrial.omron.us/en/media/V400-R2_UsersManual_en_201303_Z333-E1-01A_tcm849-114187.pdf

Thankyou Mr. Wasan. I have tried to use this method too but no response when I trigger the device to barcode..  Does barcode wiring use cognex and omron v400-r2 the same?

Share this post


Link to post
Share on other sites
47 minutes ago, diraemon said:

Thankyou Mr. Wasan. I have tried to use this method too but no response when I trigger the device to barcode..  Does barcode wiring use cognex and omron v400-r2 the same?

There are some different but use wiring RXD TXD and GND are same. I think you should use serial communication software (e.g. hyperterminal, hercules) to check how data come from Barcode Scanner first because either PreDefined Protocol or Non Procedure Protocol would check data frame that match with their data frame or not.If not error would occur. Maybe you should swap RXD and TXD barcode scanner with QJ71C24N and you should connect pin 4 (DTR) to pin 6 (DSR) and pin 7 (RTS) to pin 8 (CTS) too.

QJ71C24N_Wiring_01.jpg

Edited by Wasan

Share this post


Link to post
Share on other sites
Just now, Wasan said:

There are some different but use RXD TXD and GND are same. I think you should use serial communication software (e.g. hyperterminal, hercules) to check how data come from Barcode Scanner first because either PreDefined Protocol or Non Procedure Protocol would check data frame that match with their data frame or not.If not error would occur.

can I know which one port can be use to connect the cable barcode RS232 to (RJ45/vga port/ usb/ HDMI) in notebook?

Share this post


Link to post
Share on other sites
8 minutes ago, diraemon said:

can I know which one port can be use to connect the cable barcode RS232 to (RJ45/vga port/ usb/ HDMI) in notebook?

You should use USB to RS-232 cable as this when you install driver and connect it there are COM port (e.g. COM3) generate on device manage then use HyperTerminal or Hercules connect COM port with Barcode Scanner and check how data come from it.

https://www.moxa.com/product/UPort_1110.htm

m20150323173802.jpg

Share this post


Link to post
Share on other sites
13 minutes ago, Wasan said:

You should use USB to RS-232 cable as this when you install driver and connect it there are COM port (e.g. COM3) generate on device manage then use HyperTerminal or Hercules connect COM port with Barcode Scanner and check how data come from it.

https://www.moxa.com/product/UPort_1110.htm

m20150323173802.jpg

thankyou for the advice Mr. Wasan.. I will try it..

Edited by diraemon

Share this post


Link to post
Share on other sites
Just now, diraemon said:

thankyou for the advice sir.. can't I make a wiring manual cable with RS232 to LAN port notebook ?

If you need to convert LAN to RS-232 you should use Serial Device Server to create virtual com port same as UPort 1100 but for this project I don't recommend beacause it has more price than USB to RS-232 Converter. For detail please check link below.

https://www.moxa.com/product/NPort_5100A.htm

MOXA_Nport_5110A_01.jpg

Share this post


Link to post
Share on other sites
2 hours ago, diraemon said:

I've tried giving the monitoring time = 7s and try different time too. Its respon with error in module. But i cant see indicator the SD lite up when I activated X30. I dont know if I do something wrong with this predefined protocol ?

Untitled2.thumb.jpg.49af94beb3f3ea0749cc

Arre you trying to execute protocol 1 or 2 ?

You should set the receive wait time it is on infinite wait rigth now

Edited by Gambit

Share this post


Link to post
Share on other sites
22 hours ago, Gambit said:

Arre you trying to execute protocol 1 or 2 ?

You should set the receive wait time it is on infinite wait rigth now

I tried again by creating a new protocol, protocol 5 was executed and I also checked the error in the cable ...
"start monitoring" X3 is ON and the barcode is successfully connected, when I press the "scan button" on the v400-r2 barcode, finally the predefined reading is successful and the data is stored on the D1000 like the image I attached. but for the second reading, when pressing "scan button" the data on D1000 does not change ... I have to select "stop monitoring" in the toolbar then repeat by pressing X30 again so that the second reading can be done, is it really the way it works like that? and even in M0 the status is always OFF?

PREDEFINED.thumb.jpg.9d90ad776fd8ed8b812

Share this post


Link to post
Share on other sites
On 9/12/2018 at 1:54 AM, Wasan said:

Maybe you should hyperterminal software (e.g. hercules) and connect V400-R2 to your computer to see that how data frame send from baecode scanner

I have ever use COGNEX Dataman to QJ71C24N that use only G.INPUT instruction to to recieve data from barcode scanner use non procedure protocol

for V200-R2 there are default parameter as below

 

Communication speed   9600 bps

Data length                             8 bits

Parity                                       None

Stop bit                                    1 bit

Header                                    None

Footer                                        CR

 

if you need to connect with QJ71C24N CH1 (RS-232)  you should config as shown below

 

1. Set switch setting with parameter 9600/8/none/1/Non Procedure protocol

 

QJ71C24N_G_Input_01.jpg

 

2. Adjust Footer Receive from 3338 (<CR LF>, [H0D0A]) to 13 (<CR>, [H0D]) then Save parameter to PLC

 

QJ71C24N_G_Input_02.jpg

 

3. G.INPUT program describe as below (This program has set QJ71C24N at Slot 0 Start Address 0000)

 

D0 - Channel No. of QJ71C24N that you use

D3 - Allowable number of receive data

X3 - CH1 Normal Read

X4 - CH1 Abnormal Read

 

QJ71C24N_G_Input_03.jpg

 

4. Receive data management

 

M0 - Flag Read

M1 - Flag error read

D2 - Receive data count

D110 - Destination receive data

 

QJ71C24N_G_Input_04.jpg

 

5. Error clear

 

X0E - CH1 Error Occurrence

Y0E - CH1 Error Clear Request

 

QJ71C24N_G_Input_05.jpg

 

for more information please check link below

http://dl.mitsubishielectric.com/dl/fa/document/manual/plc/sh080006/sh080006u.pdf

https://industrial.omron.us/en/media/V400-R2_UsersManual_en_201303_Z333-E1-01A_tcm849-114187.pdf

i have done do your advise to check with hyperterminal and now the both devices can connection. I also have tried non procedure and that working now. I just press the "scan button" in V400-r2 for reading barcode and it can read different codes repeatedly without select the X83 and even in M0  the status is always OFF? is it really the way it works like that?

 

5b9b567cc159f_NONPROCEDURE.thumb.jpg.504

Share this post


Link to post
Share on other sites

When QJ71C24N receive data X83 willl be automatically on you don't necessary to on it

M0 will on one cycle scan you cannot see it.It is OK as long as M1 is off if it on that means there are some error occur.

Edited by Wasan

Share this post


Link to post
Share on other sites
3 hours ago, Wasan said:

When QJ71C24N receive data X83 willl be automatically on you don't necessary to on it

M0 will on one cycle scan you cannot see it.It is OK as long as M1 is off if it on that means there are some error occur.

I learned a lot after completing this project. Really thankyou Mr. Wasan..

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now