lamboom

MrPLC Member
  • Content count

    167
  • Joined

  • Last visited

Everything posted by lamboom

  1. Thanks to many people on this forum, and automation engineers in in several countries, not evolved with this forum, I have been able to almost finish a long project which uses the NJ and an NA HMI to manage LinMot linear motors.  However, Omron doesn't seem interested in working with LinMot .. Omron already has their own linear motors.  LinMot isn't real interested in the Omron systems controlling their drives and motors, they have a relationship with Rockwell.   In spite of this, the two systems do work well with each other, both Ethernet/IP and EtherCAT LinMot Drives will interface with the NJ, even while also using Omron Drives and motors at the same time.      There is no one in the Omron court that I know, which builds machines using LinMot ... soooo, I'm asking the forum for any contact information of someone you know, that does.  Thanks much,   Regards, Michael Lambert PS: this is a bit dated .. but it shows one early application:   https://www.youtube.com/embed/B0UGm9JTw3U?rel=0
  2. Here's some Axis Settings .. in case anyone out there has worked with LinMot: Have been getting too many following errors .. so the limits are high.
  3. I’m using a Omron NJ to manage a LinMot linear motor .. all is going very well; however, there have been a few times during this development phase when the actuator, or programming creates a fault, perhaps from a following error, or exceeding a limit.  The result is sometimes scary.  The actuator might accelerate into a hard stop.  Not a big deal, the ends are protected with Sorbothane, so it isn’t a big problem .. yet.  Once the system is correctly programmed, it shouldn’t ever accelerate an actuator into the hard stops. In spite of my newbie-ness  to Omron programming I’m aware of the need to employ error & fault action that will stop a run-away actuator in closed-loop control, rather quickly. Just how to do that.. has evaded my research. I’ve noticed:  “FaultHandler”  in the W507 & W508 Manuals. And, been quite frustrated to not find any reference to FaultHandler or FaultHandeler()  .. which kinda suggests it’s a program?… and also expected to get some clues in the "NJ Programming Best Practices V1.1”   so far… no luck. Perhaps I’m going about this all wrong..  The LinMot Driver Controller might be the way to go.. An error message from the NJ to the LinMot drive would quickly shut down movement in closed loop .. instead of turning the motor into a rail gun… Any suggestions at how to do it with the NJ,  would be greatly appreciated.. Thanks Regards, Michael PS: here’s the progress so far, thanks to many out there, and on this forum ... https://www.youtube.com/embed/B0UGm9JTw3U?rel=0  
  4. It seems to be working fine ... sort-of   However It isn't stopping the actuator when there's a following error.. and the servo is being turned off too when there's a fault.  That might be the problem.. Ya gotta have the servo on in order to stop the slider.  Then turn it off "only" if the slider is stopped.  It should take only a millisecond to stop the thing.   As of this time.. problem is not resolved.   There might be good support at LinMot now that there is an Omron Automation engineer there.  He gave me the same solution IO did about a day after IO posted his reply. I didn't expect a solution from LinMot, and was quite surprised .. I believed this was a Omron NJ problem... or, a problem with my program, and the communication between the LinMot drive and the NJ.    So far, following errors are tending to slam the slider into the hard stop, as a solution to an error.   That doesn't happen with the Delta Motion,  motion controller... it just stops the slider instantly, when there's an important error. Will get back to you & IO when I figure out what's going on... thanks. One more thing.. sometimes the  MC_ImmediateFault is activated and the LinMot Drive is left ON!  So much for stopping the Drive. I'm thinking this Function Block has no effect on the LinMot drive..the only thing that is stopping the drive is when there is the eventual error caused by a programming error in the  NJ, and the result being the slider slamming into the hard stop.. now you have a "drive error"... and the drive shuts off.
  5. Hay  Crossbow .. always nice to get your take on things.    I started this thread because I wasn't getting proper stops when errors occurred .. what I got was an attempt to fire the LinMot slider into the next county!     I'm going to try this with the MC_Stop errors included .. what could go wrong..  
  6. IO  ...Thanks again    I had to search to figure out why I didn't find it the first time.  So much of the Omron manuals provide information in a minimal, intuitive nature.  I understand .. when you have a 1700 page manual, fewer words can be beneficial if you are going to print the thing; however, today it really doesn't matter how large the manual is.  17,000 pages if fine, a computer doesn't care .. and you have a "search" routine to find anything fast. The "problem" is me .. I'm not an automation engineer, but I play one in my lab ... and with the help of good, understanding people on this forum, and others, I will soon complete a project that took several years to optimize. so, the solution is simply this?: Perhaps I'll add those "Stp_Err" and "Stp_Ca" .. thanks to your latest explanation, can't hurt.    My machine will be run by humans, nothing automatic about it .. what could go wrong!
  7. This looks like the only Omron source of info on this subject: Pages 10-19 to 10-22 of Omron manual W507 CPU Unit ..Chapter 10, Sample programming: Stopping an axis during single axis operation: You can see the 'FaultHandler" Program at the top .. activated by MC_Axis000.MFaultLvl.Active  (which is TRUE when there's a minor fault level for axis 0) As IO_Rack says .. It's a user program .. you just do whatever you want when there's a fault ..  But, it's not what is at the bottom of this example program .. which is more what IO_Rack is talking about, only the use of MC_Stop and MC_ImmediateStop is still involved at this program's end .. and is separate from the "FaultHandler" line.   (which is "Device" related) Because I already use MC_Stop in my programs,  I find this example very confusing because MC_ImmediateStop is shown linked to MC_Stop's "Stp_Err" and "Stp_Ca" OK..unless someone says otherwise, I will just connect MC_Axis000.MFaultLvl.Active  to the Execute input of IMD_STP .. that will be my "FaultHandler" I just got a similar suggestion from LinMot support, with the additional consideration of Axis settings: "Other Operation" and "Limit Settings" need some attention.     Thanks all... Regards, Michael
  8. Thanks for the reply IO Duh!  I get it!    I'm just too used to the machine providing all the programming, and i just select the little blocks and paste them into ladder diagrams ... (actually, I have quite a bit os ST in my wave tank programs.   Now that you mention it ... it should have been obvious.  There must be a "Best Practices in programming" somewhere in their thousands of pages, and hundreds of manuals ... I think they did a good job for the beginnings of programs, but not so good for ending them.    For the moment, I'll assume I just missed it.  Thanks again for the wise solution..     Regards, Michael
  9. Red Lion C programing - Wait? RESOLVED

    Thanks Nj Controls .. I posted this on PLCs.net Forum too.. just in case no one took me seriously here.. It's kinda a basic question.. Turns out one shouldn't use C programming for a position control program from an HMI.. there are unintended consequences in the HMI for loops which are paused to await a condition before continuing.   This program is easily done in the Motion Controller, which has "wait for" conditions available in it's "user programs" (the ones you write)  The Red Lion uses programs that can be called from the HMI's pages. Those programs must be written in basic C.    Using loops that wait for position conditions which are initiated by the HMI, by sending parameters and a start command to a Driver/Controller .. is not recommended.     However, some of the suggestions I got on PLCs.net were to use  while ( !inPos ){// do nothing} for a wait .. but that could end badly.. but would work if all went well. Or: switch Step { case 0: if start then issue Home(); Step:=1; Break; case 1: if Homed then issue MoveAbsoluteToZero(); Step:=2; Break; case 2: if Inpos then issue Sinewave(); Step:=3; Break; case 3: if Abort then issue Stop; Step:=4; Break; case 4: if Stopped then Step:=0; Break; } Not exactly..but something similar should work.
  10. Anyone ever used a Wait-for digital tag in a C Program? I have to use C in the Red Lion Programs.. but, I'm not at all proficient in C (or anything else for that matter ..) Here’s a nice problem for basic C programming .. I really need to solve it .. but, so far ... can't ... sigh!: I have an actuator that will be commanded to make sine wave motion.  The program that does that, in the actuator’s driver-controller, requires the actuator to first be in a zero position.  Homing has already been done, so the drive knows where the actuator is.  I cannot modify the sine wave program; but, can command a Move Absolute program in the drive, to take the actuator to zero, if it isn’t already there.  When the actuator is at zero, it is “In position” and a digital tag will go True. If the Tag is False, the actuator is not at zero, it’s at some other position,  and only the Move Absolute program can return the actuator to zero. So, when launching this position command program, In a Red Lion G3 HMI, using only Basic C programming, how would you write a control program that would test the status of the actuator’s position, and, finding it at zero (the “InPos” tag is true) would start the Sine Wave program.  And, If the “InPos” Tag is false, would start the Move Absolute program, which would return the actuator to zero, and when the actuator is In Position, would start the Sine Wave program. Here’s the tricky part. It will take only a few milliseconds to start the Move Absolute program (if required) .. but how do you get the “C” control program you are writing, to wait until the actuator actually reaches zero, and the “inPos” tag goes true … which could take several seconds? I don’t believe there is a WaitFor function in “C” , and you cannot send either the Move Absolute, or the Sine Wave program more than once .. so, if a loop is used, it can loop only one time .. presumably with conditional delays. (however that's done)  You cannot use Sleep().. that would be cheating.. the full program must run in the least amount of time, and you do not know how far the actuator is from zero. You could use if (! InPos) or if (InPos) to qualify what programs to run .. but, where does the “Wait for In position”  fit into C Programming?  You might be able to use Continue .. but, ya still have to wait for “InPos” to go True…..before running the Sine Wave.       Thanks Much, Regards, Michael
  11. NJ controller firmware upgrade.

    Perhaps I can help ..  I said earlier .."And, I'm going to Omron to get away from Siemens."   This implied no comparison between Omron NJ and Siemens S7-1200 .. they are quite different after all...  However, where they are NOT different, Is the complex and expensive manor that firmware upgrades are performed ...  I think Crossbow thought I was comparing the CPU's 
  12. Thanks for the reply Joe PROBLEM SOLVED... The reason was not expected .. and worth sharing.    There were many good articles out there on how to manage the Windows Firewall .. but that wasn't the problem. There were two identical computers, each was to be able to communicate with the HMI (not at the same time)  One could do it, the other could not. The HMI's IP address is set by configuration software created by the PC, and downloaded to the HMI.   That IP address was 192.168.0.20    Neither of these two PC's had made the original download.   I looked at the LAN static IP address for both PC's, and it was 192.168.0.105 Then I checked (using NetSetMan) the IP address of the PC's WiFi ... One was 192.168.0.19 (the PC that worked) ... and the other was 192.168.0.20 (the one that didn't work) Could there be a conflict?  Two different networks: one trying to communicate with to an IP address over LAN, which is the same as the PC's WiFi  DHCP IP Address?    REALLY? So I turned off the WiFi (little switch on the side of the PC),  Powered Cycled the PC ...  And The communication worked. Well, I liked having the WiFi active .. almost never turn it off   So, I re-sent the HMI configuration software with a new IP address for the HMI: 192.168.0.25  And now both PC's communicate just fine with the HMI.. with the WiFi on and working too... PS.. I do have to turn the WiFi off when running a full Virus Scan with System Mechanic .. otherwise SM will crash .. but that's another story.  
  13. This is a problem that shouldn't happen .. It may be due to a defective Network port in the PC. Basically, it's easy to connect to Red Lion G3 HMI's.. using USB, or Ethernet.   Unfortunately there is a flaw with the G315 processor.. and you cannot connect with newer PC's via USB .. and there is no FIX.   However, connecting via Ethernet should be quite easy .. and, I'm able to do it with several old and newer PCs' .. EXCEPT one:   A Dell Latitude E6410.   I don't need help with the Red Lion programming to enable Ethernet communication via TCP/IP ... That's kinda straight forward. (sorta) What I need help with is... what's wrong with my PC ..?  sniff!      I have two similar Dell's  .. one is an ATG model... I've set the fixed LAN IP address the same in both (192.168.0.105).. and I've set the HMI's Ethernet port (789) to an address in the same subset: 192.168.0.20  ...   The E6410 ATG communicates no problem.. the other E6410 ..communication fails.  Everything seems identical in both PC's (well... not totally .. the LAN cards might be different) Anyone ever had this connectivity problem where only one of two identical PC's can connect via Ethernet? Thanks Much... PS: perhaps a suggestion on troubleshooting a LAN Network card? OR..Firewall blocking the HMI connecting...  ?  
  14. Hi.. an easy question.. which I can't find an answer too .. in the 2 manuals:  V421 and V422 ...: "Can you make a variable that goes TRUE when a particular page is selected, and "live" on the HMI screen?" Yes, it's easy to map NJ variables to the objects on the HMI pages...  Yet, It's not clear how to create a variable for a "specific page".. so it is TRUE when that page is on screen. I'll keep looking .. and post what I find, in case no one posts the answer ... thanks   Regards, Michael
  15. INNO  .. You are awesome...     I just tried writing that program yesterday.  Tyler Corbett (Omron Engineer, Canada) told me about "SetVariable" yesterday.  I can't believe I missed that when I looked over the list of "Actions" in "Events and Actions" ... (I have that same problem when I'm looking for a specific item on a menu ... sigh!)     My first attempt WORKED!    .. I didn't try to make the NJ side variable to go FALSE when the page does away .. you just showed how to do that ..  my first job this morning, with coffee ..       Life truly has meaning Tyler also presented some good info on going the other way.. where the NJ is controlling the pages on the NA HMI ... Nice!
  16. OK.... One last way of saying it: Special_NJ_global Variable := TRUE  when Special NA globalVariable is TRUE  IF "PageName" is _HMI_CurrentPage   ... How hard can it be?  Yes, I know the above expression is bogus.. but, it makes the point......  
  17. On Page 8 of NA Practices Guide ..Omron manual V422-E1-01 .. Last question:  "Is it possible to switch the screen from the PLC? Is it also possible to report the current screen from NA to PLC?"     Someone asks  a two question, question, and this is the only answer: "On the NJ, specify a String-type variable and assign it to “_HMI_CurrentPage”, a system variable that specifies the current screen. You can change the screen by entering the name of the destination screen in the variable assigned to the system variable. If the address values are directly linked with the page numbers as in NS series, you must write Visual Basic". This answer probably means something to someone who already knows how to do it ... but, it's not much help for me.  I get that you create a String-type variable: select STRING[256] under the Type column.. But, what does it mean to "assign it to this system variable: "_HMI_CurrentPage"  .. the answer seems only to answer the first question, and ignores the second question.. which is the one I'm interested in....  Do you know the answer to the second question?  PS: I think it's in the NA's Variable Maping .... working on it... EDIT.... Nope.. nothing there.. that's just for calling pages from the NJ software...   I want to work with input variable data, and display of resulting variable data on that same page; because, the input data creates the output data.  an' I don't want to push some "Equals" button that activates an ST rung.. I want the ST rung to be auto activated by the "existence" of the current page ... "_HMI_CurrentPage"  or something like that....???   Thanks, Micheal
  18. You sayin' I would have to use Visual Basic to create a script to make a special variable TRUE  ... hmmmm...  what's the indicator in software, that a particular "page" is "ON, or TRUE ? (remember I'm a bit of a newbie here.. sorry     FYI.. I did finally figure out the last 2 wave sequences, with some Tsunami help from "Dirt" on PLCs.net https://www.youtube.com/embed/B0UGm9JTw3U?rel=0  
  19. More Example: I’m going to make a Regular Wave, I input 85mm for a height, and 0.68 seconds for the wave period.  instantly, if something is already in the SCALE data input (200), the Full Scale Height in Feet (55.8), and the Full Scale period (9.62) would be quickly displayed in the data display windows… yet the axes hasn’t run yet  (Start Regular Waves) …    How can I get these Full Scale data displays to work before the axis is run?      PS:  You can see that they work fine, after the axis is run …. .. thanks to memory of variable data….  
  20. Thanks Crossbow .. I remember reading something like that .. You have to map page numbers 0.1.2...  to the page names ..  It wasn't real clear how that would help do what I wanted.    But, that idea of a "script" that turns on and off looks good...  I'll research Scripts in those manuals... I'm looking for a way to set values or binary states to variables, depending on what "Page" was displayed on the HMI ... As an example, when I input values on a page like "wave height", and it might be in feet,  There would be another data display object (on the same page) that indicates the height in millimeters; however, that display in mm, would be based on a "Scale" factor.... like 1/200  or 200.   "Scale" would also be a data input on this, or other HMI page.    I would like the data displays to be "live" .. so that when a scale and a wave height is input as data, the wave height in mm, is displayed.    No axis program is running yet.  The HMI page is live for inputting and displaying variable data; but the CPU isn't doing any servo controlling ... I need a way to display variables that are calculated from inputted variables.  I need a small program to go live when a page is displayed, and always be calculating, and displaying different variables on the same page.         Basically, you input something, and other data displays on the same page, change in response.   Because, they mathematically depend upon the values of the variables you inputted. I would like to see them, before running the axis.    
  21. The fix is two fold:  1) the equation for only 1/2 cosine wave, is not practical, in that in one cpu cycle the position can go from + PeakMax to zero... The position equation must have a few extra points past peak + position ... so, this part of the equation:  SIN(Pi * Sine_Time ....  should be SIN(2 * Pi * Sine_Time ....  or at least 1.1  ...Just to let the IF-THEN statement catch the peak, before it drops to zero. 2) Best to use the ST version of incrementing the StateTracker variable rather then ladder in the adding of different cosine waves in series...  The ST: Inc(StateTracker) will get you out of an ST series, and into another ST series if needed.   But then, you already knew that if you took the Omron classes ...      Thanks for looking .... Regards, Michael
  22. Hi..  Still Trying to make this Position curve: Pay no attention to the glitch (arrow)  it's a different system (Think of it as inches not volts) .. this pic just shows what I would like to do with the NJ and a linear motor .. It's like 3 parts. first is a cosine move from zero to peak-to-peak (2 * Amplitude) of a position data stream from a MC_SyncMoveAbsolute fb.  The position holds for a few seconds .. then an MC_MoveAbsolute ramps the position slowly back to zero. How hard could it be ... Here's where I am so far: set variables and select for an OFFSET if required:   Equation (6) generates the cosine position move .. the trick is to stop the equation when the max positive peak is reached.  IF-THEN tries to do that (TLim is a small value 0.001mm)  to make sure it's possible for FSine_Tsunami to be larger than 2*TsunamiAMP .. T_Hold starts the TON, and TsunamiRun (the command that started the sequence) goes FALSE.   Line 10 does stop the equation at the right time ...  it's what happens next where all hell breaks loose.  The next trick is to HOLD that last position for 4 to 6 seconds.  This just won't happen because there is no way to stop line (6) of the ST.  No way to freeze a position while still using the MC_MoveAbsolute, stop using it, and transfer control to a MC_MoveAbsolute.    This is my Question ... Delay_Timer.Q goes FALSE because Tsunami_Run is now FALSE (Rung 21)  This messes up the axis control by the MC_SyncMoveAbsolute fb. and the linear motor jumps negative a little; However, 4 seconds later, the MC_Move Absolute kicks in (RUNG 31) and returns the linear motor to zero (or Offset, if selected): Everything gets Reset by rung 33 & 34 Sooo.. this program doesn't work, and is certainly not the best way to make the position curve..   The one thing I could really use help with, is how to jump out of an ST equation for a Global Variable that's being generated by the MC_SyncMoveAbsolute .. hold the selected last position.. and transfer control to a MC_MoveAbsolute, to ramp back to zero or Offset. Regards, Michael Update:  this same post on PLCs.net has over 2200 views .. and, I did get some good help there (equation (6) for example .. unfortunately methinks there are no Omron engineers visiting PLCs.net very often.    Most Omron Engineers are very busy, and I can see why.  You do have to do some serious training at Omron schools, and years of internship .. there must be very few Omron Engineers out there.  I didn't know this, when i started the Omron project... sorry)        
  23. STATUS:    Changed to using State Trackers  .. That worked well .. No clunks, and the sequence runs fine; but, only up to a point.  There is a point at short periods (0.3 sec) to the positive peak of the cosine ramp up, when the control fails and the linear motor runs away negatively into the hard stop. (have nice shock pads for that..     This may be due to the position equation itself.  By creating only 180 degrees of motion mathematically ( SIN(2 * Pi * Time increments/Period) + 270 degree Offset)  The 2 is not in this equation)  The equation is only for a half cycle...  perhaps it should be in the equation... or something a little larger than 1 .   Because, the "end" timing is too critical.  In only one CPU cycle, (0.001sec) the curve will go from + peak(max) to zero!.     Probably, better to make the cycle go slightly past + Peak(max), but try to catch the + Peak(max) with the IF-THEN statement.   UPDATE:   RESOLVED... both Tsunami and the Rogue wave series: Found a way to use Inc in ST ..  makes for easy jumping to various states.. or stages..     Thanks all!
  24. I see there are some nice math instructions in the NJ's menu.    I can't use a MC_MoveAbsolute.  It must be a Cosine position curve running from zero to a positive max end position. I imagine I can use an offset to start the curve at zero, as the COS instructions produce a wave from -1 to +1 and back again.   The trick is to start the curve at -1 and end it at +1 ... If you know an easy way to do that, please share..     Regards, Michael   PS:   This may seem silly .. but, after finding it so easy programming a Delta Motion RMC75E motion controller to due exactly what I'm asking above... I am surprised as to the degree of difficulty dealing with Sysmac & the NJ ...  The level of complication is excessive, if one tries to go beyond the available Function Blocks, Functions and packaged math expressions.    Sure it's easy to do a trapezoidal move from one position to another.  But, I want a cosine curve (or, if you like, a sine curve) .. they are somewhat the same ... but not exactly the same .. and they are certainly not a trapezoidal move component.       I know The NJ can do sine waves ... Check this out: https://www.youtube.com/embed/gGzp7HURBJE?rel=0&controls=0&showinfo=0 Perhaps, this video will help illustrate the problem.  Regrettably, it may require some innovative programming on a complex level ... such work is often done for the programmer by other manufactures of Motion Control modules...  it is certainly beyond my experience, and ability.  Any suggestions, short of actually writing the program, would be a big help in my learning curve... Thanks much.
  25. UPDATE ... This works... Sort of: The ST and the MC_SyncMoveAbsolute fb start at the same time, when the peak + is reached, StateTracker is incremented to #1), Stop_Tsunami goes TRUE, (rung 32), TCosine_Start goes FALSE (rung 29), and T-Hold goes TRUE (rung 30).  FB_SyncMove is disabled: After 6 seconds of Hold, increment State Tracker to#2, which  enables Tsunami_ReturnRamp Fb, returning position back to zero: Tsunami sequence ends, MC_Stop is activated, and StateTracker is reset back to #0   This works nicely .. but it isn't with a flaw .. somewhere..   For TsunamiPer longer than 0.3 seconds, everything works as it should.  Shorter than 0.3 seconds, (higher velocites, and decelleration ...  The linear motor's slider, when first stopped at the peak + position ... doesn't HOLD, it moves quickly negative to the hard stop...and there's a FAULT .. Could this be due to the way MC_SyncMoveAbsolute is "Switched Off" ?      Here's a trace from the LinMot drive: Not too bad.. 0.4 sec. rise time to peak of 60mm... But look at what happens at an attempt at 80mm in 0.4 sec: It does it... but control fails at the transition to "Hold" ... so much for holding,  .... YET, the NJ has no problem keeping control of a 154mm sine wave at 0.4 sec. period ..... To be continued