wbaumgartner

PID Loop Review

5 posts in this topic

Hi all, I am trying to set up a PID loop for a project I'm working on, and I was hoping someone could take a look at it for me. Most of what is written comes from the Q, L programming manual, but I've changed a few things so that the program can write changes to the SV as needed. The processor is a Q03UDE and the Analog Module is a Q64AD2DA, using only channels 1 and 5. Thanks for looking!

PID Project.gxw

Share this post


Link to post
Share on other sites

Are you getting some alarm or problem?

Share this post


Link to post
Share on other sites

No, I have not implemented it yet. I work remotely, and there are no automation techs onsite. The maintenance lead is onsite to help me test, but I want to make sure I have it correct before installing.

Share this post


Link to post
Share on other sites

     Dear wbaumgartner,

     I took a quick look and your program looks OK for me, as program structure. I ran it under simulator to check if any errors would appear (and, believe me, if you do something inconsistent for these QPLC PID instructions, you will sure get 4100 coded operation error) and no errors (I don't know if you tried to run your program under it, and more recently the GXW2 simulator is supporting PIDINIT/PIDCONT instructions).

     As you may know, PID is very process-dependent control so it is difficult to really know if it will work but all-in-all it the program looks fine.

     BR,

     Thiago

Share this post


Link to post
Share on other sites

Thank you very much. 

1 person likes this

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now