engMoH

Altivar 71 Command word

5 posts in this topic

I connected between Altivar 71 VSD drive and Modicon M340 PLC through MODBUS RTU RS485 and the communication is ok, now i want write  a command word using Write_var function to control the VSD but I find very confusing.

first : it's written in cataloug that bits from 0 to 15 can be assigned to commands , is that done from HMI? i  can't find anywhere on HMI.

second : in the function (both read and write) obj element can be int or bool bit but the EMIS element  in 'write_var' function (data going to VSD registers) only accepted if it's array of int not bool so i can't trigger the bits i want !!

third : like the picture the VSD showing it's in NST mode and it says that it won't start until hex value of 6 written to command word but the catalogue says that only bit 0 is assigned(to forword command) and other 15 bits are free for user to assign and 6 in hex (0110) bit 1 and bit 2 still not assigned to any thing  !!

i hope anyone could help 

3.PNG

4.PNG

5.PNG

Edited by engMoH

Share this post


Link to post
Share on other sites

Hi engMoh,

do you use I/O scanner on ATV71?  If yes, then just use WRITE_VAR block to write 2 registers at address 0.

The first register will be ATV71 command word (value 16#0006 -> 16#000 7 -> 16#000 F  for starting ATV) and second register will be RPM of the motor.

Share this post


Link to post
Share on other sites

Hi Quant,

thanks it worked when i write 6 then 7 but in the address 8501 not 0 .

now i want to make a ladder program to make it Automatic i tried to make ladder program to write 6 then 7 in same register but it keep writing 6 then 7 forever so the motor just make sound but is not moving. can you help me on that ?

it has to write 6 then 7 for one time and not keep writing them forever, thanks in advance.

Share this post


Link to post
Share on other sites

the easiest way is to use EQ blocks and compare actual status word or status bits with predefined values and then trigger the MOVE blocks, which moves 6,7, to to command word.

Share this post


Link to post
Share on other sites

Hi Quant

thank you again, it worked now i can operate the drive through ladder diagram. still one small problem to end it i hope to solve it. every time i download a code on plc the drive give modbus fault and won't operate until i disconnect power to VSD then reconnect it again. i want to reset fault when i press start.

i found this in catalogue, and what i get is that i should write 177 in the address 7124 every time in the starting is that right? didn't try it yet, if you have any thoughts please share it with me.

r4.PNG

Edited by engMoH

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now