Sign in to follow this  
Followers 0

Intouch 2017 U3 SP1 - AB Controllogix

4 posts in this topic

Hi all.

I've been tasked with installing/configuring a development box (dev studio 2017 U3 SP1) and then creating a test application using Intouch to communicate to a bunch of rockwell PLC's on the test wall.

Normally we would use Citect or FactoryTalk Studio but unfortunately the customer has a couple of OEM InTouch panels (I think communicating with Siemens PLCs *shudders*) and wants to go this route.

Anyways. I spent a day installing and configuring a windows 10 development box with 2017 U3 SP1, Hit the windowmaker tile and started to cry....

The new AVEVA website is practically useless, and I'm still waiting to be contacted from technical support.

I have used an older version (much older maybe 10 or 15 y/0) of the intouch software which was interfacing a triconex PLC, It looks like the developing of screens hasn't changed too much, however,

Q/ What exactly do I need to download/install for my communications?

I've read the PDFs that installed with the dev software and watched a bunch of youtube vids (and fruitlessly searched the aveva knowledgebase) and there looks to be more than one way to skin the cat.

Maybe I missed the option in the multitude of installation screens to add additional drivers??

It looks like I need either SuiteLink? or ABCIP version 7? (assuming they are not the same thing??).

I can only see ABCIP version 4 (dated 2012) on Aveva (and a tech note about version 6.? and 7.0 potentially crashing the L8x range of AB PLCs) and I'm sure suitelink is a collective term for any and all drivers

It seems like it should be a very simple and obvious thing to do but I'm stumped.

Any assistance GREATLY appreciated

Regards Dave

Share this post

Link to post
Share on other sites


So... made a bit of progress.

I found the "driver" package by searching "OI ABCIP 7" and narrowing down by selecting Downloads  (how silly of me not to add the OI bit)


Installed the "driver"

Set up the "Topic" layers


Now it looks like I need a Galaxy (seriously who comes up with these names) - I created one called "Rockwell" but it wont accept it until I define a device group


Q/ Where the hell do you set up a device group?

I have connected to the galaxy but can't find anywhere to create a device group.

Give me Citect/FT View any day!!


Any help greatly appreciated

Regards Dave



Share this post

Link to post
Share on other sites

Update 2 (for anybody unfortunate enough to have to set this up in the future)

The device group is part of the topic configuration, nothing to do with the galaxy (despite being under the big galaxy radio button)



Next hurdle....


From InTouch WindowMaker I select Special->Access Names

I then select Add on the dialogue box, give it a name and select modify


I tried with and without LocalHost (and loopback address)

I tried with and without the fully qualified path of ABCIP (C:\Program Files (x86)\Wonderware\OI-Server\OI-ABCIP\Bin\ABCIP) - fully qualified path gave an error and asked if I wanted to start the EXE

I tried DDE and SuiteLink

I tried using the names from each layer of the Configuration (maybe it needs all the layers... nope... didn't work!!) as the topic. but my flashing PLC bit is not happening in windowviewer.

From the help...



Am I being really thick or is this a ridiculously complex way to achieve what every other HMI/SCADA software package (that I have used) manages to do very simply.


Anything welcome

Regards Dave




Share this post

Link to post
Share on other sites

....and the final update... only took 6 hours to make the connection to the PLC.

Turns out the "Topic name" as stated in the help file (shown above), is the "Device Groups" name from the CLX configuration (the same bloody thing that tripped me up with the galaxy)

For any poor b@st@rds in the future, here is the complete setup....

1) Find and download the server (OI ABCIP)

2) Install server

3) Create galaxy using ArchestrA IDE (C:\Program Files (x86)\ArchestrA\Framework\Bin\aaIDE.exe) - EDIT: I deleted the galaxy and everything still works

4) Configure CIP Path using ArchestrA System Management Console (C:\Program Files (x86)\Common Files\ArchestrA\aaSMC.exe)

NOTES - in my case, PORT_CIP, ENB_CLX, BACKPLANE_CLX, LOGIX5000_CLX - the help file is pretty good for setting up the leaf nodes

4.1) Make sure to set the PLCs IP address (or host name) at the communications level

4.2) Make sure to define a Device Group

5) Don't bother with Auto-Build (I'm sure its really useful for something but I don't know what)

6) In InTouch select menu Special->Access Names and add a new item

6.1) Configure the access name.

NOTES: In my case, the server was on the same machine, leave Node Name blank, Application Name is ABCIP (no path or .exe) and Topic Name was the Device Group name defined in step 4.2

Path to OI server exe in my case ABCIP (C:\Program Files (x86)\Wonderware\OI-Server\OI-ABCIP\Bin\ABCIP.exe)


Hope this is of help to somebody in the future

Regards Dave

Edited by ADoozer
delete galaxy step

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0