4 posts in this topic

Hell PLC World!

I have been trying for several weeks in my spare time at work to tune an Allen Bradley Servo Motor.  Below is the list of hardware I am currently using:

- CompactLogix Motion Controller (1780-L33ERM)

- Kinetix 350 Driver (2097-V34PR5-LM)

- MPL Series Rotary Servo Motor (MPL-B310P-MJ74AA)

I have been using RSLogix5000 for testing and I plan to use it to develop a simple conveyor type program later.  I have tried a list of things which will be below, but to no avail, I cannot simply jog the motor for any period of time without triggering a position, velocity or bus voltage error.  I have tried changing the motor, driver and feedback cable to no avail.  Here is the process I have used:

1) Add the hardware to RSLogix5000 (PLC, Driver and Motor)

2) Configure the motor

3) Run the hookup test.  This works flawlessly.  The motor will slowly turn independently on the feedback test for as many revolutions as I input.  This is what makes me think I am doing something wrong in the tuning process.

4) Run autotune process with the velocity, acceleration and jerk set well below the limits of the hardware.  

5) Attempt manually control motion

6) Recieve error

I have tried changing the input from trapezoidal to S-Curve, changed velocity and position limits, manually tuned velocity gains in a myriad of configurations.  I have swapped legs on the 3 phase input (which made matters worse).

I suppose it is possible that multiple pieces of hardware are faulty because this equipment was previously used, but I still cannot wrap my head around why the hookup test would work so flawlessly, yet I cannot just get the servo to rotate at an equivalently low speed.

If anyone recognizes my mistake, I would be eternally grateful.  I am an intern studying control systems in graduate school and as popular as AB is, I would sure like to get some experience with it.  Thanks in advance!


Share this post

Link to post
Share on other sites

When you say that the hookup test ran flawlessly ("The motor will slowly turn... for as many revolutions as I input.")  Are you using the same speed settings (accel, velocity and decel) settings when you run your test as the hookup test uses?  I have had similar experiences during my testing where I have had aggressive accel or decel rates or the speed was excessive.  

How long after motion starts do you receive the error?

Do you have any gearing between the motor and the load?  Is the inertia of the load within the motor specifications?  If inertia is not matched between load and motor, then you will be able to achieve slow velocity movements but will most likely fail when positioning.


Share this post

Link to post
Share on other sites


Thanks for you input.  There is no load attached to the motor.  It is just sitting on the benchtop uncoupled from anything.  There was no hookup speed, acceleration, or jerk given in the hookup test, so I just turned those settings down very low.  Sometimes the fault will occur immediately, sometimes it will occur after 10 to 15 sec.  We have never been able to accomplish any control of speed.  For example, if I set the speed to 1 position/sec, acceleration to 0.5 pos./sec^2, and jerk to 0.25pos/sec^3, it will still spin extremely fast.  Most often, the servo spins out of control as soon as MSO (Motion Servo On) is activated.  I will not even get a chance to actually jog the motor at a specific speed.  I hope this all makes sense.  Thanks again!

Share this post

Link to post
Share on other sites

Unloaded motors are difficult to tune and will sometimes exhibit the problems you describe.  If I were you, I would try one of the following:

Find a load for the motor.  It could be a plain gearbox with no load, or a pulley system.  It is best if you can create a geared ratio of at least 3:1.  The higher the ratio, the better results you will find when doing the autotune.

If you can't find a load, then try to change the autotune parameters relating to the motion.  I am not near the software, so I can't tell you specifically what to change.  Start with the distance then change speed.  I have a feeling once you open up these settings, you may see a failure in the autotune.  Again, unloaded motors are hard to tune and that may show up if you try it with a longer move or higher speed.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now