Sign in to follow this  
Followers 0


1 post in this topic


I'm having trouble configuring this PLC to be able to communicate via Ethernet. The CPU is a TSX 57453, and the communication module is an ETY 110.

I can connect to it using the TSXCUSB485 and download a program just fine, but I don't quite understand how to configure the module to be able to communicate with the PLC via Ethernet, I've read the module guide and the PL7 guide but I'm still not getting how to do it correctly.

This is what I have done so far. 

  • I have configured an IP address, a Subnet mask and a gateway address in the module (ETY 110)
  • Tried to ping the IP address of the PLC and is not working.
  • I have configured the XIP driver (although I don't know if I needed it to communicate with the PLC via Ethernet), setting the local host XWAY address and all the info for the remote host (XWAY and IP address).


Any comments?, thanks.



I have managed to ping the IP Address, now the problem is configuring the PLC Address in PL7, the help document says the following:

The network address syntax is as follows:    

(network no. station no) module track no. PL7 address  

(network no. station no.)SYS

{network no. station no.} = network address and destination station on FIPWAY (this part is omitted if the PL7 to be accessed is not on the FIPWAY network).

PL7 module.track address = UNI-TELWAY address (module = 0 or 254, track no. = 0 terminal point or 1 for the communication card, PL7 address = 0 to 98).

SYS = access to the system gate (or UNI-TE server) of the destination PL7. 

Using the number 254 as a position when communicating between slaves allows it to stay on the same UNITELWAY bus by optimizing exchange routing. 
{0.2}0.1.3 = PL7 having 3 for an address on the Unitelway link of the module 0 communication card, track 1 of station 2 on network 0.

SYS = default address of the PL7 physically linked to the terminal.


So the question is how do I set up the XIP address?

I have tried to put the same remote address as the one that the driver manager has. but I get a pop up saying "The channel number must be 0 or 1".

Edited by erghurt

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0