Sign in to follow this  
Followers 0

Yaskawa MP2300 controller

1 post in this topic

This is concerning the Yaskawa MP2300 controller equipped with 218IF-01 module. I want to establish communication between the controller and the HMI. Following are the observations: 1. The serial communication between the PLC & the HMI is OK. 2. The engineering communication between the MP2300 PLC & the MPE720 software tool is OK. 3. I am facing problem with the message communication between the MP2300 & the HMI through Ethernet port on the 218IF-01 module. I tried with different protocols such as Memobus and ModbusTCP. 4. I incorporated the Ladder programs for MSG-SND & MSG-RCV functions as two high scan DWG program files H01 & H02 respectively. 5. In the LadderWorks, the current values of the various registers are not displayed though the PLC is in online mode. It seems as if the ladder programs are not being executed. The ladder program is the same as given in the Yaskawa’s MP2300 Communication Module User manual. 6. The following settings were done on the Communications Manager: Logical Port1 Kind: CP-218 IP Address: (of the PC on which the MPE720 tool runs) Rest all settings were default settings. The following settings were done on Transmission parameters screen in Module Configuration for CN (channel no) 01: IP Address: (default of MP2300 controller) All the Local port TCP/IP settings were kept as default. Local Port: 20000 (No specific port no. is mentioned in the manuals) Node IP Address: (of HMI) with node port: 20000. The Ethernet address of the HMI was entered in the proper field. Also tried with Node IP address as & node port as 0. The Ethernet address in this case was entered as all zeroes. Connect Type: TCP Protocol Type: Memobus RTU & Modbus TCP (Both these protocols are supported by the HMI.) The status screen shows the trans status of CN 01 as IDLE & Error status as “No Error”. Send & Receive counts are shown as 0. The MP2300 controller, the PC & the HMI are connected with each other through a 10Mbps hub. Can anyone help me & verify whether the above settings are correct and kindly suggest what further needs to be done to initiate the Ethernet communication between the controller and the HMI?

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0