Search the Community

Showing results for tags 'bootp'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Found 1 result

  1. It's another BOOTP post! I know you're all as excited as I am, so lets get started. But seriously, I'm trying to disable BOOTP on the built in Ethernet ports, not on an Ethernet module. I specifically say disable because BOOTP successfully assigns the IP address to my Compact Logix, however I still need to disable BOOTP to make it a static IP address rather than a dynamic IP address. I'm going to list everything that I have tried, so that anyone with the same issue can have an all-in-one-place reference. (Because there's a number of forum posts and other information for this topic on the internet, with many different suggestions) If I see different ideas/suggestions in other places, I can edit them into this post. Things I have tried: (and you should try if you have this issue) Disabling all firewalls, (For me: Windows/Avast) Disabling all other network adaptors. (Wifi especially, but any and all adaptors you are not using for the setup) Using a different laptop/operating system: (My current laptop runs windows 8.1 and uses a Linksys usb to Ethernet device to talk to the PLC, I tried a laptop running windows 7 which communicated using a built in Ethernet port) Lastly: Try to use all available methods to disable it. For me, that would be: BOOTP standalone server, RSLinx, (Trying to use both USB and Ethernet connections) and finally RSLogix. (Actually, only Ethernet modules have a "disable BOOTP" checkbox built into RSLogix, so that is not an option for me.) [If you have an Ethernet module, go to port configuration in RSLogix and uncheck the "enable BOOTP" checkbox] Anyway, RSLinx Classic (version 3.71) and BOOTP Standalone server (version 2.32) are each coming back with an error when I try to disable BOOTP. I'll attach a .jpg of some screenshots, and some Wireshark save files to show what I mean. In the RSLinx Wireshark file, it shows a "privilege violation" packet being sent from the PLC to the laptop towards the end of the exchange, but I'm not sure what privileges the laptop needs/doesn't have. For the wireshark files: I cleared everything happening before I try to send the command, so that there isn't a ton to search through. As far as timing of the wireshark files go: I start recording traffic, send the disable command (by clicking the disable BOOTP/DHCP button on BOOTP server or "apply" on RSLinx) then I stop recording traffic once I get the error message. So, the captured packets should be just the attempt to disable BOOTP and that's about it. I am sorry that I the pictures are strung together using paint, but I don't have photoshop on my work computer so it's the best I have. Any suggestions/help would be appreciated! (Regardless of whether they are suggestions for me, or suggestions that I may have missed intended for anyone with this problem.) Thank you for your time. Edit: I had the attached pictures open in paint/photo viewer, sorry that they look bad in the forum picture viewer. BOOTP_wireshark.pcapng rs_linx_USB_wireshark.pcapng rs_linx_wireshark.pcapng