Kinetix 5500 Control Sync Fault

5 posts in this topic


I am getting a control sync fault on 2 recently installed kinetix 5500 but only when my programing PC is connected to the machine network.  Install and setup all went great over a 5 day period.  Then all of a sudden I started to get this fault. Sometimes 100 times in an hour.  As soon as I go offline, and unplug my PC the problem goes away.  I have also tried another PC connected to the Machine network and still get the same result.  Sometimes machine can run for hours with my PC connected with no problem.  I do not have to be online with controller for fault to occur.


I have the 2 K5500's ethernet ports daisy chained together, and then connected via shielded CAT 6 cable directly to port 2 of the Compact Logix Controller

Coarse Update is set to 3.5ms and utilization's are at 33% and below.(I have tried the default 2ms with same results)

Ethernet modules are configured with FW rev 7.013.

Machine network is isolated.(not connected to plant network or internet)


Compact logix L33ERM Running version 30.01.

There are a total of four servos in this system all running over ethernet.  2 Kinetix 350's(not affected), and 2 kinetix 5500's.

I have tried:

separate ethernet cables for each drive ran through a switch

different ethernet cables

resetting coarse update speed

connecting a different PC for programming


I am just not sure where else to go with this.  Thanks in advance for any help.


Share this post

Link to post
Share on other sites

Those devices expect to be in a Device Level Ring.  Without completing the loop, they'll run as a degraded DLR.  Your laptop doesn't do DLR, so plugging it in breaks the DLR's timing guarantees.  Add a DLR-compatible switch, complete the ring with that switch, and plug your laptop into that switch.

Share this post

Link to post
Share on other sites

Thank you for the advice. Unfortunately this did not solve the problem.

According to the the AB rep these drives do not require a DLR and will run perfectly fine in a linear/star network.  I have seen this in multiple cases myself. (up to 7 drives daisy chained together)

This problem seems to relate specifically to the Dell computers we are using to program with.

Only advice they could give me is that there is software running in my system tray that can affect the time stamp or synchronous settings.

anyone have any idea of what software can do this?

Share this post

Link to post
Share on other sites

so it appears it was a rslinx version issue with windows 10.  I updated from 4.11 to 4.31 and have not got a control sync fault since.  I will update the thread if I see the error again.

Share this post

Link to post
Share on other sites

K5500 don't need to be on DLR. Interesting that upgrading RSLinx fixed the issue. Nice find. I would look at the motion timing statistics in Studio to see collect data with this issue. Too much jitter will cause a synch fault.  I use FactoryTalk  Updater software (Free) to notify me when Rockwell's PCDC site has newer versions of software so you might be interested in that.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now