Trajexia issues on devicenet

1 post in this topic

Hi, apologise if this is not in the correct section but I couldnt think of a specific section to put it in.

I am having problems with a trajexia on a devicenet network. PLC is an NSJ5 with another ns10 touchscreen. The machine is based in India and I am accessing it remotely via our companys engineers.

At first we believed the problem to be the motion contoller as the program would not initialise or run the watchdog or handshake wit the PLC, so we sent it back to our factory and tested the unit here. After reconfiguring the servo drive and putting a fresh program into the trajexia it was running fine.

We shipped the unit back out to India and the problem returned, no initialising and no handshake. It was then we started suspecting the devicenet network itself and asked our engineers to test the voltages on the network. The lowest V+ to V- reading was 22V and highest was around 23. something, slightly lower than normal but I don't see anything to worry about.

The devicenet power is not dedicated as we have UPS backups and need to keep the devicenet as part of a 24V maintained supply.

Next check was to check the resistance between the Can H and L which was 42 ohms, noticed this was too low and had the engineer remove one of the termination resistors (of which there were 3, no idea why). This brought the resistance to 60 ohms.

We checked the voltage between Can H and V- as well as Can L to V-. The lowest value we got was 2.6V for Can H and 1.6V for Can L. These values seem a bit low because I read that they should be minimum 2.5V and 2.0V respectively.

Running out of options I decided to just try and unassign and reassigned the Trajexia in CX-integrator and then download the network again. I noticed that the trajexia when I tried to view parameters would say no setup parameters exists, so I went to the advanced setup for the node and noticed that rather than the usual 32VR in/out in the connection tab there was just what seemed to be a random hex value. I got a clean cin file for the machine and dowloaded that and it solved the issue with the connection however when I compared the parameters of the trajexia (device) with the program (local) there were the following differences

-          Power voltage monitor : local = 23.7V, Device = 23.3V

-          Power voltage (peak) : local = 24.6V, Device = 23.8V

-          Power voltage (bottom) : Local = 23.5V, Device = 23.1

-          Communication error code : Local = No Error, Device = Network power error

-          Fault network power voltage : Local 0V, Device = 9.8V

The power voltages are obviously just slight fluctuations in the PSU however I have never encountered this network power error

Sorry if the post is a bit longwinded, any help you can offer would be greatly appreciated.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now