Sign in to follow this  
Followers 0

NX102-1220 Ethercat SEW MDX61B

3 posts in this topic

Hi, I am having trouble with the following hopefully someone can help.

Equipment Omron NX102-1220 PLC, SEW MDX61B MoviDrive B with DFE24B EtherCat Card.

I am trying to control an SEW Servo Motor via the Omron Ethercat connection.

I have connected and configured as below image, at this stage there is no errors with the PLC6336b3e3f2b0f_OmronError3.thumb.JPG.0892

When I try to add a Motion control axis I can set it up as below but when I download it to the PLC I get the following error



I have then reversed all of this and added an R88D-KN drive and this downloads fine..

Any ideas what I'm doing wrong?


Edited by NootNoot

Share this post

Link to post
Share on other sites

Some progress with this,

I have done the same setup using a NJ301-1200 PLC and this is not showing any error and is communicating with the SEW drive correctly.

The error I am receiving on the NX102 PLC suggests replacing the CPU, not really something I want to do as this is a new PLC.

I have attached the XML file for the SEW drive, would it be possible someone would have an NX102-1*** series PLC that they could download the same simple Ethercat setup as above to see if the same Error occurs? 






Share this post

Link to post
Share on other sites

I modified the PDO map for the drive to look like this for the input side:


I am unsure about the ActPos_Abs being the correct selection as there are multiple options for actual position.  You may need to ask SEW.  

And this for the output:


I also enabled the distributed clock (right below the PDO Map Settings button).


And then I mapped them like this for the axis:


When I do this, I still get the same error that you were getting.  So I kept digging.  I noticed that SEW's Control Word and Status Word were DINTs (32 bits), so instead I mapped PI0001 and PO001 to those and removed the control word and status word from the PDO map.  Then I attached those to the Axis settings like this:

SEW Axis2.jpg


When I download that, the error goes away.  Of course it will likely not work at this point, but it does show that the issue is that SEW's control Word and Status Word (both should be 16 bits as that is what WORD implies) are actually 32 bits.  So (SEW, ha!), I would ask SEW what the deal is with 32 bit Status and Control WORDs.  They may be able to somehow map one half of those 32 bits to both the PO001 and PI001 WORDs.



Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0