Sign in to follow this  
Followers 0
Alias Andy

Troubles with remote access to omron plc by using tosibox vpn

2 posts in this topic

Hi all, 

I am having trouble with Cx-programmer when trying to remotely connect to a Omron plc (cj2m cpu34) using Tosibox vpn.

Set up is that the Omron plc is located in customers facility and is connected to a Tosibox "lock box ", and i have the "key".

From the Tosibox key side application i can see that the PLC is connected to the Tosibox lock and is available.

The problem is that in CX-programmer, when i try to search for available devices (by using the PLC->Auto online-> Ethernet/IP node online)  i cant find the PLC i am looking for, or any other device connected to the tosibox network. Just gives a empty list. Before searching the cx-programmer ask's me to choose interface card, showing my Ethernet and Wlan - connections, i have used Ethernet one.

I have tried matching the IP addresses in network connections settings for the Ethernet connection but for no avail.

And apparently this connection has worked before, i just have no idea how it was done or what were the settings or methods they were using. 

I'm not sure but i have a gut feeling that somehow the cx-programmer cant recognize (or connect to) the Tosibox vpn connection and proceeds to search without it and then of course finding nothing.

Could it have something to do with the network interfaces? That when i use the Ethernet to connect, it doesn't go trough the vpn?

I am not really familiar with these system so any kind of help would be much appreciated.

So my question: has any one of you ever encountered something similar when dealing with cx-programmer, tosibox or vpn's in general?


Thanks in advance.




Share this post

Link to post
Share on other sites

Hi, i got my self the answer. 

By opening up the PLC program (existing copy of what the plc is running) in cx-programmer and changing the PLC's network type from Ethernet/IP to just Ethernet, and from network settings (driver tab) setting up the ip address to match.

After that just " Work online" and it worked.

Didn't really help to the problem of not seeing anything when searching.

But i got the connection to the PLC and that's what i needed.

1 person likes this

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0