simonongsk

NX1P2 Fins

7 posts in this topic

Hi:

      Has anyone use Fins Command with NX1P2 (or any NX/NJ). I try with Multiway with "[!]: Command format error (1004)"

Below is the command from multiway

800003000100000100060101820001000003

Data memory are define in global variable table as  A as %D1, B as %D2 and C as %D3.

The relevant setting are done on Fins Setting and Memory Setting in the PLC.

 

Anyone ?

 

 

Share this post


Link to post
Share on other sites

 Download Etherway - much better.

Give yourself some more memory to work with - for testing give yourself 100 words and stick to one memory area. I found an old FINS command and response from Etherway for D20:

<--: 46494E530000001A000000020000000080000300140000FB00050101820014000001  (Request)
-->: 46494E53000000180000000200000000C0000200FB000014000501010000FFFF   (Response)

Capture.PNG

Capture.PNG

Share this post


Link to post
Share on other sites
11 hours ago, photovoltaic said:

 Download Etherway - much better.

Give yourself some more memory to work with - for testing give yourself 100 words and stick to one memory area. I found an old FINS command and response from Etherway for D20:

<--: 46494E530000001A000000020000000080000300140000FB00050101820014000001  (Request)
-->: 46494E53000000180000000200000000C0000200FB000014000501010000FFFF   (Response)

Capture.PNG

Capture.PNG

11 hours ago, photovoltaic said:

 Download Etherway - much better.

Give yourself some more memory to work with - for testing give yourself 100 words and stick to one memory area. I found an old FINS command and response from Etherway for D20:

<--: 46494E530000001A000000020000000080000300140000FB00050101820014000001  (Request)
-->: 46494E53000000180000000200000000C0000200FB000014000501010000FFFF   (Response)

Capture.PNG

Capture.PNG

Hi @photovoltaic:

                                          I did use Ehterway, the  end result is the same error code of 1004.  but using UDP. It seems like you are using TCP?

How do you set up TCP instead of UDP in Sysmac Studio? 

The Etherway shown Time out if I am using TCP (client ?) Try connecting to 192.168.250.1  ERROR: No connection could be made because the target machine actively refused it 192.168.250.1:9600.

 

 

Share this post


Link to post
Share on other sites
19 hours ago, simonongsk said:

Hi @photovoltaic:

                                          I did use Ehterway, the  end result is the same error code of 1004.  but using UDP. It seems like you are using TCP?

How do you set up TCP instead of UDP in Sysmac Studio? 

The Etherway shown Time out if I am using TCP (client ?) Try connecting to 192.168.250.1  ERROR: No connection could be made because the target machine actively refused it 192.168.250.1:9600.

 

 

It is TCP yes. A lot of what you see is the header. You change between TCP/UDP here:

Capture.PNG

Share this post


Link to post
Share on other sites

Posted (edited)

I did a test with UDP reading words D1,D2, and D3 from my NX1P2. See screenshots.

TCP doesn't work on the NX1P2. The message I posted earlier was from a different controller.

Capture.PNG

Capture2.PNG

Edited by photovoltaic

Share this post


Link to post
Share on other sites

@photovoltaic:

                           I am using NX102 9000. The error is dealing with connection. What is the Fins Settings (under Built in Ethernet/ip) . I am unable to make connection using TCP. Even with UDP, the error of 1004 will occur if the command is send to the PLC. If I use the TCP/UPD Messaging Services, Connection can be make but response message is not encouraging

<--: 46494E530000001A0000000200000000800007000100007800020101820001000003
-->: 46490400009A1500

May i know are there any setting in Ethernet/IP and the Operation Setting tabs?

Attached 

Error.jpg

Fin Routing.jpg

Finsetting.jpg

tcpudp.jpg

Share this post


Link to post
Share on other sites

If you are using the NX102 then FINS is only supported on ethernet port 2. It looks like you are connected to port 1.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now