Sign in to follow this  
Followers 0
Robror

HMI Data transfer to PLC

1 post in this topic

Posted (edited)

Hi there! I'm trying to communicate HMIS5T HMI with a Modicon Micro TSX3722001 PLC.

The communication is OK, but whenever I try to enter some data into a numeric display I get an error that says "Method or function in Communications System unsupported" and data won't change on PLC's Animation Table. Also, if I modify a variable's value in PL7 Pro, the value in the HMI numeric display won't change properly. It displays the last digit of the binary format of the number (let's say I write a "3" on PL7 Pro, then I get a "1" on the numeric display, despite all data types being UINT, and all ranges are OK. Then if I write any number which binary version ends in 0, I get that 0 on the numeric display, nothing else. Again, all data types and ranges are OK).

Changing variables' source on Vijeo Designer to Internal doesn't seem to work. So I'm wondering what else must I do in order to send and receive data from/to HMI and PLC? 

 

Thanks in advance and I hope you can help me!

Update: Got this solved. For anyone wondering, Vijeo Designer 6.2 SP8 it's kinda buggy with Unitelway communication. There's a hotfix that solves this problem, provided free by Schneider.

Edited by Robror

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0