Sign in to follow this  
Followers 0
JustinSmith

SLC 5/03 rs232 connection problem

11 posts in this topic

I have an SLC 5/03 that Im trying to get the program from. I have a 1747-uic. Im not getting anything to show up in rslinx and I suspect the channel 0 is configured for ASCII because theres an HMI plugged into it. Also the rj45 connection is broken because someone used a crossover ethernet cable...lol. is my best bet to try and fix/replace the 1747-uic? I have an offline copy of a program from a different machine that uses a 'similar' setup and the CH.0 -System is configured for DF1 full duplex,19200,CRC and CH.0 - user is ASCII 19200 baud. Any Ideas? I was using the 3 wire db9 connector running from the HMI to the PLC. I unplugged it from the HMI and used it with the 1747, Should I use a standard DB9 cable with a null modem adapter?

Share this post


Link to post
Share on other sites

Posted (edited)

Null-modem cable, if port configured for DF1. Autoconfigure should work.

The 1747-UIC is for DH485 only. The port would have to be configured for DH485 protocol.

 

What is the complete catalog number of your HMI ( PanelView?). With this we should be able to tell how the serial port on your SLC is configured.

Edited by Mickey

Share this post


Link to post
Share on other sites

Thanks for the reply Mickey. I'll pick up a null modem cable tomorrow on the way to work. I'll post more info about our setup tomorrow. We got a 'new and better' laptop from IT with a smaller screen and no serial port haha. Should I buy a serial to usb converter?

Share this post


Link to post
Share on other sites

Posted (edited)

 

Quote

Should I buy a serial to usb converter?

You will need one. Bear in mind not all USB to Serial adapters work. "Keyspan" and see link(s) for ones that do work.

 

https://www.plccable.com/allen-bradley-usb-1747-cp3-1756-cp3-1761-cbl-pm02-micrologix-and-slc/

 

https://www.tripplite.com/keyspan-high-speed-usb-to-serial-adapter~USA19HS

Edited by Mickey
1 person likes this

Share this post


Link to post
Share on other sites

So Im looking at the project file from another machine that has a similar setup and Chan. 1 - System is DH+ at 57.6k Baud, Chan. 0 - System is DF1 Full Duplex, Chan. 0 - User is ASCII 19200 baud. thats a 5/04 cpu though. Our machine in question has a 5/03. I will try the DH485 connection today but Im pretty sure our 1747 converter is broken for dh485

Share this post


Link to post
Share on other sites

Channel 1 is set to dh485 and the indicator led slowly blinks, when I plug in the 1747-Uic to the port with a straight pass through cat5 cable the light continues to blink. On the 1747 the usb and dh485 lights occasionally blink but still nothing shows on rslinx 

Share this post


Link to post
Share on other sites

Posted (edited)

Quote

a straight pass through cat5 cable

Channel 1 on a SLC5/03 can only be DH485.

That is not the right cable. A 1747-C13 is the right one to use( note misssing pins) you may have damaged the 1747-UIC because the SLC has 24 volts on one of its pins.. see link(s)

 

DH-485 Cables used with SLC-500 processors and the 1747AIC.pdf

1747UICProcedure.pdf

Edited by Mickey

Share this post


Link to post
Share on other sites
On 3/13/2021 at 1:00 AM, Mickey said:

 

You will need one. Bear in mind not all USB to Serial adapters work. "Keyspan" and see link(s) for ones that do work.

 

https://www.plccable.com/allen-bradley-usb-1747-cp3-1756-cp3-1761-cbl-pm02-micrologix-and-slc/

 

https://www.tripplite.com/keyspan-high-speed-usb-to-serial-adapter~USA19HS

Another vote for both of these devices. All of the stuff I've used from plccable.com has been top notch and the only things I haven't been able to connect to with the Keyspan USA19HS have only worked at all with a native COM port. In my experience, if the Keyspan won't work, none of them will. Mine has been dropped multiple times so that the housing has electrical tape holding it together and it still works perfectly. I've had it for about a decade.

Share this post


Link to post
Share on other sites

Thanks guys. I got the adapter in the mail and it worked right out of the box. I was about to start pulling whats left of my hair out!

Share this post


Link to post
Share on other sites
20 minutes ago, JustinSmith said:

Thanks guys. I got the adapter in the mail and it worked right out of the box. I was about to start pulling whats left of my hair out!

Which adapter did you get?

And thanks for coming back with your solution.

Share this post


Link to post
Share on other sites

The Tripplite keyspan usb serial adapter + a null modem adapter for my serial cable

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0