PeterParker

Alarm Comments Not Showing on GOT

7 posts in this topic

Hello!

Im trying to set up Alarms on my project using GT Desisgner 3. My GOT is a GS Series, and my PLC is a FX5U.

I usually just do a multi state lamp with descriptions for what's happening on the machine, but this system is much more complicated, so id like to do an alarm screen.

I found a few sample projects, as well as tried both the Simple and User alarm tools on my own. However once everything is set up, when an alarm is triggered, the comment for that alarm is missing...

The alarm time of occurrence, as well as turning green when its resolved all works on the screen, but i cant figure out why my comment doesn't show up.

When in my project, all the "previews" of my comments show up great and are all there, just not on the screen itself...

 

Any help would be greatly appreciated! Thanks!

Share this post


Link to post
Share on other sites

Can you post your project or just that part so we can see what you have done ?


 

Share this post


Link to post
Share on other sites

Posted (edited)

Project attached 

Screen 9 is my temp screen while trying to figure it out

 

Thank you so much Gambit

W1338_CIEMATIC_HMI.GTX

Edited by PeterParker
Solved

Share this post


Link to post
Share on other sites

Posted (edited)

You're setting are fine, But you also using multi language. 
By Default Spanish. You will need to make D0 - 1 (English language) to show the correct comments. 
Alternatively you can also set if no language is set to display nr 1 in the multi language settings.  (display radio button)

I hope my explanation is clear if not let me know

 

Capture.JPG

Edited by Gambit

Share this post


Link to post
Share on other sites

Oh man,

I will look at that.

I was a little overwhelmed using the comment setup for language switching, and i need that for this job. So i decided to duplicate my screens and do Spanish variations instead. My language switching is then done by 2 buttons that are flags, that switches between my groups of screens. I'm too used to language switching on Vijeo screens which is built into the text input, this is my first Mitz trying to do that.

I forgot that the first thing i did was enable that Spanish, and then deleted the other column after an hour of frustration.

 

Thank you so much Gambit!

Share this post


Link to post
Share on other sites

Turning off language switching fixed it.

 

Thank You!

Share this post


Link to post
Share on other sites

Posted (edited)

The duplicate screens are totally not necessary. Just create all the screens in English but use comment text and not direct.

Than all you do is change the value  multi language register in your case D0 to 2 3 4 5  etc which means the comment column (language)

just some suggestions:
use labels instead of direct device addressing
use overlay screens for the menu's 

Nice Flags though :)

If you need some help let me know spiderman :)

Edited by Gambit

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now