CQM1H-CPU21 communication with NT21

3 posts in this topic

Hi All

Newly registered here and in need of help!

I have a sketchy knowledge of PLCS, usually enough to get me by in my field of maintenance. However as you might have guessed I've come unsuck with the equipment in the title.

The situation is this; I have a machine running on a CQM1H-CPU using the NT21 as the operator interface, Ive had an intermittent problem for a while with the NT21 coming up with a comms error. ive replaced the NT21 which had no effect so i also replaced the comms cable, again no change, by elimination i ventured to change the PLC itself. I had the PLC program backed up on a laptop which I transfered to the new unit via the CX programmer, with seemingly no errors. When I powered everything on the NT21 is stuck on 'system initialising' which I'm aware means its not communicating. It fails the host link test in the NT21's servive menu. with the old PLC its intermittent. Ive pulled it out of the machine and put the old one back so they can run the machine for now and ive rigged up on my bench the CQM1H-CPU21 and a NT21 so I can have a play however Im struggling to get communication. Ive checked the cable works and the the NT21 works on different machines so i know theyre both ok. Ive checked the comm port settings match. Obviously the peripheral connection works as I can easily connect to the CX programmer

Im thinking that Ive missed something in the transfer to the new PLC? Ive checked dip switches are the same and have tried dipswitch 5 in both positions. I did read in various online manuals of the DM values however this is getting out of my knowledge base, I had thought that everything I'd need like that would be in the transfer? or was that simply the program that has been transferred?

Any help would be hugely appreciated and any brownie points I get for fixing this will be shared equally....




*Sorry for the double post, too impatient and jabbed too many buttons, admin feel free to delete one! thanks

Edited by chrisnewbie

Share this post

Link to post
Share on other sites

Hi Chris,

How are you connecting to the PLC to the PT unit?
• Connect to the CPU Unit’s built-in RS-232C port.
• Connect to the peripheral port through a CS1W-CN118 Connecting Cable.
• Connect to the RS-232C port (port 1) on a Serial Communications Board.

It sounds like the  PLC Settings are not set in the PLC. See the following manual on Page 45. " PC Setup Settings "

Have you tried lowing the baud rate in order to see if communication errors still exist? 
What are your communication settings?


Share this post

Link to post
Share on other sites

Thanks for the reply Garry


Connecting the PLC to the PT unit via the built-in RS-232C port

I agree it sounds like PLC settings are not set, would these settings not have transferred over with the program?

Yes i played around with the baud rate changing the setting at both PT and CPU

Communication mode - Host Link mode

Baud rate - Set the same speed as set at the NT21

Stop bits -  2 stop bits

Parity - Even

Data length - ASCII 7 bits

Unit #00



Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now