Sign in to follow this  
Followers 0

Axis error Error: No device is assined to the required item

3 posts in this topic


I wanted to run an SMC linear actuator and found this error in axis settings: No device is assigned to the required item.

More strange is that I checked one of my old programs in which I ran a Fastech motor (with Ezi driver) by Omron Nj501 series. Everything is OK and the system works. But, If I change "output device 1" in "axis basic settings" to "<not Assigned>" then re-select again my Ezi driver it does not work and I get the same error message. I checked everything. There is no change in the axis settings. 



Share this post

Link to post
Share on other sites

Expand the options under Detailed settings and match up the settings the controller is expecting to see with the settings in the drive.  You need to do this when adding third party devices.  it is usually pretty easy to figure out which objects need to be matched together.

Here is an example with a Parker drive:

This is the state you are in (I showed the expanded detailed settings)


As you can see, the ones that are no good are highlighted with RED exclamation points.

This is the corrected setup:


As you can see, the choices are pretty obvious.  

1 person likes this

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0