Sign in to follow this  
Followers 0
_mmel

Unable to conect to PLC

8 posts in this topic

Good day members of MrPLC.

I am facing a connection problem to PLC with my personal laptop.

error : Unable to connect to PLC

If i use my work latop i am able to connect it through Direct Online and/or Work Online

I am connecting via USB and my software is CX-Programmer V9.5

Any advise ok this? 

 

Thanks in advance

Share this post


Link to post
Share on other sites

Hi

Check if you have installed the right USB drivers in your personal laptop. You can find them into C:\Program Files (x86)\OMRON\Drivers\USB.

 

Share this post


Link to post
Share on other sites

Another thing to check would be in cx-programmer go to PLC>Change Communication Settings>and change to whatever communication method you are using

We had it before where the plc program was set on ethernetIP and one on computer was USB, and it didn't want to connect

Share this post


Link to post
Share on other sites
6 hours ago, _mmel said:

Good day members of MrPLC.

I am facing a connection problem to PLC with my personal laptop.

error : Unable to connect to PLC

If i use my work latop i am able to connect it through Direct Online and/or Work Online

I am connecting via USB and my software is CX-Programmer V9.5

Any advise ok this? 

 

Thanks in advance

We need way more information than this.  What PLC are you connecting to?  How are you connecting? (USB, serial, Ethernet, other)  

Share this post


Link to post
Share on other sites
On 08/05/2020 at 11:40 PM, Michael Walsh said:

We need way more information than this.  What PLC are you connecting to?  How are you connecting? (USB, serial, Ethernet, other)  

Hi. Firstly thank you for the response. I am connecting it thru USB, and it's the CJ series which uses cx-programmer v9.5

 

Share this post


Link to post
Share on other sites
On 08/05/2020 at 7:24 PM, MartyB said:

Another thing to check would be in cx-programmer go to PLC>Change Communication Settings>and change to whatever communication method you are using

We had it before where the plc program was set on ethernetIP and one on computer was USB, and it didn't want to connect

Hi. Thank you for the response.. Yes, I did this as well but still couldn't connect... 

Share this post


Link to post
Share on other sites

Posted (edited)

If everything is Ok, then change USB cable and check it. Sometimes if the cable is too old or any other cabling issue then this problem may occur

Also try by changing the USB port in the laptop

Edited by Abdul Wajid

Share this post


Link to post
Share on other sites

-Do you have another plc you could test connecting to?

-go to device manager and see if com port is showing anything connected.

-if you do have another plc then you can test if the issue is on plc side or laptop side.

-If you don't have another plc then test the USB port on laptop (insert usb drive, see if opens/shows), I assume your cable is USB type A to USB type B which you can test on anything that uses one (printers usually do). Or look up cable pinout and use multimeter.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0