Raltru

NS5 HMI Connection Problem

16 posts in this topic

Hi!

I am trying to connect OMRON PLC CP1L with NS5 HMI.

PLC: 192.168.81.10

HMI: 192.168.81.11

HMI shows all time this msg:

Quote

Communication error detected while writing the System Memory Area.

Allocantion Host: ETH

MRES=05. SRES=01

Any idea?

 

Thanks =)

Share this post


Link to post
Share on other sites

See Below

MRES5_SRES1.jpg

Share this post


Link to post
Share on other sites

I have read that error table. But I am little lost... How can i set the destination address on the routing table?

I am in that point now.

HMI NS5 config:

IP: 192.168.81.11

Network address: 1 (I cant put 0)

Node Address: 11

 

PLC CP1L config:

IP: 192.168.81.10

Network address: 0

Node Address: 10

 

On HMI I can't set Network address as 0, min value is 1.

I am having problems changing the network address from 1 to 0 on PLC because If I change it cant connect to PLC

 

Share this post


Link to post
Share on other sites

What is the complete part number of your plc?

Share this post


Link to post
Share on other sites

I've been told many times that these various settings can be made with CX Programmer and CX Designer. I haven't had any luck doing it and further more, Omron tech support had trouble helping me. They ended up making this document for me using CX Integrator.

 

Share this post


Link to post
Share on other sites
39 minutes ago, Vuongtran1979 said:

I’m new and don’t know yet making a new post, sorry for any inconvenience. Can anyone help me this issue?:  My Omron HMI NS10 now show connecting, can not change IP address for it and I don’t know how to restore factory. Thanks 

You can view and change the IP address from the system screen on the NS HMI

1 person likes this

Share this post


Link to post
Share on other sites

But now my screen now show only “ connecting “. I can not restore it to original to see that option

Share this post


Link to post
Share on other sites
2 hours ago, photovoltaic said:

You can view and change the IP address from the system screen on the NS HMI

Now I only see “connecting “ word on bottom right, I can not restore to original or reset factory 

Share this post


Link to post
Share on other sites

You can access the system screen from the 'connecting' page. Press the top left and bottom right corners at the same time the from the system screen select the Comm. tab then next to Ethernet near the bottom press the enable button and your IP and subnet etc. is displayed.

1 person likes this

Share this post


Link to post
Share on other sites

If you can upload a copy of the HMI project running on the screen and share it on here we can better assist you.

Share this post


Link to post
Share on other sites

Posted (edited)

8 hours ago, photovoltaic said:

You can view and change the IP address from the system screen on the NS HMI

Now I only see “connecting “ word on bottom right, I can not restore to original or reset factory 

 

3 hours ago, photovoltaic said:

If you can upload a copy of the HMI project running on the screen and share it on here we can better assist you.

Connectino,

image.jpg

Edited by Vuongtran1979

Share this post


Link to post
Share on other sites

Posted (edited)

On 4/8/2022 at 10:01 AM, photovoltaic said:

You can view and change the IP address from the system screen on the NS HMI

I press as the same time and it work. I can change IP. Thanks all. 
but after I download it show connecting without showing my design on screen.

can people show me how to download by Ethernet cable, I adjust them the same IP address but nothing happened, usb is ok

Edited by Vuongtran1979

Share this post


Link to post
Share on other sites

You can go to select ethernet as the transfer method by going to PT -> Transfer -> Transfer Setting

From the dropdown list select ethernet then click on Set and setup the PT address etc.

Your PC will need to have a static IP on the same subnet as the HMI

1 person likes this

Share this post


Link to post
Share on other sites

I'm assuming you are trying to connect the NS10 to a PLC, correct?

Are you trying to connect via FINS or EtherNet/IP? With FINS, make sure your Network Address and Node Address are correct as well. Node Address is typically the last octet of the IP address.

On 4/9/2022 at 11:03 AM, Vuongtran1979 said:

can people show me how to download by Ethernet cable, I adjust them the same IP address but nothing happened, usb is ok

Downloading the program to the NS will be the same with either connection. 

Share this post


Link to post
Share on other sites

I use Ethernet. I connect Hmi to laptop. I set IP with same subnet mask, status ip but now when I press transfer to pt nothing happen on the screen, I didn’t see any transfer signal on screen, when I ping between laptop and Hmi, they recognized each other, they reply but no signal on screen 

Share this post


Link to post
Share on other sites

As was requested earlier in the thread, post your PLC and HMI code.  You can take all of the actual code out of each (CX-Programmer and CX-Designer files), but be sure to leave the settings.  Make sure to get the folder that is the same name as the .ipp file for your HMI program and zip them in a file together.

For instance:

If your file name is NewProject.IPP, make sure to also include the folder located in the same directory called NewProject.  

For CX-Programmer, only the .cxp file is needed.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now