Trouble connecting from PC to CP1H-XA

4 posts in this topic

Hi all,

I am having some trouble communicated with a Omron CP1H PLC from CX Programmer.  The CP1H itself comes with two option boards (CP1W-CIF01) to allow for communications via RS232.  The PLC also has standard USB access.

When I connect my PC (Windows Server and Windows 10) to the PLC via USB connection I am able to communicate successfully.  The only caveats are:

  1. The PLC program appears to be read protected (not related to USB I assume!)
  2. The system which I want to integrate the PLC with, Kepware Server, does not appear to support OMRON usb communications.

Kepware Server does have support for connections over serial or ethernet so I am looking to make a connection via RS232.

After some digging I realised the RS232 cable needed to connect the PLC to a PC is not your standard cable.  I purchased the XW2Z-200S-CV RS232 cable and tried it in both option boards but CX Programmer is not able to make a connection.

I used the auto-online, serial port sniffer and manual configuration.  I must have cycled through all possible combinations of settings several times but no joy. I can see an led light on the option boards flicker when CX Programmer is attempting to connect so it appears that something might be happening.  One of the option boards is already occupied by another device (which is working) btw.  I did unplug that device and tried my own cable, again, no success!

I also double checked the cable itself to make sure the wiring was working correctly, it appears to be fine.

So my question is, does anyone know why the RS232 method is not working?  Are there any options and settings I need to check?  Perhaps I'm missing something obvious.



Share this post

Link to post
Share on other sites

+1 Bits N Bytes

Are you using a USB to Serial from the computer and then the cable into the PLC? If so then not all USB to serial cables will work. I have had success with the Ugreen cable.
This link will take you through the process of communicating serially to the CP1H. (RS485) It will be similar. 


1 person likes this

Share this post

Link to post
Share on other sites

Thanks all for the replies.

I had tried both DIP switches on 4 and 5 previously but I decided to check again.  It worked this time!!  When I was previously checking I had been targeting COM1 on the server.  The RS232 cable was actually accessible over COM2 :doh:

So the combination of settings which works for me are COM2 and DIP 4/5 in the ON position.  I'm still not sure why OFF doesn't work, I thought the cable and software supported this also??  

Anyway communications are now sorted.  I just need to find a way to deal with the read protection and interact with the symbols/tags... but that's a separate issue.

Thanks again. 

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now