OMRON CJ2M-SCU32- RS485 Connection to gyro compass

5 posts in this topic

hi all, 

I am using SCU32 ( unit1, port2, 2wire and termination OFF)  to get the RS485 data strings from the compass with setting 19200bps, 8 databit, 1 stop bit &  No parity.

I can send the TX string ( 01 03 00 01 00 03 54 0B)  from D100 memory and  write the Rx data to D2000 (01 03 06 xx xx yy yy zz zz CC CC).

But the whenever the there is no RX data, The TXdata bounce back to RX. (refer to video, d100 is TX, D2000 is RX).

I also tried wth SCU32 termination resistance ON. Same thing.

I am not sure what is missing. Should i use different logical Port for TX and RX ? 



Just tried another scenarios

 1) removed the connector and tried , D2000 - was written the TX values

 2) Disable the RX  changing  LD from P_On to P_Off. D2000 - was written to #0000 0000 0000 0000 

I am not sure what is  happening., Open connection also TX data bounce back to RX


Appreciate all help

Thanks a lot 






Edited by T J SHARON

Share this post

Link to post
Share on other sites

Just noticed that 'No protocol; doesn't work with 2 wire connection.

So i will try to use cx protocol

Share this post

Link to post
Share on other sites

You shouldn't split threads, because people won't see both.

I don't know what cx protocol is, but some RS-485 devices need physical jumpering for half duplex operation - where the Tx negative is jumpered to Rx negative, Tx positive is jumpered to Rx positive.


Share this post

Link to post
Share on other sites

I would try turning off CTS control (Port 2 settings)
I have no idea what 1:N protocol is, do you?

Given how close it is to Modbus, can you try Modbus RTU protocol?

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now