Unknown extended error code

3 posts in this topic

Hello everyone, I'm currently trying to communicate  via ethernet with a Parker drive IPA15-HC. I'm using a 5069-L306ER CompactLogix 5380, revision 30.011. There are add-on instructions that allow you to control the drive, but since they're really basic I'm trying to use message instructions to get more data out of it.  The knowledge base provides a zip named IPA_AOI_Rev4, that includes the add-on instructions and the program you should download to the drive to use them, this is the current file downloaded in the drive. Now, I've tried different msg configurations: CIP Data table read, CIP Data table write, CIP Generic copying the values in the examples and I always get the same: 

Error Code: 16#0001

Extended Error Code: 16#0000_0125

That extended error code is nowhere to be found, not in the Logix designer online help and not in rockwell's knowledge base. Any idea?

cip read.PNG

cip generic.PNG

Share this post

Link to post
Share on other sites

Your pictures are indicating a connection failure.  You need to check and properly configure the Communications path for IPA1.

In IPS_MSG_3, you indicate that you want to read from P12290 (assuming this is a parameter number in the Parker, then you also ask for 3 elements.  Your destination shows a single tag READINMOTION, this tag might need to be configured as an array with length of 3, then change the destination to READINMOTION[0].

In IPS_MSG_2, is the source an actual tag in the Parker?  You then define it's length as 16 bytes but how is Msg_cip defined.  These must match in size and datatype.

Needless to say, the Parker manual should have examples of MSG configuration to poll various data from the servo.  Additionally, it will have tables for each parameter along with the correct Service Code, Instance, Class and Attribute settings.

1 person likes this

Share this post

Link to post
Share on other sites

Hello there, problem solved! Yes, as you said, the elements I was asking for didn't match, that was one problem. The other one was on the Communication options, I had to uncheck the Connected box. CIP data table read and CIP data table write are working fine, haven't tried CIP Generic yet.

Thank you!

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now