3 posts in this topic

I am using rslinx in my configuration with 2 devices: windows xp computer and an SLC 5/05 CPU.  The XP PC is running a program that relies on a file that is automatically dropped in a shared folder from a separate networked PC.  The file is deleted immediately from the shared folder.  The program on the XP PC uses rslinx to control the SLC 5/05 CPU to complete the operation.  The original XP PC hard drive failed and a new PC was installed with all the necessary software and services.  Ounce I completed the  setup, the process worked for 48 hours, then stuck in one operation (one file).  Now, I can restart rslinx and the software and the process will function normally, but stall, then get stuck on one file.  There are no files in the shared folder, rslinks has not lost connection.  The original router was replaced at the same time as the PC.  I am leaning towards rslinx storing the files somewhere and stalling/stopping the operation.  I can not find files anywhere.  Does the SLC 5/05 CPU store the files?  I'm lost.  Do you have any troubleshooting suggestions?  

Share this post

Link to post
Share on other sites

For the life of me, I cannot understand the topology of this control system you have described.  But it sounds very interesting.  Can you explain the normal operation in more detail?

When the XP PC hard drive was replaced, and the operating system was installed, did they install the same 32-bit XP OS, or did they install a 64-bit XP OS?  

Did someone document the software and versions of the previous build and build exactly to suit, or did they use what versions they could find?

RS Linx is the communication layer of most A-B software products, it is the glue between the hardware layer software (RSLogix or Studio5000) and the hardware (PLCs, HMIs).

From your description, I cannot state where the problem lies...within the network or the Windows XP PC.  Have you tried looking at the XP OS Error Reporting?  XP does a good job of documenting when processes take a dump.

Share this post

Link to post
Share on other sites

I appreciate the response.  If you haven't figured it out, I'm just a hack of all trades in this problem.  The OEM has given up and nobody can wrap their head around the problem.  I'll do my best to include all normal operation information:

This is a CNC glass "cutting" and "breaking".  There are (2) pieces of equipment (cutter and breaker bar), and (2) PCs (MMC and Byline).  The cutter PC (MMC) automatically looks on a network drive for the next "cut file" in the sequence.  The cut file represents one "sheet" of glass.  The software on the MMC uses the file to cut (no problem there).  It also drops a file in a shared folder (autospl), which is located on the Byline PC, through a router.  This file immediately disappears so that the folder remains empty.  The Byline PC software sends the instruction to the SLC 5/50 via RSLINX.  The breaker bar/belts read switches/encoder make up the configuration of the breaker bar process.  After the sheet is cut, it advances via conveyor to the breaker bar.  The breaker bar performs its process which is lining up the cut lines to the breaker bar, pausing, lifting the breaker bar and breaking it on the cut line.  

A fresh start produces good results up to as man as 50+ sheets at times, but the process eventually freezes up.  So, when it freezes on sheet 60 "break", the process occurs correctly for sheet 60 from that point forward, but the breaks wont be oriented correctly since the breaks vary from sheet to sheet.  There is not a stopping of equipment.  Only a failure to let go of the previous break instruction and run the next in sequence. 


I'm guessing the instruction is sent to the SLC and are held in order there until the finished instruction is dropped and the next is added.  So, maybe 2-3 sets of instruction under normal running conditions. 

It is very difficult to explain because of the amount of information I have gathered that leads me to targeting one process over the other.  I do know that once the freeze occurs, the SLC still has the next 2 sheets in sequence without receiving it from the MMC to the Byline PC.

I will look at the OS reporting.  Thanks for that suggestion.

All help is greatly appreciated!

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now