Lotus Elise

Sysmac delta robot palletizing

9 posts in this topic

I have looked through the manual for Sysmac, but I can´t see how I should do a palletizing with a 3 armed delta robot on a conveyor.

Can someone point me in the right direction?...a functionblock would be nice.

I cant see how I move on after MC_LinearSync?!

Share this post


Link to post
Share on other sites

By that question I assumed all others are completed (Kinematics, Axes Group, etc.)

Now onto the palletizing, algorithms went like this :

  1. You use MC_SyncLinearConveyor to grab the item on the conveyor. It's a very good FB that already implements Trapezoidal movement, and follows Conveyor movement.
  2. After you confirm that the robot already grabbed the item (via sensor or timing or whatever), you execute MC_SyncOut to move the robot up in Z-Axis. This will also remove the synchronization to conveyor movement.
  3. Afterwards you can use MC_MoveTimeAbsolute to move the robot on it's palletizing position. This typically need two movement, one is to move the robot on the top of place position, and the next one is to move the robot down on Z-axis.
  4. Move the robot back up with the same FB, then repeat from 1.

 

Another approach that I use often is to use MC_SyncLinearConveyor eventhough the place location is static. The reason is because it implements Trapezoidal movement automatically, compared to MC_MoveTimeAbsolute which requires you to execute two different FB in succession and using a Buffering Mode.

I usually created a Virtual Encoder Axis whose position stays at 0, to help place part of the MC_SyncLinearConveyor.

Share this post


Link to post
Share on other sites

I using NJ501-4300 to control a SCARA RRP+R Robot with ball-spline design.

I use Function Block "MC_RobotJog" to jog the Rz axis, Z axis and Rz axis turn together.

When Jog z axis, only z axis are turning.

Any solution?

 

Share this post


Link to post
Share on other sites

Don't know what you are saying here.  RobotJog is meant to only move one axis at a time.  There are a dozen other commands that are meant to move the entire robot.

1 person likes this

Share this post


Link to post
Share on other sites

Thanks reply.

Initially, i measure  mechanical position for robot z axis's about 0mm and Rz axis at 0 degree.

After that, i jog positive the robot at Rz axis with "MC_RobotJog" command with 180 degree, i measure again mechanical position robot z axis's about 10mm (wrong) and Rz axis at 180 degree (correct).

I try again using "MC_MoveTimeAbsolute" by Robot X=400mm, Y=100mm, Z=0mm, and R=0degree at initial position.

Then i command "MC_MoveTimeAbsolute" with Robot X=400mm, Y=100mm, Z=0mm, and R=180degree position.

i found that mechanical position for robot z axis's increase 10mm (wrong) and Rz axis at 180 degree (correct).

Sorry, i dont know why i can't attach any picture/video for better explanation.

Share this post


Link to post
Share on other sites

I've never seen such a behavior on my robot.  When I rotate Rz the only motor that moves is the center one for rotation.  The other 3 would have to move to make a change in the Z height.

1 person likes this

Share this post


Link to post
Share on other sites

Yes, the Omron delta robots.

Share this post


Link to post
Share on other sites

Thanks for reply.

I also successfully develop delta robot without any issue, 

But, i faced the mentioned issue above when develop SCARA RRP+R Robot..

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now