Sign in to follow this  
Followers 0

RSLogix Emulate Troubles

1 post in this topic

Good evening everyone.


I just recently tried to get into the whole RSLogix Emulate 5000 setup, for training purposes and setup.
In our AB Software directory I found and installer for RSLogix Emulate 5000 (which was located in the installer directory of 21.03.01 Firmware support. I’m not sure if I installed it correctly, but it wasn’t part of the installer, as it had Its own installer which I ran and received following error:


Running setup.exe:

The files for installation requirement Rockwell Automation Driver Package x64 could not be found. The installation will now stop. This is probably due to a failed, or canceled download.


Running RSEmulate 500.msi:

1.       A severe error occurred while using our EDS services component. Contact Rockwell Automation Support for Assistance.


After clicking OK, the installation continues nevertheless, but throws the following error:

2.       RegOpenKeyEx-1 failed. (Window Titlebar reads C:\Windows\ Installer\MSIC5F8.tmp)


However, the installation continues and doesn’t fault out, but when I try to start the emulator I get:

Unable to read Virtual Backplane status. Please make sure that RSLinx Classic is installed and the Virtual Backplane driver is running. Click OK to terminate the Chassis Monitor.


I do have RSLinx Classics installed (Revision 3.90.00 CPR 9 SR 9) and running with the mentioned driver.

However I also do know that the manual of the emulator reads that it can not be installed on a PC where SofLogix5800 controller is installed.


Looking ath the Installed Controller Support I see that SoftLogix5800 support is enabled by my RSLogix 5000 install, I just don’t know how to uninstall it, or if that is the reason, why my Emulator doesn’t install & run properly.


I unfortunately can not afford Rockwell Support, otherwise I would call there to find answers.



Please advise of what else I could try.

Backplane error.png

Installed Firmware support.png

RSLinx Driver.png

setup error 1.PNG

setup error 2.PNG

setup error 3.PNG


Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0