Unable to save due to CTree Error - RSLogix 5000

2 posts in this topic

Hi everyone,

First time posting here, sorry if I screwed up any rules on this forum.

I have a logic file that was created two years ago. I'm using RSLogix 5000 version 20.04. The customer has owned it for two years, and I just got the latest copy back from them to do a kit.

So when I go to save my changes (offline), I get "Failed to save the project as 'filepath'. An unexpected CTree error occurred." Error 753-80042211. (see attached screenshot)

I tried searching this error on google, with no results. I went to the help dialog box, which wasn't helpful. (See second attached screenshot)

I can't think of anything else to do, my boss is gone until two weeks from now, the other guy in my department has less experience than me.


Can anyone think of a way to fix this? Otherwise I'm completely stuck. Don't think my boss will be happy with me getting nothing done for a week.


The help file says:

Error saving the project to a different file

An attempt to save the project to a different file failed. The error message you receive indicates one of the following conditions:

Name is badly formed

The name does not follow the IEC-1131 Name standard.

Enter an IEC-1131 compliant name.

>>> I tried the name "test" with no success

Access denied

If the file already exists, make sure that you have read/write privileges to it.

>>> It is not set to read only or anything of that sort

In use by another process

The file is being edited by another process. Close the file in the other process if you want to save over it.

>>> Tried making a copy to my local drive, opened that one, still won't save

Path doesn't exist

Make sure that the path exists. If you are saving to a network drive, make sure that you are still connected to it. If you are not connected to the drive, you can save to another drive to preserve any work in progress.

>>> Tried making a copy to my local drive, opened that one, still won't save


Not enough disk space

Free-up space on the drive you tried to save to, or choose another drive.

Note: RSLogix 5000 cannot save a project to a drive with less than 2M of available space, regardless of how small the project file size.

>>> There's way more than enough space for this file



Edited by Foundries_Controls

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now