CP1E host link communication via serial port gives IC error code for Timer SV Read

28 posts in this topic

They were supported but not all the functions of the latest firmware version. I was thinking about the CP1L-E series. I would still strongly suggest updating your software to the latest version.



Share this post

Link to post
Share on other sites
On 2/3/2016 at 4:39 PM, S2N1992 said:


    I'm trying to communicate Omron CP1E unit with PC via serial port using hostlink protocol.  I need to read the Timer/Counter SV value and write the timer/counter SV values to the PLC.  I'm able to use other C mode commands (like RC (timer/counter PV read), WC (timer/counter PV write) etc.) but when I give the command for Timer/Counter SV Read 1 which is R#, I get the response as IC (Undefined Command).   How do I write or read the timer SV Values? 

Example command and response :

@00R#TIMH001028*  (TIMH is the high speed timer, 0010 is the timer number and 28 is the FCS)



Is is that CP1E doesn't support these commands? If so what is the equivalent command that I should send inorder to perform this?

Please help.


Hi all, i am require to control my PLC from a pc software which i can read and write the DM and contact on CP1E. I need to know the command to send to my CP1E. 
And according to this post. May I know which manual is able to guide me on the instruction as the post like @00R#TIMH001028* 

I keep searching in the internet but cant get any manual which showing this. 


Share this post

Link to post
Share on other sites
On 2/4/2016 at 10:45 AM, Michael Walsh said:

I was referring to the fact that I issued the @00R#TIMH001028*<0D> command when the timer was a TIMX timer.  When I change the timer to TIMHX, it worked just fine.

I also tried @00R#TIM 001028*<0D> (with the space) and I received this response as well:  @00R#1636*<0D>.  When I changed the timer from TIMHX to TIMX, this command then worked:  @00R#TIM 001028*<0D>.

I did not try it with straight TIM and TIMX (BCD) timers. 

To summarize:  I tried both the TIMH and TIM(space) host link commands.  When a the timer existed for that number of the proper type (TIMHX and TIMX respectively), I received a valid response.  When I changed the timer in the PLC to the wrong type (TIMX and TIMHX respectively), I received the 16 error response.  I did not try with the BCD versions of the instructions (TIMH and TIM respectively).


Did you see this post by Michael Walsh?

What does your timer look like in ladder?

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now