Sign in to follow this  
Followers 0
digispark

OMFINS3 Citect #BAD Data

22 posts in this topic

Hi All, I got a CS1H-67H CPU with EIP21 card setup. I'm having trouble for Citect SCADA 7.20 SP3 to talk to the PLC. I keep getting a "I/O Device offline, cannot talk" error. Both PLC and SCADA PC are on same network switch, that's all it is between them at the moment. OMRON EIP21 IP: 10.10.0.10 Unit number: 12 Citect SCADA Primary Server IP: 10.10.0.1 Secondary Server IP: 10.10.0.2 Citect.INI [OMFINS] Source = 0/1/12 (not too sure what this should be...) COMMUNICATION settings: [bOARD] Name: OMRON_BOARD Board Type: TCPIP Address: 0 [PORTS] Name: OMRON_PORT Board name: OMRON_BOARD Special Opt: -I10.10.0.10 -P9600 -U [i/O DEVICES] Name: OMRON_PLC Address: 0/10/12/S Protocol: OMFINS3 Port Name: OMRON_PORT Startup Mode: Primary Tried many times with different I/O device settings: 1/10/12/S and 0/10/12/S doesn't seem to work. Am I missing some other configuration at PLC side to make it talk to Citect? Thanks! Edited by digispark

Share this post


Link to post
Share on other sites
Nothing to do with the PLC - only the driver. Just going to bed and many hours away to a job in the morning - will have a look when I get back tomorrow for you. Have several systems on EIP with Citect/Omron. I/O device offline is a comm fault - the switch is irrevelant - the problem is in your setup in Citect. Do not use Omfins driver - use FINS driver - Omfins is old and simple. Type 3 is for the latest PLCs - CJ1, CJ2, CJ1, CP1 and CS1 - lets you read W words etc.

Share this post


Link to post
Share on other sites
Your citect.ini file for the primary server should be [OMFINS] source = 0/1/0 and your standby server [OMFINS] source = 0/2/0 Assuming that there is no routing table set up in the plc. This is from the citect knowledge base. Hope this helps.

Share this post


Link to post
Share on other sites
Hi chelton, There is no routing table setup in the plc. I tried setting primary server to 0/1/0 ... no luck, still same 'cannot talk' error. Secondary server is offline as I only have one citect development licence right now.

Share this post


Link to post
Share on other sites
My mistake, The Omfins network starts with network 1 so. Your citect.ini file for the primary server should be [OMFINS] source = 1/1/0 and the IO device address would be 1/10/12/S

Share this post


Link to post
Share on other sites
Very strange. That didn't work either. Kinda running out of clues now.

Share this post


Link to post
Share on other sites
Have you tried connecting with CX-Prog using the ethernet or ethernet(fins/tcp) driver to ensure your eip21 card is configured correctly? Also the unit number is the unit number of the cpu not the eip21. so the address 1/10/12/S is the /12 the unit number of the cpu? Edited by chelton

Share this post


Link to post
Share on other sites
Hi, Did you activate TCPIP=1? over [LAN] And add: [OMFINS] IgnoreNonFatalError = 1 Melin

Share this post


Link to post
Share on other sites
Yeah [LAN] TCPIP = 1 is already there. Tried IgnoreNonFatalError = 1, no luck either.

Share this post


Link to post
Share on other sites
What errors do you see in the kernel? Can you post a screen shot of your driver and io/device windows when you test the project? I've used the omfins3 driver in my last few projects and have had no problems. only minor tweaks in the citect.ini file to stop any errors showing . @BobB Do you supply and install fins-gateway on all your new projects?

Share this post


Link to post
Share on other sites
@Chelton Can you confirm that you have Citect working with the EIP21 card and not the ETN21? Driver help only mentions ETN21. I assume the CPU unit would always be 0. And local network is network 0. It is clear that the IO device address should be 0/10/0/S. Do the port settings look OK to you? The only part that is unclear to me is if the -U is required. @BobB I also had the same question for BobB. I thought the OMFINS driver was the Newer, and also saves an extra licence for the SYSMAC Gateway. I am sure you have yor reasons for using FINS over OMFINS. I would like to hear them.

Share this post


Link to post
Share on other sites
FINS is newer although OMFINS may have been brought up to date I do not know. I use Sysmac (or FINS) Gateway as it allows me to mix networks - Ethernet - Controller Link - RS422 - great when older jobs are being updated. Also allows routing tables. I also have some Omron Sysmac Link stuff out there as well. O(MFINS was developed by Citect many years ago - the original FINS driver was developed about 1997 - I was one of the guinea pigs for it on a job. It was developed for Citect by a contractor - it was great for a few I/O - I had thousands and it was terrible. Citect have since taken in house and re-wrote a lot of it to where it works very well - even with mixed networks on the Omron side through FINS/Sysmac Gateway.

Share this post


Link to post
Share on other sites
[sOLUTION] OK, I got this working. :) Problem lies with Omron setup and SCADA driver. In order for Citect to talk OMFINS with PLC, you must set the EIP card FINS network to anything but local network 0. So if you set the card as local FINS network 1, and use 1/10/0/S in Citect, it works. Thanks for the help guys.

Share this post


Link to post
Share on other sites
@The Fat Controller I have not used the eip21 card yet. But I have successfully used the omfins3 driver on CP1's with a CP1W-CIF41 or CP1W-MODTCP61, and on CJ2M's using onboard ethernet/ip module, and from what I understand the EIP21 card is the same as the built in Ethernet/IP except it has a far greater data link capacity 180,000 words, compared with 640 words.

Share this post


Link to post
Share on other sites
@digispark Glad you got it working. Whenever I use the OMFINS driver with the default setting I get an error, as shown below. To rectify this I increase the [OMFINS]Delay=0 in the citect.ini.

Share this post


Link to post
Share on other sites
Dear experts! I have prolem communication CJ2M CPU33 with citect PC: 192.168.1.100 PLC:192.168.1.10 unit 0 Board: ICPIP adress 1/10/0 Port:-I192.168.1.10 -P9600 -U IO device: OMFINS3 Citect.ini 1/100/0 Please give me advice how to fix this prolem. thank expert 111.bmp

Share this post


Link to post
Share on other sites
Have you set the fins network address to "1" on the cj2? From memory the default network address is 0 and this did not work with the OMFINS driver. The FINS network is set when with the routing table editor. I'm not in front of a PC to show an example.

Share this post


Link to post
Share on other sites
Chelton - I always use FINS Gateway - leaves me a lot more options with respect to configuration and the FINS driver in Citect I find more reliable than OMFINS. Unless they have changed OMFINS W areas and the like are not available to Citect.

Share this post


Link to post
Share on other sites
Bob, I'm not sure when the omfins driver was updated but it does support W areas and bit addressing of D memory. All the same areas as the FINS driver
1 person likes this

Share this post


Link to post
Share on other sites
Bonus Chelton.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0